SL2 does not save Background color.

Dec 05, 2014

Hi all,

I face one issue in storyline 2.
I create one new project & change the background color (in Home -> Player setting ->colors & effects ->Background color) & check publish output ; That time i get my custom background colour(shown in Img01) but when i close my entire SL2 file & re-open it and again publish my project that time i found storyline set default background colour i.e. white.(shown in Img02)

Please let me know any one else is having this issue.
so how i can set custom background colour for my project?
whenever i publish my output I want my custom background colour?

Img01

Img02

 

Thanks ,

Akash

9 Replies
Akash Jambhorkar

Hi Wendy,

Whenever i re-open storyline file for publish every time need to follow  below two step's:- 

STEP 01:- Click on publish option

 then open below pop up window

 

STEP 02:-Then click on storyline player option in above img 

then open below pop up window 

And just click on OK button without make any change & publish course then it will take custom background color again.

But whenever i open story line file for publish its need to follow above steps other wise if i open storyline file & without open storyline player option (2nd step) directly go for publish (click on publish button on step 1) storyline set there default background color.

 

 

Akash Jambhorkar

Hi Ashley,

When you close & Re-Open story file then you go for directly publish or you click on player: Storyline player option?
Because I face this problem when I go for publish without click on storyline player option.

Here below i attached my demo storyline file & Set Background color RED :-
When i reopen this file i follow below steps Please check it out:-

STEP 01:-CLICK ON PUBLISH Then

 

STEP 02:- CLICK ON PUBLISH BUTTON   (Please don't click on storyline player option)

 

After publish please check background color.

 

 

Ashley Terwilliger-Pollard

Hi Chris,

Our team has continued to look into this, and documented some known issues with the page background color here:

If you change the page background color in your course player to something other than white, you may find that it's still white when you publish your course.

This is a known issue that can occur after closing and reopening a project file. It'll be fixed in the next software update for Articulate Storyline. In the meantime, here's how to avoid this behavior:

  1. Before you publish your course, go to the Home tab on the ribbon and click Player.
  2. When the Player Properties window opens, click Cancel to exit without making any changes.
  3. Publish your course.