SL2 - Drag and Drops Not Working in Safari on iPad

Hello,

I'm experiencing an issue when trying to test drag and drop slides in the Safari App on an iPad. The drag items cannot be interacted with, however this same slide works fine in Chrome.

Is this something that is being looked into?

 

Information: 

Storyline 2 LMS Publish

Testing in SCORM Cloud

Apply iPad Pro 9.7 inch

Safari 13 on iOS 13.3

13 Replies
Lauren Connelly

Hi Michelle!

Thank you for sharing the details of where you're noticing the drag and drop interaction error!

The good news is that it is working in Chrome, but we need to dig deeper to see why the same behavior isn't working in Safari. How did you publish the course? I know you've stated publishing for LMS, but did you choose the Articulate Mobile Player and HTML5? 

Michelle Pickering

I've selected "Include HTML5 output" but have not selected "Use Articulate Mobile Player" as this doesn't work well in my organisations LMS. 

We always recommend our users to try to only run our courses in Chrome as it is more reliable, but it would be good to know if there is anything we can do to allow our content to work as expected in both Chrome and Safari for mobile devices. 

Michelle Pickering

So when viewing the attached slides in Chrome on iOS I am able to move the Drag Items around the screen... However in Safari on iOS I cannot interact with the Drag items at all. 

I have tested the drag and drop slides in multiple courses/Storyline publish files and none of them have worked properly in Safari. 

Ren Gomez

Hi Michelle,

Thanks for following up on this. I'm sorry that you're running into issues playing courses on an iPad. We have reported it to our team for Storyline 360, and it seems the same problem is popping up for Storyline 2.

We're working through this, and I'll pop back in here to let you know as soon as I have an update. Thanks again for bringing this up!

Vincent Scoma

Hi Michelle,

I wanted to share that we just released Update 34 for Storyline 360, which addresses the issue with these interactions on iPadOS 13. Here is where you can find all of the enhancements for Update 34.

I do want to mention that this isn't fixed for Storyline 2. With the vast majority of customers using Articulate 360, this is where we have shifted our focus. We will also continue to deliver periodic updates to Storyline 3.

If you haven't already, I would encourage you to give Articulate 360 a try! You can access the trial here. You can also import Storyline 2 courses into Storyline 360, which will keep those courses updated as the sunsetting of Flash approaches.

Please let us know if you have any questions! 

Vincent Scoma

Hi Nataliya,

Thank you for reaching out! 

May I ask what appears to be happening when learners interact with the course on their iPad? If you can, would you be able to share either a screen recording or the file for further troubleshooting?

You can share files in this thread or you’re always welcome to share them privately here. We'll let you know our findings and will delete it after having a closer look!

Nataliya Eremeeva

Hello Vicent,

In the attachment video from an employee. 

Drag and drop doesn't work at all. And we tried to republish the course in the latest version of Storyline (the course was made in 2017), but it didn't help.

Here are the models of iPads from employees who have a problem: A1895, A1896. iOS 13.3.1

Ren Gomez

Hi Nataliya,

Thanks for sharing that video of what you're experiencing. I'm sorry, but it looks like you're running into a bug we have for Storyline 360:

Drag and drop interaction is not working on an iPad when the drag objects have broken outline.

We do have it reported to our team, and we'll be sure to update you when we have a fix in place. In the meantime, if you use a shape with a solid outline, does it work correctly?

Nataliya Eremeeva

Hello!

Unfortunately, the problem is not only with objects with broken outline. In the attachment are two more examples:

The first video has a problem with the slider, which also doesn't work.
In the second video, the employee finally presses the button on the right (it's not visible), but the answer is still considered incorrect, because the employee didn't drag anything.

Lauren Connelly

Hi Nataliya!

Thank you for sharing both videos! In the drag and drop video, I can see where the answer is marked incorrect! I'd love to get another set of eyes on this project.

Are you able to privately upload your file to us? This will help us understand what the fix is. We'll test your file on our end and then update you with what we find! Here's the private upload link. Our team can sign an NDA if needed.