"Store must be open for this operation" error

Help!  I have made some changes to my story file and I have to get it published ASAP!  But every time I try to save it, I get a pop-up error box that says:  "The project file could not be saved.  Store must be open for this operation."

What store?  I've never gotten this error before and I'm up against a serious deadline.  

54 Replies
Rebecca Adler

I am having this problem on one computer only. SL2 worked fine on my desktop PC (which is currently in the repair shop). My laptop will not allow SL2 to save files. I get the "The project file could not be saved. Store must be open for this operation." I have tried all of the trouble-shooting steps up to uninstalling/reinstalling .NET and Adobe Flash Player. What's odd is that the first time I save my Storyline 2 file, it saves OK. The second time I save, I get the error message. Of course I'm on a deadline. I want to know what the uninstalling/reinstalling .NET or Flash Player will do to help fix this.

Ashley Terwilliger

Hi Rebecca,

The repair solution here is a way to provide a clean install of Storyline and remove any registry keys that could be interfering with your set up. 

When you're saving it the second time, are you able to check that you're saving to a local drive and following along with the other guidelines here in regards to your file names and paths. 

Rebecca Adler

Hi Ashley,

Thank you for working on this case.

In response to your questions:

I never use any drive other than my local hard drive for creating and publishing Storyline files. I also checked my file names and they are well under the character limit.

I did almost all of the troubleshooting steps before I even posted a support case. The only thing I did not do was the .NET uninstall/reinstall and the same with the Flash Player uninstall/reinstall. It is not clear from the troubleshooting steps on that web page exactly what those steps accomplish. Since the previous steps had done nothing to fix the problem, I was reluctant to keep going until I knew what the purpose was.

The only thing that has given me a way to save without the error was to start a new file and import all of the slides from the old file. Some information is lost when you do this, though, so not a perfect solution.

Rebecca Adler

Ashley Terwilliger

Hi Rebecca,

I also see now that you're working on a case with Jayem (# 00436771 for my reference) so once you've completed all those repair steps, which you will need to go through all of them to conduct the full repair and to see whether or not that resolves the issue you're having please let us know. If the behavior persists after that, Jayem will be able to provide some additional information in terms of looking further into your system set up. 

Rob Milne

I just ran into this same issue this Friday morning... rendering my entire morning wasted. Honestly, it seems like it's just one bug after another with Storyline... this isn't the first time a bug has cost me hours with this program. It's not just the 3 hours I've wasted, its the 3 more I have to spend redoing the same things. For such expensive software.. you'd think more time would be put into fixing how buggy this program is. I figured storyline 2 would be better. Nope. Auto-save sounded promising... didn't help me here.  

I don't need help fixing this issue... I closed my project without saving (because it wasn't letting me save)... re-opened it.. and now it seems to save fine. I just wanted to leave this comment so that hopefully your developers can see that there are serious issues to fix with their current version before they run off and create storyline 3.

Thoroughly disappointed, as usual with this program.

 

Ashley Terwilliger

Hi Rob,

Thank you for commenting here. I know that this is a frustrating bug and situation to be in, and I've shared the thread including your newest comments with our QA Team for additional information. They're continuing to look into it, and with a number of the users who commented here have shared their files and system logs to help us track down what specifically is occurring and it seems a few members of our team have recreated the behavior when inserting and editing a video.

If you haven't already you'll want to go through the repair steps detailed here, and we're happy to take a look at your set up as well if you'd like to connect with our support team. 

Brian Schuster

I have been getting this error to on my window 8 machine. It seems to happen when I have more than one Storyline 2 files open. It has happened about 3 times. Some times I need to copy slides from one Storyline to another.  This is what I used to do all the time in Storyline 1, but 2 is not liking it at all. The other two times I was waiting for one file to preview (because in Storyline 2 the preview and save takes a very long time) so I opened and began working on another file while waiting. When I tried to save, the one file it would not allow it.

Ashley Terwilliger

Hi Brian, and all,

I know that this issue persists for a number of you, and our QA team continues to investigate the issue. Since it has not be something we're able to consistently reproduce, it will be helpful to have additional users who are able to share their project files with us and once our team has a fix in place, we'll be able to provide you with a beta version to test that further and confirm that it resolves the issue you've been experiencing. If you'd like to share your files with us, please send them along to our team here and reference this thread so that they're aware of the troubleshooting steps that you've already gone through. 

Thank you for your continued patience as we work towards a fix for this. 

Anja El Kabbout

Had the same issue today with the newest upgrade installed a few days ago. Got both the 'store must be open' and 'closed stream' error messages. It was a project newly created in SL2.

I had 2 other instances of SL open which saved without  any issues, so I'm dumbfounded by what went wrong with this one project.

Worked around it by starting a new instance / new project and copying all slides from the old project that won't save into the new one. Lost some of the triggers (jump to slide xyz), but got it set up again as it was in the old project in very little time AND it saved!

So, for this time I'm save (ha ha) and thought I'd share my work around. But I surely hope that won't happen again. Would be great to get an update from the staff here when they found & fixed the error.

Ashley Terwilliger

Hi Anja,

Thanks for sharing that here - and I'm glad you were able to get your file back to a working state. I know my last post was about two weeks ago, but I don't yet have an update to share. We've shared this thread with our QA team and continue to communicate with them about the updates we see from users here, so we hope to have additional information to share soon. If you have a problematic file or can reproduce the issue please let us know by connecting with our Support engineers as that information is invaluable to our team as they continue to dig into this one. 

Ashley Terwilliger

Hi Shawn,

Our team is continuing to look into and work on fixes for this issue - but it's been a difficulty one to track down as we've been unable to replicate the issue and the users who have opened a support case aren't able to share a specific set of steps to help us replicate this issue. If you're able to share the steps you go through each time that result in this error please feel free to connect with our Support team here. 

Brandie Jenkins

I am also having issues with this and mp4 videos. It seems to happen when I add additional items (like text captions) to the timeline. I can stay on it for a little while, and it will even allow me to save it on one or two instances, but if I am on it for awhile and try to save, it eventually gives the error message.  The only solution I have found is to start a new file and copy/paste the work into a new file, so that it is not lost, and try again. It is very frustrating.

Matt Lang

This is an extremely aggravating problem and I hope there is a resolution soon. I've taken to saving after each change so that whenever the error happens I can close the file and restart and not lose too much work. But, each save takes approximately 10 seconds and all that lost time adds up. Better that than having to re-do a bunch of work, but still, *saving your file* should not be an issue!

Brandie Jenkins

I have had to give up and take the videos out of my file until all of my other edits were complete. It is very frustrating. I also noticed that assets (like backgrounds and other images) would start to disappear when I added them back in, and if I tried to reimport the slides, it did not help.  This is a government project, so I cannot share the file.  On a sidenote, the file doesn't crash without the videos, so I am assuming it is tied to those.

Matt Lang

These are the error messages I've gotten: 

The project file could not be saved. Object reference not set to an instance of an object.

The project file could not be saved. Can not access a closed Stream.

The project file could not be saved. Store must be open for this operation.

When it won't save I'll get one of those and then if I keep trying I'll get the others.

Last night though, after saving after each slide and occasionally encountering those errors and having to restart the module and re-do the slide I had just been unable to save, I got a new one: The project file could not be saved. File contains corrupted data.

There was no computer crash or anything that might have triggered this. It just all of a sudden happened when I tried to save. 

The only way out of this problem apparently is to create a new file and import from the broken file. While this did save my work to a certain degree, all the slide layouts are slightly screwed up and by the time I am done fixing all of them, it will have been roughly an 8 hr detour due to this ill-performing SL2. I am worried that I'll get nearly finished and have it happen again. If I could import into SL1, I would do it and I can assure you that I will not be using SL2 any more until this bug is fixed. I am wasting far too much time due to this bug.

While I am sure it's frustrating for Articulate, it is far more frustrating to be under a tight deadline and having to spend many extra hours due to (expensive) buggy software. That extra 8 hours I'm spending is 8 hrs out of my weekend that I would much rather be doing other things than repairing broken layouts. I would be more understanding if it was something more normal like one of the tools was broken, but something so fundamental like *saving the file* should not be broken.

Brandie Jenkins

Matt, I can so relate to the frustration of lost hours.  I am concerned about what happens when I try to put the videos back in. I plan to try to see if I can publish the videos in a smaller file size and pray that works. The sad part is I wasn't the actual developer for this project. I offered to help a customer of mine with the editing and adding in 508 compliant components. After the way this project has gone, we have made the decision to look at other software for our 508 compliant courses.