Storyline 2 crashing when trying to publish to Dropbox public folder

I just upgraded to Storyline 2 and discovered that Storyline 2 errors each time I try to publish to the Dropbox Public folder. The same files publish fine if I publish to my local drive, and I used to be able to publish to the Dropbox Public folder without any trouble in Storyline 1.

Any advice on how I can resolve this?

15 Replies
Brian Allen

Do you have Dropbox installed on your computer, so that you can publish to your public folder locally?  This is what I do and it works dependably.  If there's any other way to publish content to the dropbox public folder I'm not familiar with it.

If you're somehow trying to publish directly to a web-based or network-based location, that isn't supported in Storyline - http://www.articulate.com/support/storyline-2/create-edit-and-publish-articulate-storyline-courses-on-your-local-hard-drive

Elissa Purtell

Hi Brian,
I have Dropbox installed and am publishing (browsing to the Dropbox folder, like I would any windows folder) in exactly the same way I have always done with storyline 1, when it worked fine. The file appears to be publishing and then at the last minute it pops up with the error. I have verified the same is happening with colleagues.
Thanks.

Brian Allen

I'm running SL2, latest update, and just tested publishing to my dropbox public folder on my local hard drive and didn't see any errors, it was a successful publish.

I'm wondering if it may be something in your local environment?  Would be odd, but it's the first place I'd start troubleshooting if it were me, especially seeing as how your colleagues are able to replicate the issue but others outside your environment (like me) aren't experiencing issues.

Elissa Purtell

Hi Ashley,
Correct. I can publish fine to my desktop or to another location on my C drive.
My dropbox is installed locally – the path is: C:\Users\\Dropbox.

I used to publish all the time to dropbox from SL1 – so it seems something is working differently in SL2.

Thanks,
Elissa

Elissa Purtell

Hi Ashley
Yes, the issue is just with publishing to Dropbox. As this was not an issue and I could publish fine to Dropbox with SL1, I don't imagine it's a set up issue with Dropbox.
Do you have any suggestions of what I can check with Dropbox? I have Dropbox installed on my PC and I can navigate to the Dropbox folders from Windows Explorer, like any folders I have on my C drive.

Elissa Purtell

Problem solved!! ☺
I changed the output file to a much shorter name and it worked.
I noticed that the automatic output folder name for SL2 is longer than it was for SL1… SL2 has added “- Storyline” to the output folder name, (i.e. SL1 output was “ output”, and SL2 is “ - Storyline output”), and this difference must have pushed the file name over the limit for the number of allowed characters, so it was failing in SL2 when it didn’t in SL1.

Thank you so much for your help, Ashley!

Sarah Pouezevara

This is actually happening to me now with Storyline 2. It's not an error--the page just never loads. I've tried on two different connections so doesn't seem related to internet connectivity. If not the dropbox public folder (and i saw a message already from the community about google drives not working either), then how are you sharing draft output with colleagues, short of sending .zip files or something like that. 

Brian Allen

Dropbox still works for me, but here are some other options that may work for you. Tempshare is a really good option if you only need your content to be available for a short period of time...

https://www.articulate.com/support/storyline-2/publishing-and-sharing-articulate-storyline-content-sl2

Hope this helps,

B

Ashley Terwilliger

Hi Sarah,

I also wanted to confirm are you trying to publish direct to the Dropbox folder, or after you've published uploading to the Dropbox folder? I'd encourage the latter set up. I also use the Tempshare set up, and the first article Brian linked too also includes information about Amazon S3 which is a good hosting solution as well.