Storyline 2: Layers, Preview and Publishing Error

When previewing or publishing a project, I have run into an issue where:

  1. the layer and/or button disappear after I select the button that should trigger the layer.
  2. Other times, multiple layers will display on top of one another,
  3. Or, clicking on one of three button results in a mirror effect, ie all of the sudden six buttons appear out of nowhere.

Solution: If I close out of Storyline 2 and relaunch, all is resolved. But if I publish multiple times in a row, the issue returns. 

Has anyone else come across this issue?

Initial State

After clicking on the Sales Enters... button, it disappears:

After clicking on the Portfolio Management Button, the buttons in the bottom right hand corner display a mirror effect, and no layer is displayed.

9 Replies
Ashley Terwilliger-Pollard

Hi Chadi and welcome to Heroes! 

I'd first want to confirm that you're working on local project files as described here and publishing to a local drive as well.  You'll then want to ensure you're testing your published content within the intended environment. 

If after checking into those items, you're still having difficulty we'll want to take a look at your .story file. 

chadi El-Khoury

I have attached the .story file. You will want to click on the "Quote to Order" button, which will direct you to slide 2.2 Originate. 

I haven't been able to identify the exact steps to reproduce this issue. I have noticed that it occurs after I launch the project, work on it for a few minutes, and attempt to relaunch. Sometimes it fails, and other times it is fine. I am sorry I can't be more helpful. 

chadi El-Khoury

I was able to reproduce this issue by modifying the animation for any given object on slide 2.2. 

Steps:

  1. Publish a project, then close the published output
  2. modify the animation enterance of the effect option for any object on slide 2.2
  3. re-publish or preview project

In following these three steps, I was able to reproduce the issue. 

Ashley Terwilliger-Pollard

Hi Chadi,

Thanks for sharing the file here. I saw the behavior with the duplicate images and elements not appearing when viewing the course in the version you shared. I imported it into a new .story file and continued to play around with it - changing one animation entrance seemed to cause the file to no longer work as expected. Changing that animation element back to what it was originally allowed for some of the functionality to come back - but not all of it. I can't recreate any of this behavior in a new file - and have tried to remove individual elements on your slide one at a time to see if I could narrow down - and it seemed to happen no matter what I removed on the slide 2.2 specific to the Sales layer or the Portfolio layer caused the display issues you're seeing in the images. I tried removing all the elements there and changing the animation - and it was still causing problems. It seems to be an issue with the Sales layer and the PortfolioM layers - so at this point I think you'll need to recreate those layers.

In addition to working locally, you'll want to ensure you're file path and file name don't contain any special characters, accents, etc. and are well under the 256 character limit imposed by microsoft. 

chadi El-Khoury

Ashley,

So is this a bug? I understand that these things happen, and that I will need to recreate those layers. At the same time, I want to confirm that it isn't due to user error. I don't want to make the same mistakes, and recreating parts of the project will be time consuming.

Thank you for your help.

Ashley Terwilliger-Pollard

Hi Chadi,

I wasn't able to recreate it in a new file by applying animations and then trying to change them, so I can't say that it's a bug within Storyline. It seems to be a bug or element of corruption within the "Sales" layer that is also impacting the "PortfolioM" layer. 

Also, one of the items you might want to look at to help in terms of rebuilding is, the Portfolio layer has the same markers that are on the base layer, but they're adjusted in terms of position slightly - and so that's the image you're seeing when they show through overlapping (again, odd and based on an issue within the layers themselves). You could choose to show those individual elements from the base layer on that layer by clicking the eye next to each of them the in slide layer's timeline.