Storyline 2 not replaying

Greetings,

I published my first reusable learning object with the web option for a course I took last October in Instructional Design.  I'm coming back to it now to try and open it in Storyline 2, which I have installed on my Mac Book Pro.  I used the version with has .story as the extension, which my instructor advised was the one I published.  I know I used a link to post it to the web and play it when I was in school.  My instructor told me it should play by just opening it in Storyline but it's not converting to Storyline 2, nor is it playing.

I have searched the discussion boards to try and find information on this topic; there are variations of discussions but nothing specific to this issue.

I'm new to Storyline and would appreciate any input.  

Thanks!

25 Replies
Ashley Terwilliger

Hi Brenda and welcome to the Heroes community! 

The .story file is the pre publish file, correct - but upon opening it, the file will not play. It'll open in a mode in which you can edit it. You mentioned it's not converting to Storyline 2 - was it created in SL2 or SL1? You should see a message to "upgrade" the file if it was created in SL1 and that a back up file for SL1 will also be generated. If you're not seeing that could you tell us what occurs when you try to open it? 

If you're on a Mac, you'll also want to confirm that you're viewing the .story file within the Windows environment, with a valid install of Office, and adhering to these other guidelines. 

Brenda Armstrong

It was created in SL1.  There was no msg to upgrade the file to SL2 either... this was also something my instructor suggested would occur.  

When I use the option to play it...it opens to slide 1, but it will not play the module.

And yes- I have a valid version of Office.  I'm not sure if I am in a Shared parallels environment or not.  I'll have to go back and check.  And I saved the file to my Mac desktop.. from my external hard drive.  I guess I'll need to save it on the windows desktop, check for the shared parallels setting... I'll go back and check on all those considerations...  and see if I have any luck.

Thanks very much!

Ashley Terwilliger

Can you open Storyline 2 on it's own to start a new project file? So you're still able to open it in SL1? Or, I'm misunderstanding the "play it" element? If you're viewing the published output, you'll want to confirm that you're viewing within the intended publish environment as testing it locally could cause you to encounter security restrictions from the computer or browser. 

You'll want to check into those elements in regards to the shared profile as not working locally in the Windows environment could also cause you to have some corruption associated with the files. 

Brenda Armstrong

Yes- I can open SL 2 on it's own to start a new project file.

As far as I can tell,  I disabled the shared profile on all the options in parallels.. 

I'm using only the windows side..  and it still says 'preview- storyline player', which is what is said before.  In other words, it is doing the same thing it was before.  I resaved the file onto the windows desktop from my external hard drive...and tried to open that... 

Perhaps I am doing this incorrectly..  I wasn't inclined to press publish in SL2 because I thought that would mess with my file.  I'm trying to use preview to just view what I published previously.  I'm not sure how to 'view within the intended publish environment'.  

The file is loading into SL2...it's not resaving in SL1, nor am I able to view anything other than the slides..even after pressing preview or using the player by selecting the built in or storyline player options from the open menu...

 

 

Ashley Terwilliger

Hi Brenda,

I'm sorry  if I'm misunderstanding, but it sounds like there are a few different things going on - and in between both SL1 and SL2 so it's a bit tricky to follow. Let me try and recap what you're saying and answer - 

SL2 opens fine on it's own and you can start a brand new file. When trying to open an SL1 file, in SL2 - it opens in SL2? Do you see a message stating that it was "created in a previous version and to upgrade it?" and that a back up version of the SL1 file will be created? That file would be titled "Your File Name - SL1 Backup.story" vs. the newly upgraded SL2 file which will just retain your original file name. 

What I mean by view within the intended publish environment, is once you've published a course we don't recommend testing the content locally - as in viewing the story.html file on your local drive. You'll want to test within the intended environment as described here. 

If you've already published a file, but you're going back to the original .story file (the file that you edit prior to publishing) you should be able to Preview that using the options in the top tab from the "Home" tab. Is this the part that isn't working? What happens when you click on Preview? 

You mentioned you can't preview anything besides the slides - are there audio/video elements included that aren't working? Some things such as web objects, hyperlinks, Javascript etc. won't work in preview. 

If you're still having difficulty could you share a copy of the file so that we could get a better sense of what is occurring? 

Brenda Armstrong

SL2 opens fine... I can open a new project.

And yes- the SL1 file I developed only opens in SL2...but it will not play.  And no-there is no message on the versioning.. upgrading, or backup version.  

I see what you mean after reviewing the 'intended publish environment' section regarding where it should be played. I'll be trying Tempshare next to see if that gets me anywhere.   I've only attempted to open it in SL2.   And when I attempt to use Preview mode, it only opens slide one.  That is all it will do.

I have an embedded goanimate video in this, as well as an audio clip.  The slides do not play in the form of a short training module like a video clip...  period.  They only appear as a slide.  Neither the audio nor the goanimate clip play... only the first slide appears.  That is it.

And yes, I'll go to my laptop and share the file.  It will be attached momentarily.

 

Brenda Armstrong

So, if I take the file in my folder on my external hard drive that has the story extension, save it to the windows side desktop and attach it to this site from there, will that be the most likely option to offer a file that will work?  The zip file worked on the Tempshare site, but you presumably would want the .story file.    I believe my mac has now been configured so that it's not sharing sides with the mac side..  and if I now slide the file over to the windows side desktop and attach it, I should think that would provide a file that you could play...  correct me if I'm wrong here.  

Ashley Terwilliger

Hi Brenda,

The file you previously attached - where was that from? If that's the same file, it may be something in the file and therefore problematic with the file as a whole. 

The zipped file is the published output so we won't be able to take a look in that. If you're able to open a file with the .story extension and see the course there - regardless of if you can preview it - but if you can see all the slides and slide elements, that's the one we'll want to take a look at. 

Brenda Armstrong

The two files I've attached show the parallels icon on my windows desktop and end in .story.

I can see when I open them in SL2 that all the slides and content from my project are there..

They just won't play in SL...nor do they indicate anything about a conversion to SL1..

 

Ashley Terwilliger

Hi Brenda,

Thanks for sharing these. The first file you sent opened for me in SL2 and I was able to preview the course (with the exception of things like the web object on slide 2). The second file you sent was still a blank empty file for me with only one slide. If you're unable to Preview the course using the first file, following the directions that Leslie mentioned I'd want to have you go through the repair steps detailed here as the course itself seems to be working as expected. 

So, you'd only see the conversion information when a file was first opened in SL2, and that would create the back up version for SL1. You're not going to see this message every time. 

Brenda Armstrong

Hello Ashley and Leslie,

So, I uninstalled and then reinstalled SL2... (at least a temporary version until I obtain my serial number at home to activate the permanently installed version).  It still does not play.  I also saved it from my external hard drive onto my windows side.. and opened it from there.  

I'm not sure why I'd have to use the F12 key on my mac when that appears to be for sound.

I have attempted to play the correct file, the one containing all the content-- and still- under the preview option-- it will not play.

The repair steps indicate to uninstall and reinstall.  At this point, I'm not sure what to do given I've followed each trouble shooting step offered to me thus far.  

I'm at a loss.

Brenda

Ashley Terwilliger

Hi Brenda,

Ok - it may be easiest to continue to work on this with our Support engineers, as that way you can share a screen recording of what you're actually doing to get the file to play. You can reach out here, and please reference the steps you took in this thread (i.e. repair, working locally ,etc.) and you can include a link to this thread as well.

Also, in regards to the F12 key, it's just one of the options for previewing:

  • Press F12 on your keyboard.
  • Click the Preview button on any tab of the Storyline ribbon.
  • Click the Preview icon in the lower right corner of the Storyline window.  

Since it's also a function key within Mac, I'm not sure how this behaves in Parallels, but if you've tried the other options as well, and nothing is working, then it's a larger issue with your install of Storyline that we'll want to investigate. 

Ashley Terwilliger

Hi Brenda,

I just wanted to follow up as it looks like you and Wilbert had a screen recording and were able to work through the issues. He shared the following as recap:

STEPS TO RESOLVE: 
1) We verified that the slide is set to advance by User, thus you need to click the Next button to move to the next slide. 
2) We also discussed that by design Web objects do not play during preview. 
3) I also provided the link below with information on publishing your Storyline project.

Brenda Armstrong

Hi Ashley,

Thank you for the follow up.  That issue was resolved... however now I'm facing yet another issue.  That pertains to using dropbox.   I am trying to do this for personal use and thought by using that, it would allow me to move forward.  However this process also seems to require the use of a web administrator...  I thought I would be able to post the module into drop box... but it seems with every step of the process, I reach an impasse.  

I'm not quite sure at this point what I'm supposed to do next.  Now that I know the file works, I'm following the tutorials and just about time time I get positioned to complete a step, there is another hurdle which I can't seem to resolve independently.  It can be frustrating.

So, now I'm at the place where despite opening a dropbox account, I can proceed to the next step.  I would have to go back in and see the exact message I receive to accurately state it here..but basically, I have reached a standstill yet again.

Brenda