12 Replies
Tracy Parish

You can try this:

There should be a "Cancel" button to the Publish dialog, which should theoretically allow you to cancel out of the publish dialog if you hit the lockup, rather than having to use Task Manager to kill Storyline.  However, this "Cancel" button comes with a couple of important caveats:

A.  The cancel button will be unresponsive until the publishing process has completed in the background, and when the lockup occurs, the progress bar won't progress to show you when the publishing process has completed.

B.  There will be no visual indication (such as a "grayed-out" status) that the "Cancel" button is unresponsive.  You will have to either (1) monitor CPU utilization or (2) wait for a period of time that exceeds your typical publish time, before you can click the "Cancel" button.

Alternatively:
I have also in the past hit CTRL-ALT-DEL to bring up my task manager (assuming you are in windows) and force shut Storyline.  (SCARY YES) when I do this Storyline has aways said do you want to save (window pops up behind my task manager).  I quickly save, shut down, restart and the story file has been ok, minus any adjustments I might have made on the publishing screen.

Suggest you send in a bug/support report as your situation arose from a slightly different sceanrio than mine.  http://www.articulate.com/support/contact/  But it may help moving forward to a different course of action.

Ashley Terwilliger-Pollard

Hi Philippa,

I'd agree with all of Tracy's suggestions, and you'll also want to make sure you're using the latest update of Storyline 2 (Update 5) which was released yesterday and dealt with some publishing/freezing issue. 

If you're still having difficulty, you'll want to reach out to our Support Engineers using the link that Tracy shared above. 

Mel Ruth

I find the same thing, although this happens every time that I try to publish after having Storyline open for a while.  When this happens, I know right away because I've learned from experience that if the progress bar does not appear immediately after clicking 'Publish', it has frozen and will never complete.  I always have to Force Quit in the Task Manager then reopen Storyline 2 and publish again - it is always successful once reopened.  Because of this, I now make a habit of closing Storyline once I'm ready to publish and reopening before doing so to avoid the hassle of it freezing.

I haven't published anything since installing Update 5 a couple of days ago so I'll have to see if this issue has been fixed by that but, if not, at least this is a work-around.

Philippa Fairbrother

Hi All,

Thank you so much for your responses. I have gone in to it this morning and it has worked straight away. Maybe it was because I had just uploaded the new software. One quick question though.... Will update 5 have automatically happened when I installed the new software or do I need to go back and do that too?

Thanks

Philippa

 

Ashley Terwilliger-Pollard

Hi Philippa,

Thanks for the update - and Update 5 dealt with a lot of the publishing issues folks were experiencing, so  I'm happy to hear that it worked for you as well.

Just an FYI, replying here via email includes your signature as well so you're welcome to edit and update the post to remove that information if you wish. 

Scott Richardson

We have update 7,  but I see the exact same behavior that Mel Ruth mentions -- often enough (but not every time?), Storyline will not publish, and I have to cancel and try again.  Often have to cancel multiple times before ever seeing a progress bar, and publishing is successful.  Anyone else experience this? 

Leslie McKerchie

Hi Scott!

We have not seen much action or response on this thread in quite a while, so I'm not familiar with an on-going issue. Do you experience this across files or just with a particular course.

We are currently on Update 9 of the software now and updating will repair your software if needed as well.