Storyline 3 errors - "The process cannot access the file [filename] because it is being used by another process" and more

Help, please!  My coworker has had this issue many times, but this is the first Storyline course I've had trouble with. I'm working in Windows 7, from my local drive, using Storyline 3. My course has no videos or large assets. 

I am in the habit of saving regularly, but starting yesterday, I get this error when I save:

Storyline then makes a new copy of the course with a new number at the end of the filename (How to Use WebEx 062020182), even when I click the cancel button.

When I try to save again, I get this error:

If I click overwrite, I get this errror:

I'm ending up with 20+ versions of the course every couple of hours. I've seen similar issues posted in this discussion group, but none with exactly this error.

My coworker has been getting these same errors ever since she got Storyline 3, and thought that's just what Storyline does, so she never looked into fixing it. 

I can't install updates myself, without requesting a help ticket from our IT department, and I can't remove any .NET files either. If I request a re-installation, the IT department will install the original version of Storyline 3 they bought in May 2017, because that's the file that was approved for purchase. 

Any ideas to fix this? The time it's taking to manage all of these versions is really adding up, and my drive gets filled up and slows down my whole computer if I don't take time to delete past versions.

33 Replies
Katie Riggio

Really sorry you've come across this roadblock, Sonya. That's got to be frustrating, so I'm glad you reached out to us!

simple repair for Storyline 3 may do the trick here, but I've opened a support case on your behalf so our Support Engineers can closely work with you to troubleshoot this behavior based on your specific setup. We never want you to spend extra time when it's not necessary 🌟

Keep an eye out for an email from our team, and I'll also follow the case!

S R

Well, it's happening again - the fix lasted 2 days. 

My IT supoort team at work installed the latest update - I'm using update 4: 3.4.15731.0 now. I've also made sure I'm following all the guidelines given by the Articulate Support team - I'm working from my desktop (only this and my recycle bin on my desktop, plus a few shortcuts). I rebooted my machine, I've been opening the renamed copy of the file from File Explorer, and I don't have anything backing up my data in the background. 

I also renamed my file to a one-word name, because I saw a thread that spaces and long filenames can cause trouble. BTW, this is a different file than the one I had originally reported - all of my Storyline projects are doing this now.

My file saved successfully Friday and today a few times, but just now, I got the same error again. 

Katie Riggio

Thanks for keeping us in the loop, Sonya; I'm so sorry that error is rearing its head again.

I've given my teammate, Renz, your latest update. He'll be in touch with some next steps shortly after carefully analyzing these details. Appreciate you continuing to reach out, and I'll also be sharing updates here once we get to the root!

Katie Riggio

Hi, Jayashree! Really sorry you've hit this roadblock, too. We're here to help!

I took a peek at Sonya's case and saw that Renz shared some helpful tips to start:

Please also check the following after troubleshooting and updating: 

• Ensure you're working locally with the latest version of Storyline 3 
• Close any other instances of Storyline in your Task Manager 
• Reboot your machine 
• Copy and rename your .story file in File Explorer, and then open the new file from there 
• Check for any applications that 'back up' your data running in the background 

Looking at the screenshot, the E: drive could be the culprit. Are you able to copy the .story file to the C: drive and then attempt to save?

Let me know how you make out with moving the file to the local hard drive; I'll be standing by!

Philippe JEANTY

PANIC !!!

Same thing. I had not used SL3 for a couple of weeks. When I came back it suggested an upgrade. Went ahead, no trouble. First day after saving a few slides I got the same message 

wont save

I tried to save under different name and even different directory, no luck. It created a gazillion copies

copies

 

only one copy of articulate running

taskmanager

and this is on the C drive...

Any logs you want ? I'll leave the machine on.

After the first day problem i saved the file after a small change to reassure myself it was working and it did.. but later on the problem came back !

Philippe JEANTY

Follow-up...

Well i decided to crash the work: i did a million save and save as and finally closed WITHOUT saving

turns out SL3 was lying to me...  it did save ! Now i did not check the couple hundred slides in there but the last few ones i did were correct...

 

Pfwww.. but still need to be fixed !

Philippe JEANTY

A little before. Fundamentally Anna suggested to use the "Microsoft fix it tool:

https://support.microsoft.com/en-ph/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed

Once the above has been done, please follow the steps in this article to try and fix it:

https://www.articulate.com/support/article/Storyline-3-How-to-Fix-Unexpected-or-Erratic-Behavior

Please make sure that you are logged-in as an admin user, disable UAC and your antivirus software (if any) temporarily before installing the application."

For those with the same issue. I have done this and the first saving was working as expected. I will continue to monitor and report. This was actually the same version I had (Aug 16).

For others who might have the same issue, at least be reassured that although SL3 reports it cannot save the file, it actually does ! So the work is not lost, just saved with incremental names.

 

Philippe JEANTY

Maybe check in Task Manager if you have anything running that could be "locking" the file.. in my case it was a backup program that marked the file as a file to back up, and prevented any changes to it. So try to disable continuously running backup programs.

But at least in my case i could Save As, and actually even the normal Save did work, just that SL3 reported that it could not although it did. You can check that in Explorer: look at the time the file was created, then save and note that the time was actually changed !

Good luck :)

Steven Roberts

I have tries all the fixes mentioned above and I have also contacted Anna. So far no luck. I went through all the programs that are running and I could not see anything that would cause this but I don't know a whole lot about the programs that are running. Some I don't have access to stop anyway. Crystal - I am assuming that Anna is one of the support engineers; is that correct?

Steven Roberts

Philippe, Do you happen to know what the name of the back up program that was causing the issue was? I have looked through the active processes but cant see one that would be causing the issue. I have followed all the instructions from Storyline engineers but still no solution. I have got almost 2 days of work into the fix and have involved my IT dept as well.

I am running on Windows 7 Professional, service pack 1, have update Adobe Flash a couple times and uninstalled and reinstalled SL 3 at least 4 times.