Storyline 360 - publish to video is not working

Hi - since the recent update of Storyline  the Publish to Video function is not working when there is a small video included in the Scene.

I published the same Scene about 10 days ago with no problem - I updated it today (a matter of a couple of word changes) - and it will not create a new mp4 file.

Any ideas?

12 Replies
Katie Riggio

Hi there, Marion. Happy to dive in!

Does your project have two inserted video files and more than four slides? We're currently looking into a problem where the publishing status gets stuck on 'Preparing to encode video' on that condition in Update 36 of Storyline 360.

Let me know if that matches what you're seeing. I'll be right here!

Katie Riggio

Hi there, Lily!

I'm glad you reached out, as we just released a hotfix for Storyline 360 that resolves the issue where a project could freeze or hang while publishing to a video file!

You can explore the release notes here, and download the latest update with these steps. Thanks for helping us make this improvement!

Dave Harlander

When I tried to publish a Storyline 360 file to video, I got this error message:

"An unexpected error occurred while publishing to video. If this problem persists please contact support."

I'm using Storyline version 3.48.24159.0

The Storyline file size is 29.7 MB, has 29 slides, and each slide includes audio (from mp3 files). It has no interactions and each slide is set to advance automatically.

I'm puzzled because I successfully published to video a different Storyline file (11.8 MB, 18 slides, each with audio).

Does anyone know how to solve the publish-to-video error?

Lauren Connelly

Hello Dave!

Sorry, you're running into this error message! I'm happy to help figure out what is causing this error message.

Which option did you choose for the navigation when publishing to video?

The two options are Follow "Next" Actions and  Follow Slide Numbering. 

Would you mind uploading a .story file so we can test it on our end? You can either attach the file to this discussion or upload it to our team privately using a support case.

Ren Gomez

Hi Dave,

Thanks for the follow-up! I was successful in publishing your file using Storyline 360 Update 49 and everything looks good! I'm attaching it here for reference, but let me know if you spot any issues, and I can connect you with our support team to take a closer look.

I hope this helps!

Dave Harlander

Hi Ren,

Thank you for producing the video. I'll be able to use it to complete my project.

I upgraded Storyline 360 to v3.49.24347.0 this morning and was curious to see if I too could publish the file to video. But I got the same error message as before. 

Is that the version you're using? Did you use any particular settings the may account for your success? Thanks again.

Dave Harlander

I solved the problem.

My team uses IBM's RTC (Rational Team Concert) for backing up files. I was publishing the video to an RTC folder on my C drive, but the path to the folder is long, and publishing to local RTC folders is known to cause problems.

I was able to published the video to my desktop (shorter path, outside of RTC), without any errors.