20 Replies
Alyssa Gomez

Hi there Amy,

You're right -- when I inserted Try Mode slides, the typing portion did not come through. Let's see if we can narrow down why this is happening.

Is the Accu-Tech software installed locally on your computer, or is it accessed on the web? 

You mentioned that you've recorded this software before using Storyline 2. Did Storyline 2 pick up the typing portion correctly?

Brian Johnson

I'm having a similar issue...when converting the recording to test mode, SL-360 only picks up the clicks and none of the typing, however, my screen recording was not in a browser, but rather I was recording completing an interactive PDF on my own desktop.  The view it mode came out beautifully.  Thoughts? Any help?

Alyssa Gomez

Hey Brian,

I wouldn't expect you to have any issues with text entry fields when recording a fillable PDF document. In fact, I did a quick test with a sample fillable PDF -- you can check out the file I attached. 

Would you mind sharing the fillable PDF you recorded with our team here? I'd like us to test that specific PDF file to see if we run into the same behavior you saw.

Rory Lavender

I just wanted to confirm that I am having exactly the same problems as well now that I am recording in SL360. Same applications that I recorded in SL2, but now I am only getting clicks in TRY/TEST mode. If I insert as a video on one slide, the text entries come through. I normally record in Chrome, but now I am experimenting in IE. IE is recording my text entries, one letter at a time, meaning if my entry is TKOK, the entry is broken down in to 4 entry slides (T, K, O, K.). You can imagine the fun if the entry is 50 characters long! I am experimenting with fine action tuning to help "elongate' the slide to include all the letters, then I update the acceptable correct answer. Anyway... still experimenting. Just wanted to say, this is a problem.

Rory Lavender

I wanted to follow-up on what I've discovered so far in case it helps anyone else with regards to recording in Chrome.

1. Last week, if I recorded anything less than full screen in Chrome, Storyline recorded clicks only, no text entries.
2. If I recorded at full screen, Storyline records the text entries as expected, i.e. no clicks or 1-letter slides for a long entry for text entries.
3. The Chrome full-screen recording seemed to work until it didn't. The enter key stopped being recognized on a consistent basis. Correct answers are not being evaluated correctly on a consistent basis. So far, the feedback from Articulate has been include correct feedback, which we have never used on computer simulations in the past. If I include correct feedback, it does seem to improve enter key performance.
4. I took the test one step further. I recorded a simulation in Chrome, using partial screen, and it worked IF I include correct feedback on text entries.

Now, what does this prove? I don't know. But it may give someone else ideas as they troubleshoot. It seems that the back-end logic of Storyline processing the Enter key as expected now requires that correct feedback be included in text entries. But until hear from Articulate as to this, I am not saying this conclusion is definitive. But it may help someone in the short term.

 

Rory Lavender

Well, I am back again. Just started testing recording a simulation again. The most consistent results I had in the past was using Chrome, Full Screen, with extra clicks in between text entries to make sure they were separated. This means one text entry is TKOK followed by RFPSGR. If I did not add an extra click (slide which I removed later), the two text entries would be combined as TKOKRFPSGR as one entry. I just created 7 recordings. The first one worked, the following 6 did not - only clicks were recorded - no text entries. As mentioned above IE didn't work because  it recorded a TKOK entry as 4 separate entries, i.e. one letter at a time. If anyone has any suggestions, I would greatly appreciate it. The idea of having to manually create text entry interactions on many, many slides is not appealing. I forgot to mention that including correct answer feedback is no longer making a difference like it did when I posted 5 months ago. We never used correct feedback on computer simulations, but were willing if it got them to work. Now, even that, isn't helping. Just recording clicks no matter what I do or try - no text entries. I did verify that if I insert the video as a single slide, then yes, the text entries show up just fine.

 

Lauren Connelly

Hello Rory!

It sounds like this is where screen recordings don't receive the entire details when using Chrome.

From your previous post, I understand that using IE 11 isn't supported by a main application you use. Unfortunately, we do recommend using Internet Explorer to record web-based screencasts. It provides the richest data set.

I see that you've tested firefox and edge as well. It sounds like you've found ways to get the most out of Chrome for screen recordings.

Thanks for coming back to share your findings!

Rory Lavender

Thanks Lauren. Most of our applications do support IE. The problem is when I record using IE, Storyline breaks up my text entries in to single letters. That is to say, an entry like TKOK becomes 4 slides (one text entry for T, then another one for K, etc). My workaround now is to use the recordings for the system responses, remove the click screen interactions, and build the text entries using convert to freeform to match what is happening in the screen recording. Hope that makes sense.

Leslie McKerchie

Hello Enid and welcome to E-Learning Heroes :)

If you're recording a web app, we recommend using Internet Explorer. It sends the richest data to the Windows Accessibility API, so Storyline knows what to record. Firefox also works well. Google Chrome reports little information, so caption details will be missing and some steps could be omitted entirely.

Rory Lavender

Enid, I just opened up a support case on this problem. I usually get one recording, with text entries, but only one. I do have to record in Chrome using Full Screen in the recording settings to even get this much success. I had a little success yesterday using Incognito mode in Chrome (Ctrl + Shift + N), which seems to stop Chrome from doing some back-end processing, which seems to impact text entry captures. For me, when I insert a recording on one screen, it does show all of my entries, but when I import as Try mode, I lose the text entries. For now, I was told the workaround is to try using manual text entries. I just started testing in Edge and my recordings seem to be working better, but it is not a recommended browser for us either, but I may have to use it for recordings, not in training. 

OK, one last update. I just tried a second recording in Edge to see if it was a consistent solution for recording, it just returned the same results I was getting in IE 11. That is my text entries were being broken into single-letter text entries. I typed TKOK, and Storyline broke it in to 4 text entries (T then K then O then K).