Storyline 6 bug - hyperlink that breaks over lines & hover effects

I think this was raised in previous iterations of Storyline but it doesn't appear to have been fixed. When I create a hyperlink that breaks over more than one line using the 'Insert>Hyperlink' when published to HTML5 it only activates over one part of the hyperlink rather than all.

The solution I've had to use since we have LOTS of links that go over the line is to simply put a hover area over it that links to the actual link and changes to a highlight cover when hovered over. Unfortunately it now appears that Storyline 6, when you publish to HTML5, is not turning off the hover effects once you move off it. This is incredibly frustrating to the point I'm looking to see if I can re-install Storyline 5 until this can be fixed properly.

5 Replies
Ashley Terwilliger

Hi Emily,

Are you seeing this in the Flash and HTML5 versions., and only when you use the publish to HTML5 option? Did this issue not occur for you within Storyline Update 5? I'm curious if you could share an example that you published with update 5, and then if you're able to publish that same example or even a few slides with the behavior using update 6? You can share them here in the forum or send the links to me privately.

Emily Jackman

Hi Ashley,

I've attached a published and the .story file from version 5 using a real references page from one of our activities. You'll see that we have several references which break over more than one line. My work load however is such that I unable to spend time installing V6 and then re-installing V5 as I've got quite a few deadlines the next few days.

Ashley Terwilliger

Hi Emily,

Thanks for sharing the examples with me here that was very helpful to see the behavior in the previous course and taking a look at the new update 6 version when I published it.

I did a few different tests with your file, and was able to replicate the behavior when viewing the HTML5 output within Google Chrome. The links stay highlighted once the user mouses off of them, but they are still active and clickable in both versions published for Update 5 and Update 6.

Next I tested on a brand new file, and inserted some hyperlinks in a few different ways - such as hyperlinking to the text (using the Insert-> Hyperlink from the top tab) or hyperlinking to the text box as a whole with a trigger and both are set up to wrap. This version published in update 6 has the hover behavior as expected on the top and the bottom ones don't show the hover as I didn't set up a hover state for the entire text box.

With that in mind, I'm curious if you could recreate the odd hover behavior on a new file, ensuring that you're working from your local drive and following along with the other guidelines here. Please share the new .story file if you're able to recreate the behavior.

Mark Smithers

Hi Emily and Ashley,

This is a problem for me also. We get quite a few long hyperlinks that may span over several lines. Everything works fine in Flash output but in html5 output it is only the bit of the hyperlink on the last line that behaves as a hyperlink. This is quite problematic. It is not always possible to put hyperlinks on their own lines without spanning onto a new one.

I'll try Ashley's approach but it is something that needs to be looked at.

Tx

Mark

Ashley Terwilliger

Hi Mark,

Thanks for popping into this thread. As I shared with Emily, I saw the behavior in her file, but couldn't replicate it on a brand new file. You'll want to confirm that you're working with Update 6 of Storyline and following along with these guidelines for working on project files.

If you're able to recreate it on a new project, can you detail what steps you took in terms of adding the hyperlink and then share that file here with us?