Links to web pages not working

Aug 22, 2013

I have a slide in Storyline with 4 links to pages on our company's intranet (in SharePoint). The triggers to "Jump to URL/File: http://xxx" are on nearly transparent rectangles over each picture. None of the links work when it is published. The mouse pointer turns to a hand when you hover over one of the pictures indicating there is a hyperlink, but when you click, nothing happens. Here's a picture of the slide. Any ideas? Thanks!

(P.S.) The owner of this project wants it this way and not in a Resources tab.)

33 Replies
Beverly Scruggs

OK, so following Daniel's suggestion, I created a one-slide file with a rectangle box linked to an external Internet website. It does the same thing when published..the "hand" icon appears when you hover over the rectangle, but when you click, nothing opens. Does anyone have any other ideas? I may have to redo this module in Presenter instead of Storyline, because i know it works in Presenter. Bummer...

Leslie McKerchie

Hi Beverly! How are you testing this content? 

Are you viewing the published course locally, by any chance? If you view published Storyline content on your local hard drive or send it to someone else to view on their local hard drive, you'll encounter security restrictions from the computer, web browser, Flash Player, and network that'll cause various features of your content to fail.

To properly test your published content and share it with others, upload it to the environment for which it was published. Please review the following article for details: 
Beverly Scruggs

Hi Leslie,

We upload our courses to SharePoint and provide a link to it on our company intranet (also a SharePoint site). All of the links are to documents on SharePoint sites. None of them worked.

I was on a deadline, so I went back and published the course in Presenter '09. The links worked perfectly. Why would security restrictions be a problem in Storyline but not Presenter? Can you tell me the best way to provide links to web pages in Storyline so they will work? I searched the tutorials and forums but didn't find a definitive or useful answer.


Leslie McKerchie

Hi Beverly! I agree, as I do not think the two programs should have performed differently. Perhaps something was going on with your Storyline file? Next time you are having an issue with only one file, you can try to do an import into a new project.

As far as hyperlinks, you can check out this tutorial.

Nicola Avery

Hi, thank you for all the suggestions above.  I've had a similar problem today with just text hyperlinks not working. I only discovered it by trying out an ipad version so initially thought it was something I had done wrong in the publishing mode. 

I also tried disabling pop-up blockers on browsers and copying the published files onto sticks and trying on other pc's but didn't work. I tried Articulate Online with a test file based on the advice above - one slide and one line of text in a text box with a hyperlink on some of the words and this worked ok.

I've now uploaded to our internal portal running Sharepoint 2007 and it works ok.

Beth Tarbell

Hi, I had the same problem. I published my content to Articulate Online and then zipped the file. I sent it to someone else, and they extracted the file and played the .story file. I played well, but none of outside web links worked. 

How can the security issue be overcome (if that is what this is)? Do they need to clear cache? 

Beth Tarbell

Hi, Leslie

What's odd is that they work if I clear cache and publish to Arcitulate Online. But if I publish as a zip file and extract files and play story file, it doesn't work, on my computer or on my lab partner's computer (I emailed it to her).

Thanks so much for all of your help today! I really appreciate it.

Leslie McKerchie

Hi Beth! Thanks for the additional details. Viewing from your computer, is considered local viewing and we would not expect the links to work in that environment. We recommend viewing the published output in it's intended location as when you are viewing in Articulate Online.

Although if you are publishing to Articulate Online, I'm not sure why you are choosing to publish to the web vs publishing to AO.

Leslie McKerchie

Hi Beth!

Details for publishing to Articulate Online can be found here.

If you'd like to invite someone to view your Articulate Online content, follow the steps in this article.

You can also utilize the User Portal, so users can login to Articulate Online and view content to which they have been granted access. Here's how.

Chris Roetzer

There is post after post about links to URL's not working and they are about to put me over the edge. I have a course with many text links within text boxes. I did not design the course and no option to redevelop at this late stage. Similar to some above, these are links to internal sharepoint sites at work except one or two public URL pages. Links are a real issue that need addressing in SL2 IMO. The triggers at times either don't work or one that was perfectly fine on one version of the course (version two was saved as to create a derivative course) are hosed in the second. I primarily publish to my local C drive at work as I was advised and then copy output to our network shared drives. And don't be fooled... testing the links simply by clicking the check link button next to the URL path in the trigger wizard window, that just opens the link. That's not testing whether your, in my case, 'text within xxxx' text box works. I published version 2 to my SME testers and I'm embarrassed they reported some 20 errors on non working links. In one case, linked text (top box of the wizard) somehow shows only the period at the end of the line. Another one is completely blank for link text. And when you highlight text within a text box to add (re-add) the trigger, it thinks you want the trigger to fire when clicking the box, not the highlighted text within the box. C'mon Articulate, please fix this in an update soon.

Chris Roetzer

Hi Leslie, i'm not quite sure what you mean by local environment. I'm at work so it's all with in the corporate network. As I mentioned, I follow the recommended procedure to publish to web to your local C drive, then copy the output folder to a shared drive. The links are either to external public hosted pages or internal sharepoint sites. What seems to be the problem is multifaceted. The trainer can look fine, that is the link text information appears correct but when you preview the slide or run the published version, The identified text is indeed not clickable it's just formatted text. The other thing going on is that the link text box contents itself corrupts. In one instance, the text link contents was completely blank and in another it was just the period at the end of the text that was originally highlighted. I had to reestablish so many links yesterday I can't even remember how many. Using the Control + K tip was helpful because you can't set the trigger properly by just using the mouse to highlight and select the options within the trigger wizard as I had mentioned. The trigger was thinking I wanted to jump to the URL if the entire text box was selected which of course is not what I wanted. I've forgotten how to share a story file in the forum? Can I share privately to you since our training content is confidential?

Sent from my iPhone

Stephanie Rideout

Hi Leslie,

Not sure if you could help me out as well. I seem to be having a similar issue as Beth and Chris. I am trying to link to an internal beta site and the hyperlink works when I click the green checkmark to test the link however, when I publish to the web, it does not work. Thinking that it was the link, I replaced it with and it does not work either. I then tried attaching the link to the Resources tab, but it will not work either when I click on it. Just wondering if you have any suggestions?