Storyline Accessibility

I need to make my course Section 508 compliant, so I was viewing my course with Jaws screen reader.  My course was published for the web and I viewed it in Internet Explorer.  I ran into the following issues:

1) I couldn't figure out how to select a button once I tabbed to it.  (In other words, I'm trying to find the keyboard equivalent of a left-click.)  I tried the Enter key and the "/" key on the keypad (which is what the Jaws documentation suggested) but it didn't work.

2) Disabled buttons were still read by the screen reader as if they were active. I went in and discovered that you can also put alt-text and remove items from visibility for specific graphic states, but I'm not sure what that does compared to entering alt-text for the graphic in the timeline.  The alt-text I specified on the timeline wasn't visible when I looked at the specific button states.

3) Variables were read as the variable reference with percent signs instead of saying the value displayed on the screen.  This was for variables set on the master slide.

Any suggestions are welcome. Thanks!

Nancy

8 Replies
Steve Flowers

Hi Nancy - 

Try the space bar for activating buttons. The other two are good catches. Disabled buttons shouldn't be indicated as active by the screen reader and the text field should represent the text contained not the authoring text. You might want to add these as bugs / feature requests. I know the Articulate staff wants accessibility support to be top notch.

Steve

Debbie Chaddock

Hi, I wanted to know if the issue of a JAWS reader being able to select disabled buttons had been fixed. I created a multi-layer interaction that re-uses the base-layer buttons and disables previously selected buttons. However, when I tab through the interaction, I can use Enter to selected a disabled button and it throws the interaction off track.

Is this a known issue, or has it been fixed? Does the Storyine tabbing function behave differently than a JAWS reader will?  

Ashley Terwilliger

Thanks Debbie and I see John was able to test your file and reproduce the issue and as such has reported it to our QA Team for review. At this time we cannot offer a time frame in regards to when we'll hear back from them about this issue. As a workaround you can add a condition on each of your triggers if <the shape where the trigger is attached> state is not Disabled. You also have to move the trigger that changes the button state to disabled to the new layer that will appear.

Also just an FYI that responding via email includes your signature here so you may want to edit the post to remove the information if you'd like.