29 Replies
Christine Hendrickson

Hi Joseph,

Sorry to hear about the trouble!

First, please make sure that you're working with a local project file when you modify or publish your project. If you're working on a network drive, or any other external storage, that might be causing the trouble. 

  • Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. 
  • You should also make sure the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate).
  • Avoid using special characters, accents or symbols in your file names (this includes spaces and underscores).

Additional information regarding "Naming Files, Paths, and Namespaces" in Windows operating systems can be found in the following Microsoft article.

Please make sure you're running the most recent version of Storyline. Articulate Storyline Update 5 includes bug fixes, performance improvements, and HTML5 output enhancements. Click here for details.

If you're already working locally with your Storyline project files and you've updated, it may help to run a quick repair:

Articulate Support - How to Repair Articulate Storyline

If running the repair does not solve the problem, please try following the troubleshooting steps outlined in the following article:

Unexpected or Erratic Behavior in Articulate Storyline

Let me know if you see any improvement.

Thanks!

Joseph Replin

Okay, all my files are local but I am working with an SVN client for filesharing. I don't think that's a problem since I try to start a new project and it crashes on me. My file paths are less than 100 characters, and there are no characters outside of letters and numbers in my filenames.

I've followed the directions for uninstalling Storyline, and I've deleted the registry keys using slCleanup, reinstalled and am still having the same issue. Any other ideas?

Thank you!

Christine Hendrickson

Hi Joseph,

I'm not sure if the SVN would impact it - is there any way you could try to work off of this, just for testing? 

Also, can you tell me the steps you're taking to insert a new slide? Are you inserting from Story View, or Slide (Normal) View? Are you using the "Insert" option in the ribbon/menu, or are you right-clicking, etc.?

If you haven't already, please try running Storyline as an administrator. To do this, right-click on the Storyline shortcut and select "Run as administrator". 

Additionally, if you could confirm you're running the most recent version of Storyline, that would help. To find this information, please click on Help >> About Articulate Storyline. Please let me know what version you have, or share a screenshot of the version number here.

Thanks! 

Joseph Replin

Hi back! I've tried testing locally and had no help. 

I've tried to both use the top bar option and the right click context menu and I get the same result. I've also tried to Run as an Administrator...no help.

I am running update 5: 1401.2415 of Storyline as well. I'm also using Windows 8. Attached is a screenshot of what happens when Storyline crashes. Please let me know if you need anything else. I need to actually begin a Storyline project soon HA!

Christine Hendrickson

Hi Joseph!

Thanks very much for the screenshot, that helps! :)

I haven't seen anything specific to Storyline or that particular version of the error. However, I did find something similar for Quizmaker that may help with this.

If you see a System.UnauthorizedAccessException similar to the one below at the beginning of the error details, your Articulate files may be hidden or read-only:

   System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. —>

   System.UnauthorizedAccessException: Access to the path ‘C:Users…xml’ is denied.

Please review the following article for more information and solutions:

http://www.articulate.com/support/quizmaker09/kb/?p=1374

If the solutions in that article don't help, are you able to contact your IT department, to check the read/write privileges for the user account or memory process(es)?

You also mentioned a recent update to Windows - did you recently upgrade to Windows 8 or 8.1, or did you install a Microsoft Update recently? Was Storyline running properly before this update?

Thanks!

Jeff Nauman

Are you opening your files from the "Recent Files' list on the welcome screen when you first open Storyline, or from a file list? I had this problem a year or so ago- and I'm still having it. I found a workaround that works every time for me. Articulate support worked with it for a while but could not find the problem, so I just accepted the workaround as way of life and haven't had the problem since. I always open Storyline fresh- not from your working file itself. When the welcome screen opens, I ignore the 'recent files' list, browse directly to the file and open it that way. Not sure if this will work for you, but you might want to try it. Good luck. BTW, I'm using W7.

Joseph Replin

I've attached the error report to this post and have also sent it through your error report service. 

The Articulate folder was read-only and I removed that but I'm still getting the same error. I am also the administrator on this machine. I might try a system restore later but I have to get working. In the meantime, I'll work around issues by duplicating old slides and changing them (not inserting new slides). I'll write here if anything else comes up.

Jeff, I've tried opening my files from the Storyline welcome screen and from local files. Thanks for the advice though. I MIGHT have to accept a workaround but will try to contact technical support at some point.

Joseph Replin

I'm not sure if this forum is still being monitored but I formatted my PC, reinstalled Storyline, and everything worked fine.

That is until yesterday when I had the same issue and Storyline crashed on me again when I selected 'New Slide'. I BELIEVE at the time I was messing around with the freeform pick many slide and button sets. I can't be exact but that is my hunch.

I've also ran into a bug with the pick many screen following these steps:

1. Publish the slide

2. Select all the correct answers and one wrong answer

3. Deselect the wrong answer

4. Submit the interaction

This will cause the pick many interaction to display incorrect feedback even when I submitted with all the right answers selected. I'm beginning to think these pick many interactions are breaking not only the interaction but storyline itself. Would the Storyline professionals have any input on this issue?

Ashley Terwilliger-Pollard

Hi Joseph,

I don't see where the error reported was uploaded to our team, did you get an email with a case number to let you know the status? 

I haven't run into that same issue with pick many questions, but wonder if I could take a look at your .story file? Does this happen when you preview it or viewing the published output? 

Ashley Terwilliger-Pollard

Hi Joseph,

It sounds like you may be sharing the file within Storylines "report a bug" feature? If so, those go to our QA team for review and fixing, but if you'd like us to take a look at your .story file and the error report you can share them here in the forum thread or send along to our Support Engineers here. 

Ashley Terwilliger-Pollard

Hi Ros,

I checked in on Joseph's case, and it looks like he was asked to disable an internal program they use to share files. It seems he still experienced the behavior after that, and was asked to pull his system logs so that our team could look further into what was causing the issue and that was mid July, and there has not been an update from him since.

Did you already go through the steps Christine suggested at the beginning of this thread in regards to repairing Storyline and ensuring you're working with all local files?

Ros McNamee

Hi yes, I am working actually from a new project. So I would go into Storyline, New Project, wait for it to load, then go to new slide and BAM... crash. I've also tried the long list of steps to uninstall (plus all registry files) and reinstall. Restarting my computer between each step. Still nothing. I've started a support case and they have also asked me to send them log files. I sent them (as much as I could) and have heard nothing back.

Will Findlay

I don't know why it worked, but I just fixed this myself for my computer. I noticed in the thread above that a conflict with another piece of software was suggested as a problem, so I went and looked to see what I had installed recently:

Control Panel > All Control Panel Items > Programs and Features

Sort by date installed.

I found that I had installed a plug-in to the popular music player Spotify called Equalify recently. So I uninstalled it, and now Insert > Slide works again.

How is that for an obscure fix? I also uninstalled a couple of other things, (Apple iCloud, Citrix GoToMeeting) but my gut tells me it was removing Equalify that did it. That'll teach me to install obscure Spotify plugins.

Joseph Replin

Wow,

Mr. Will Findlay thank you so much. I've been working around this issue for a long long time by never adding a new slide (only copying from preexisting projects) and you found the issue. I also had the Equalify plug-in installed. I've gotten rid of it and now my Storyline is functional.

Thanks again.