Storyline FTP feature = "0 matches total" ??

Hi folks --

When I use the built-in FTP feature to upload my module onto a server, perhaps a third of the time the FTP attempt aborts with a mysterious alert box:  "0 matches total."   This appears after it has already asked things like "that folder does not exist on the server, do you want to create it?"  and so forth, so it has clearly located the server and is set to go.

Have others seen this?   There's no denying it's a bug, because even if this only occurs when my internet access hiccups (would be very strange, my net access is fine, when I FTP with filezilla it doesn't abort much or ever) ... even if it WAS due to a connectivity problem, the error message shouldn't say "0 matches total."

happened to me probably 5-6 times on varying days, etc.

thanks --eric

30 Replies
Peter Anderson

Hey Christian, welcome to the community!

In Eric's case, it looks like we narrowed this down to a third-party software conflict. If you'd like our support team to work with you on possibly locating another software application on your machine that may be causing the issue, please feel free to contact them here, and they'll be happy to help. 

Thanks!

Eric Stephan

hi you guys -- I don't recall it being resolved what caused this... but, what I did was I basically said goodbye to that Storyline FTP function and I simply use FileZilla to copy my presentation into the desired folder on a web server.  It made the process super reliable and possibly even faster.  You just have to know where to drag the files, and be sure to hit the key combo to "select all" to make sure you are copying ALL the files in the presentation's directory, to copy over.

eric

Davoren Chick

I had the same problem, with the same error messages. I was using the Storyline FTP function on a Windows XP machine (which is what our employer still requires) and IE. I finally switched to FileZilla as well, and it works very well. Just produce the files and save them to your computer, then upload them via FTP transfer using the directions on the FileZilla website. FileZilla is free, but be sure to get the real software from the filezilla site, as there are malware impostors out there.

Melanie Mornard

I'm having the same problem.  I've tried FTPing to my VPS server.  It says I have the correct connection. But then I get that 0 Match popup and the process freezes.  This last time it almost went through.  When I checked my files on the server it said that files had been transferred today, but when I attempted to show my presentation the changes I made to the presentation didn't go through.  This is driving me nuts, and I don't have that far to go.  Can anyone help, please?

Ashley Terwilliger

Hi Melanie, 

Have you checked with your IT team or whoever assists with your FTP server to see if there is an issue overwriting old files or such? It could be a caching issue - so you may want to try accessing the story.html file from another browser or clearing out the history/cache to see if you're presented with the new version. 

Dave Moxon

I also have this problem regularly. Funnily enough, it only started for me with Storyline 2.  I have no problems using FTP via my server or via FireFTP in Firefox.  I suspect this is to do with Storyline somewhere.   I was hoping to demo this feature but maybe not after all.  I also wanted learners to share their work easily for instant review in the classroom.

It is also a shame that we can no longer see the progress of the upload like we can/could with Studio but I guess that is another topic.

Dave Moxon

Hi Ashley,

I don't think there is any issue on the method I am using although I did review the information you suggested. I have uploaded many files from Storyline and from Articulate Studio by FTP in my time.  I have just created a single slide with a text box saying FTP test and got the attached error message.  This seems to be the same error message as many others are reporting. I am using the latest version of Storyline 2 on a Windows 7 machine.  It may be that I just need to repair and reinstall although I think I have had this error with Storyline 2 on all the updates.

Funnily, when I test the connection there is no problem in the FTP dialog box. When I click on publish then I get the error.  The error actually caused Storyline to crash on this latest attempt and I needed to close it.

Ashley Terwilliger

Hi Dave,

Thanks for the additional information and error message. It's not one I've seen before, so if you're able to conduct the repair and still see the behavior - are you able to create a user for us on your FTP Server so that we can attempt to reproduce? If you'd prefer to not share that information here, please feel free to connect with us here as well - and you could share the project files and log in information. 

Dana Kocalis

I am experiencing the same 0 matches found error.  I would like to manually upload the published content into my ftp server, FileZilla.  My question is, which, if any, specific remote server folder do I upload this content to?  Do I put it into the public_html or www_html or it's own standalone directory?  I have watched the videos referred to here and there and have tried to upload the published content (using the web option in storyline) into each of these three directorys and when I copy the story.html file into a web browser, it does not start the course, it just gives me an internet search page.  I have also changed the settings in FileZilla to Binary.  I know that I am missing something.

Thanks Dana

Dana Kocalis

Thanks Leslie,

I did review all of this information and watched the video which helped greatly.  However, my specific question is once I have my remote server up in Filezilla - do I put my elearning content (published files) into a specific directory...do I upload my Storyline Output folder to the www. folder or the public.html directory?  Or do I upload this storyline output folder into its own directory outside of any of the existing folders (i.e. directories)? 

The reason I ask is because I have gone to many websites including filezilla and articulate and others and each set of instructions states a different thing.  I know that I am not doing something right but am not sure what it is.  According to al of the videos I have watched, mine should work :( 

Thanks for any additional help.

Dana Kocalis

Thanks for the help Leslie.  I am going to share my steps here and let me know where I am missing something:

1.  Publish web output in storyline 2

2. At remote server, create directory within www.folder titled to match my site.  Then add directory into mysite directoy titled same as folder on my local computer.

3. upload published output (all files and folders within the Storyline Output folder) into this new wwww/mysite directory.

4. After upload is complete, I am able to copy that directory into the internet address bar and add story.html (example: www/mysite/elearningchallenge1/story.html or www.mysite/elearningchallenge1/story.html

When I copy this path into the internet address bar, it gives me an error that the file was not found. 

What am I doing wrong?  Note: My Transfer Type is Binary. 

Thanks,

Dana