9 Replies
Jeremy Dittmer

I have recently been having the same issues with the Noto Sans CJK fonts.  By a tedious process of elimination it seems that the publish crash occurs when any text field using Noto Sans contains either bold or italic text.   This is becoming very frustrating as many projects I work on end up being translated into Chinese, Korean & Japanese. Whilst italicisation makes no sense for CJK characters, bolding is often useful so having to remove it is a nusiance. 

There is clearly a bug in the Storyline publishing routines as I can see in the error logs that an exception is being thrown:

ErrorReporting Error: 0 : [2021-04-27T11:58:12.7079547+01:00][0000094c:000011fc:00000018] ErrorReport.ShowAndSendErrorAsync(...): System.OutOfMemoryException: Exception of type 'System.OutOfMemoryException' was thrown.
at System.Text.StringBuilder.ToString()
at System.String.Join(String separator, IEnumerable`1 values)
at Articulate.Player.PlayerWriter.a(bwFonts A_0, bwFrame A_1)
at Articulate.Player.PlayerWriter.b(bwFonts A_0, bwFrame A_1)
at Articulate.Player.PlayerWriter.Write(IPlayerContentProvider contentProvider)
at of.n()
at Articulate.Design.Publish.TargetContext.PublishBackgroundWorker.OnDoWork(DoWorkEventArgs e)
at Articulate.ComponentModel.STABackgroundWorker.a(Object A_0)

Any chance of fixing it?

Dominik Ginthier

Hi All,

We were experiencing the same issue with Noto Sans. Storyline was constantly crashing while previewing or publishing courses. We solved it by simply uninstalling and reinstalling the fonts. Since then it is working perfectly fine and Storyline never unexpectedly crashed again.

Best regards,
Dominik

Jeremy Dittmer

Arith,

Articulate have been very helpful in looking at this & confirmed it is indeed a bug. 

You currently have several options:

  1. Use an old version of SL - apparently v3.46 is the latest version that works correctly with Noto Sans CJK.
  2. Avoid any bolding or italicisation.  I encountered the problem in translating English modules into Chinese (Simplified & Trad chars), Japanese & Korean, so my workaround was to pre-process the translation documents in Word to remove any bold or italic, before importing into SL.
  3. Just use another font!  This is my choice going forward.  Noto Sans CJK is an attractive typeface but there are several other good & similar options.

I did try removing Noto Sans CJK & reinstalling but it didn't seem to help.  Maybe I should give it another go.  There are multiple packagings of the font to choose from (which may possibly be part of the issue) so when I have more time I might experiment with the alternatives.

Arith Hsu

Thanks for the solution / workaround. It seems to be with complex issue(s) so one workaround works but failed in another course, and another workaround works for the 2nd course.

Means, we tried to un-install all Noto Sans fonts and re-install them (we now tried to use Noto Sans TC / SC / KR, etc., instead of Noto Sans CJK TC/SC...), and the publishing works well for some courses. 

And for the failed one, we tried to un-bold text and replace it with Noto Sans TC Medium, font weight isn't the same, but at least the publishing works well. 

Fiona Macelli

Hi, I'm getting this issue (Storylne 360 crashes) when I use, or even hover to preview several but not all custom-installed fonts from Google Fonts. Do you have any parameters as to which font styles or formats Storyline will accept?

(They were installed the normal way, by dragging them into the Windows > Fonts folder, while Storyline was closed and then re-opening Storyline). Also note that I see the fonts in the Storyline menu, but if my cursor lingers too long over some of them it crashes.

Becca Levan

Hello Fiona,

Thanks for reaching out! It sounds like Storyline 360 is crashing when you hover or preview some custom-installed Google fonts, and I'm happy to troubleshoot this with you!

Storyline 360 will accept any font except for Adobe Type 1 PostScript fonts.

  • Does this happen if you test the font in a new blank Storyline 360 project, or does it happen in every project?
  • Can you share which specific font or fonts are causing Storyline to crash?

As a first step, try uninstalling the custom fonts then reinstalling them, following the instructions here to see if that makes a difference.

If you don't see improvement, and these insider tips don't help, connect with one of our support engineers here as the next step so they can lend a hand!