Storyline to SharePoint - Which file to change to .aspx?

Hello All,

I've spent hours reading all the helpful hints on how to publish and load a Storyline course to SharePoint. Many instructions say to change index.html to index.aspx or story_html5.html to story_html5.aspx,  however, I don't have an "index.html" file or "story_html5.html" when I published using the "Web" selection. In the LMS area, there are SCORM choices but no HTML5. I am using the modern player.

What are the correct publish settings to get an "index.html" file? Or do I just rename the "story.html" to "story.aspx"? (Could it be that simple?)

When I published a Rise course I see the index but not Storyline.

I'm about to get IT involved in helping me, but I want to make sure I give them the files that actually work before they load to OneDrive. I don't want to waste their time.

I've been following Daneil Kiss's instructions here, but they are for mostly Rise.

Any help would be greatly appreciated.

Thank you,

Kely

 

 

 

4 Replies
Judy Nollet

Hi, Kely,

It is that simple. Well, almost. I've heard that you should change both the story and the analytics-frame files to the .aspx extension.

BTW, the index.html file is only published for LMS content.

The story_html5.html file used to be needed for differentiating between running HTML5 and Flash. Because Storyline no longer publishes for Flash, just the story.html is used.

Ginger Beaver

I am working with Storyline 360 and we are using the modern SharePoint.  When I publish, I do not find any of the story.html files.  I know the steps for the previous storyline and thought I could follow them, but this does not make any sense to me?

See attached for which files I get when I publish

 

 

James Martin

I see a file labeled "story." That's your "story.html" file. But your system settings are hiding file extensions. In Windows 10, it's in the File Explorer Options (you can just hit your Windows search box and start typing "show file extensions" to find it quickly. Make sure Hide extensions for known file types is unchecked