Sumtotal and Storyline

Aug 08, 2012

We're having a strange problem where a course we have posted to our LMS Sumtotal sometimes gives a Page Cannot be Found error message. I got this message a few days ago, the next day it ran fine. Now today I'm getting this message again. Most of our limited community of users who have been given access to the course have not had any problems but now today one user in China experienced this problem.We only have about 100 users who have access to this course. Next Monday though we are rolling it out to a few thousand users.

Is anyone aware of any issues between SL and Sumtotal? We are using Sumtotal V 8.2.

Any ideas on leads to follow to solve this problem?


13 Replies
Gerry Wasiluk

Don't have an answer but a question--how are you connected to the LMS when you see this?

In my old company, there were three ways to access a LMS:

  1. Direct network connection
  2. VPN
  3. Through the Internet via one's ISP and logging into the network

We would see issues like you see with Method # 3.  That was because special hardware and software was required to support that kind of access--and it didn't support Flash well.

Jesse Kramer

When I experienced the problem it was on a direct network connection at my company's site. As for the person in China I have no idea but I can certainly investigate that. Now a question back for you Gerry, The issue you mention about how users access the content I assume would be true whether you're talking about Articulate or StoryLine. Right? We've not had this problem in the past with other courses created using Articulate.

Gerry Wasiluk

It might depend . . .

It was the software that ran the hardware for web-based network access that was the issue.  At first it confused any Flash-based Articulate content.  Then it got upgraded and only had issues with embedded Quizmaker quizzes or Engage interactions.  Never tested it with Storyline.

The hardware/software would "hide" the true URL to the content and alias the URL in some strange format to the user.

Because Storyline content is a bit different from Suite content, there could be a scenario where Suite content works fine but Storyline not.

*     *     *     *     *     *     *     *

What I might do is use a HTTP tracker like HTTP Watch to see if "under the hood" you might see exactly what file is not being found.  Might offer a clue.  Maybe the URL to the content asset is getting "changed."

Jesse Kramer

Forgot to follow up on my post. Turns out the problem was with Sumtotal and not Storyline. The LMS apparently uses a server farm and depending on when you logged in you would be directed any one of a number of servers. Sumtotal was not distributing courses throughout the system and so some people were looking for content from a server that did not contain the content. Our vendor has since solved the problem. Always something valuable to learn from any experience. 

Kim Simmons

I know it's been over a year, but I'm now working with SL and trying to load it to our LMS which is Sum Total v. 8.2. Unlike you, I'm not able to get my courses to load. The error messages is "identify the launch file and  launch method for the file"... I'm not sure if that's verbatium but that is what I'm told is happening. Since we are just starting to use SL in our environment, I'm wondering if I'm packaging the files properly. Any insight would be helpful.

I've attached a screen print of how I'm publishing my files. Does anything strike you as being wrong?

Ashley Terwilliger-Pollard

Hi Kim,

A 404 error is typically a security error. So you are able to load your files to your LMS, and then when you click to play them that's when you get the error? Have you connected with your LMS team to see if there is another setting that is blocking the launch of your course? Is it set to open in a new window, possibly the browser is set to block pop ups? 

Kim Simmons

Sorry for not providing a recap. Turns out that the issue revolved around the steps I was taking to recreate the Manifest Maker. For whatever reason, our SumTotal LMS has issues with the Manifest Maker files (XML & XSD) that are generated with the published output folder. Once I had the correct steps to make the conversions the file worked as it was intended.

Emily Ruby

Hello Michael!

You may want to try and import the files into a new file and republish.

Since this is working on the SCORM Cloud, I would recommend sharing your SCORM Cloud results with your LMS team. SCORM Cloud is the industry standard for LMSs, so it's a good sign that it functions properly there.

you can also look into the information here about troubleshooting your LMS.

This discussion is closed. You can start a new discussion or contact Articulate Support.