Templates with Variables. Getting Renamed When Inserting

I am having a problem. A big big problem.

I've spent the past week developing a lot of company templates. Each template has quite a few triggers along with variables in them.

The process is as follows:

  1. I start a new project
  2. I insert one of my templates
  3. I then rename the variables that came in from that template to more suitable names that make it easy to recognize that the variables go with that slide. In the template the variables are named QuestionX, and AnswerX. I rename those to Question1 and Answer1.
  4. I then make a completely new slide, I insert that same template onto this new slide. When I do it doesn't make variables named QuestionX and AnswerX. It instead seems to use the variables Question1 and Answer1 from the slide I previously inserted. I don't understand why it's doing this. I need them to come in as QuestionX and AnswerX so that I can rename them to Question2 and Answer2.

This is very frustrating that Articulate is doing this.

Anyone have any ideas?

1 Reply
Grant Goulet

Additionally. If I have one project open and create the first slide from the template. I rename my variables to Question1 and Answer1.

I then open Storyline up so I have two apps running. I start a new project and I create a slide and import the template, in that project I rename the variables to Question2 and Answer2. I then try to copy that slide over to the other Storyline app I have running and paste it in. Again the variables are not coming over. It's just duplicating Question1 and Answer1.

Why on earth does Storyline not retain the variables??!!

I am so frustrated right now.