Storyline 360 - Text variable not displaying on iPad

Hi

I have a slide that requires the user to enter their name in a text entry field. On a slide master I have inserted the reference to that text entry field variable:

%TextEntry_NAME%

When viewing the story on a computer it works - the name is shown on slides using that master (tested in Chrome, Firefox and Safari). But this does not work when viewed on an iPad. It also doesn't work when the reference is added directly to the slide, not using the slide master. 

Is this an HTML5 issue? Thanks!

18 Replies
Leslie McKerchie

Hi Nicole,

Thanks for contacting us to share what you are running into.

I just created a simple sample file to test this behavior but was unable to replicate the issue.

Do you experience the same issue with my published output here?

With your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.

Gary Overgaard

The last few weeks I've been experiencing a problem with a text entry input not saving it's value to a variable as programmed. I'm using the latest version of Storyline 360.

I had a graphic and hotspot as a Continue button that was supposed to save the text entry input to a variable and Jump to another slide. This worked when played on PCs and from most iPads including my own. But several iPad users were reporting that it was not storing their text entry input. But I could not replicate and most other iPad users could not either. The inconsistency between like devices had me baffled. 

So after searching this forum, I am so glad I found Bruce Roberts post above about changing from a hotspot to a regular button solved a similar issue for him.  I tried switching from a hotspot to a button myself and problem solved. That kind of seems like a bug to me, but glad to at least have a workaround. Thanks so much for sharing your solution Bruce!

Math Notermans

In fact this is an issue with older iOS / iPad devices. On newer models you don't have this issue. iPad and iPhones up from Generation 5.

My iPad is a iPad Generation 4 way back from 2012 and I notice that the newer iPads act differently.

 Hotspots, text-inputs etc. cause issues on these older devices. There are workarounds though, but you need to be aware of it.

Gary Overgaard

Thanks for that info Math. I do have some device info on some of the iPad users that have tested my piece and it seems mostly consistent with what you report. The failed behavior was displayed on a Gen 3 iPad and also on two iPad Air 2 models. However on an 8th generation iPad the text entry / hotspot worked fine. What I found weird though is that I personally have an iPad Air 2, the same as the two that the hotspot didn't work with, but on mine it worked fine. The only difference being that my Air 2 did have a newer version of IOS than the two that failed. Perhaps IOS version is a factor as well on some older models.

It still seems odd to me though that hotspot versus button would make a difference, but like you say as long as you are aware and have a workaround, all is good. But this also emphasizes the point about folks sharing their solutions in here, if only for archive purposes. Bruce got his solution working with Articulate support offline and that knowledge could have remained private, but he helped me and likely others by sharing it in the user forum. It's a thoughtful thing to do, I know you do it all the time as well Math. Still grateful for your amazing START button workaround.

Math Notermans

ah yes, forget to mention that indeed the iOS version definately is a factor. I forgot what iOS worked properly and what not... out of my head newer ones are fine.
When running into trouble and to ensure everything works on all iOS and devices ( and i donot have the devices myself ) i use https://www.lambdatest.com/ to test. You can define device and iOS. I found the results clear and in sync with real devices.

As about the hotspot thingy. I had the same issue on older iOS devices and discovered it was due to differences in eventbubbling in iOS's and Storyline.

Lauren Connelly

Hello!

I wanted to share that we are no longer seeing this bug, Text Entry will not Set if the Trigger jump to slide is attached on Shape object viewed in iPad/iOS/Andoid devices, in our latest version of Storyline 360.

If you're seeing a similar issue, please make sure you're using Storyline 360 (Build 3.61.27106.0) or later. You can reach out to our Support Team in this discussion or in a support case if you have additional questions.

Gary Overgaard

Hello Lauren,

That's the exact version I am using. It sets the text entry variable when attached to a button without issue. But if the same triggers are attached to a graphic/hotspot, the text entry variable does NOT get set.....but only on some iPads. I'm satisfied with using a button right now, but I would contend that the bug is not fixed based on what some of my users are reporting.

Gary Overgaard

Hello Lauren,

No there have been different versions of IOS involved. For example one user has an iPad ver. 3.0 with IOS 15.3 and the graphic/hotspot works for him. Another user has a newer iPad ver 3.6 but with IOS 15.2.1 but a graphic/hotspot does NOT work for that user. However a button with the same triggers attached seems to work for all users regardless of iPad version or IOS version.