Timeline problem

There is a minor irritation with sort timelines which still exists in Storyline 2 which would be great if it could be rectified next update.  The problem occurs if one has a very short timeline - for example I recently needed a stopwatch to appear, it used a timeline of 1 second duration so whenever it got to the end it popped back to the start and added a second to the display.  When I wanted to paste in an extra graphic to the stopwatch image the timeline immediately reverted to 20 odd seconds.  Of course as one has not intentionally changed the timeline one could well not notice that this has happened.

Incidentally I can no longer search for anything on this Forum, whatever I look for it says it cannot find even if I know it exists.  Am I doing something stupid or has the Forum itself got a problem?

27 Replies
Emily Ruby

Hello Charles!

Wendy already addressed the search field issue. Hopefully it will be corrected soon.

As far as your timeline issue, I am not seeing this in Storyline 2. I had a slide set to 1 seconds, added 3 more images, and the timeline did default to 3 seconds, but only with the first image, it stayed the same after that. Then added an audio file, and the timeline extended to the length of the audio.

If you are just adding an image or shape, the timeline should not change to 20 seconds.

Please make sure you are working locally as described here, and you could preform a repair.

You can also add the file here if you would like us to look.

Phyllis Colgan

This is a really basic question about the timeline. How can I adjust the end time of all the objects in the timeline at one time. When I try to select all the objects,  and then try to push the timeline in, all the objects deselect. I tried using the Ctrl and Alt keys too. Also tried without highlighting. I'm sure it's a simple fix. Does anyone know the trick?

Charles Huff

On the timeline length jumping issue I think I have found where the problem lies.  It is when one pastes a group.  Paste a shape lasting half a second into a timeline which is also set at half a second and all is fine.  Paste two shapes of the same length and all is still fine but if you first group the two shapes, even though the group is only half a second in length then the time line jumps in length.

Charles Huff

Hello Emily

Odd that I get the problem and you do not.  I am attaching a screen from a programme we have been working on.  The idea is a menu drops down when you move the mouse to the top of the page then retracts when you move the mouse down again.  The retracting bit relies on a half-second timeline in the 'out' layer.  Select all the items on the 'out' layer of screen one and paste them to the same layer in screen two (which I have already set to half second duration).  When I do it the timeline of that layer jumps to some 20 seconds.  I will be fascinated to know if it doesn't happen when you try it.

regards

Charles

Emily Ruby

Hello Charles!

Thank you for sharing the file. I took a look, and on the second slide you have 2 items in place already "back" and "on" both .png files that are loaded at 22 seconds. When you paste the items from the first slide, they do expand to match the 22 seconds. I did added a new blank slide, and copied the group. The items were set at .5 seconds when pasted, but the timeline did paste in to match the 22 seconds that it is set on your slide 1, which is where these were copied from.

I also created a new file and was not able to recreate the behavior. Grouping the items and pasting them did not cause a jump in the timeline. Attached is the file.

You may want to try importing your file into a new Storyline file, or try a repair of Storyline.

If the issue persists, you could open a support case. 

Jennifer Brown

I have this issue in Storyline 2, and it's worse than in Storyline 1. In Storyline 1, copying an object from one slide to another could extend the timeline simply because Storyline 1 didn't shorten it's timeline. That was mildly distracting, but an occasional thing, easy to fix.

But in Storyline 2, to which I just upgraded, the problem has worsened, and it's not just with long objects. And these phantom timeline expansions/time jumps are becoming a real time sink.

Today, I literally added 20 seconds to the end of a timeline by changing the cue points on lines in a text box with the 'by paragraph' entrance animation -- by moving things to an earlier cue/time. It seems as if Storyline 2 is trying to estimate object times and adjust their length accordingly.

I've attached a screenshot with the same timeline showing a text box with Entrance Animation Fade by paragraph.

  • Timeline A: The four bullets are aligned at cue point 4. Timeline just over 44s.
  • Timeline B: Align to cue point 2 applied to the first bullet. Timeline now over 63s.
  • Timeline B: Align to cue point 3 applied to the third bullet. Timeline just over 69s.


I had no problems like this in Storyline 1. I always used this same animation for paragraphs, never had a problem with realigning to cue points before. There are hard returns between lines (no manual line breaks which I know cause some issues in Storyline 1).

Alyssa Gomez

Hi Jennifer, so sorry you're experiencing those issues - I know that is frustrating. First thing I wanted to check was that you have updated to the most recent version of Storyline, as this issue was corrected in Update 5.

If you are on the most recent update, I would recommend sharing your .story file with our support team here so that we can understand and attempt to reproduce for our QA team.

 

Ashley Terwilliger

Hi Jennifer,

Thanks for sharing the detail and information here associated with your image. I'd want to take a look at the .story file in question, as you'll see in Emily's previous answer it wasn't something that she was able to replicate in a new file but that she did see in the file shared above. When it's not something that we're able replicate in a new file it tends to point to an issue in the file itself and we look to the guidelines here in regards to prevent odd behavior and file corruption. 

You may also want to test out Emily's suggestion above to import it into a new file as detailed here. 

If you're able to share the .story file here you can use the "add attachment" button to upload and since you're seeing it from copying from one slide to another, we could likely just take a look at one slide as a sample. You are also welcome to share privately with our Support Engineers by uploading to our case form here. 

Jennifer Brown

Thanks. Using the case form.  I am able to recreate this issue in a completely new Articulate file (new project, still unsaved, no template applied, and a "fresh" instance of Articulate, so nothing cachey that should be interfering with normal function).

Look forward to finding out the root cause of this.

Ashley Terwilliger

Thanks Jennifer for letting me know that and sharing your file with our Support Engineers. Since you've got a fairly common name, I didn't find it based on searching your name alone - could you share your case number with me here so that I can follow along? You would have received that via an email confirmation after submitting the case. 

Ashley Terwilliger

Hi Jennifer,

I just wanted to follow up here as it seems that Victor confirmed the behavior and has reported it to our QA team. He shared the following as a part of your case.:

Thanks for sending these info. We were able to replicate the issue and have reported this case to our Quality Assurance Team for their review. 

The issue occurs when aligning objects that are set to "Show Until End" - resulting in unexpected lengthening of the timeline. To workaround this behavior, disable the option "Show Until End" first before aligning the object to Playhead. You can then re-enable it after making the adjustment. Here's a quick screencast for reference:

http://bit.ly/2fsPJxj

I cannot offer a timeframe for when or if this issue will be addressed in the upcoming updates or product release but I'll certainly keep you posted on any updates on this case. 

I'll also include this forum discussion in the report filed with our team so that once there is any additional information to share we'll be certain to update you here and as a part of your case.

Allan House

Hi, 

Any update on an answer for this? Or any suggestions? I have a similar issue. I have a slide that I will need to add a lot of objects to (I mean a lot). I need the timeline locked at 0.5 seconds. 

Every time I add a new object, the timeline springs out to 3 seconds. This happens in both Articulate 2 and in 360. 

Ali Goulet

Hey Allan! 

I'm seeing the same behavior- if the timeline is set to anything under 3 seconds, it will jump to three seconds when an object is added. 

I'm reporting it to my team as a possible software bug for Storyline. From here, I’ll meet with my team to take a closer look so we can determine next steps. Sometimes my team catches errors in my logic and we don’t have a bug after all. Of course, if that’s the case, I’ll let you know! 

Depending on priority and risk, some bugs can be fixed quickly, while others take longer to resolve. Here's more information on how we identify and tackle bugs.

For now I would recommend waiting until you've added all the objects to the slide, then changing the slide timeline to .5 seconds.

I’ll let you know as soon as we have an update on this issue! Thanks so much again for letting us know about this, and I’m sorry if it’s slowing you down.

Allan House

Thanks and much appreciated. In the meantime I found a workaround for my
own project (won't work for everyone). I set one object's timeline to .5
seconds and have a trigger jumping to the same slide when the time line
ends on that object (with that slide set to reset to initial state). Not
sure about long term stability but will allow me to test with the right
loop lenght while I build the slide.

Rob Verzera

You see this same thing if you drop an image onto the stage.  Set your timeline to 1 second.  Drop an image onto that stage - and it will pop to 2 seconds.

I see the issue w/ copy/paste items from a different slide or layer.  It keeps it timeline property when pasted. ie - an object appears at 20 seconds.  If you copy this object, and paste it to a different slide or layer, even if the timeline is 3 seconds, it will retain the timeline property and paste it at 20 seconds and push the timeline accordingly.  Frustrating as hell!

I would love to know if there is a fix.