Triggers not working: related to update of 'set/toggle' state?

Jul 21, 2022

I have several slides that act as menus with the player's Next button disabled initially.  User must click each item on the slide to view the topic's content on other slides.  Each topic returns the user to the menu slide so they can choose another topic.  After the user has clicked on all 3 topic items, the player Next button should enable.  I've done this millions of times using 2 triggers:  1.  When the timeline starts on this slide, change state of Next button to disabled + 2. When the state of all 3 items is visited, change state of Next button to normal + 3. slide properties' when revisiting item is set to "Resume saved state".

But recently, this trigger combo isn't working.  The next button never enables.  I've tried also tried this:  disable the next button IF any of the 3 items = 'normal' (not visited) state, keeping the slide properties at "Resume saved state".

In each case, the slide does resume saved state (the items are in the visited state), but the next button does not enable.  Anyone else having this issue?  I'm not new to Storyline, but I'm feeling pretty dumb right now!  What am I missing?  I've attached a sample .story file for you to dig through.

5 Replies
Judy Nollet

Michael beat me to the answer (2nd time today!).

[EDIT NOTE: This post originally had info about the "Reset to initial state" function" (as quoted in a comment below. I deleted that info because I found it is no longer true.]

BTW: Here's more info about controlling the Next button. 

Brenda Heilman
Judy Nollet

Michael beat me to the answer (2nd time today!).

FYI: "Reset to initial state" and "Resume saved state" are misnamed. 

  • "Reset to initial state" = replay timeline from the start. That allows timeline-based triggers to run again. And, of course, it also replays animations.
    • If the state of an object is changed (via a trigger or clicking), the program will not revert that object back to its original state. 

Hey Judy, I'm not seeing this action...if I have it set to "Reset to initial state", the object DOES appear to reset to it's initial state.  It makes more sense to me for this to occur, so I'm not complaining!  :)