Trouble with a Quiz slide at the end of a scene

Add a simple Quiz slide at the end of one scene (Scene A). Change the navigation on the "Correct" feedback for the question to jump to Scene B instead of next slide. Problem: once the user answers the question, if he/she navigates back to the quiz slide in Scene A, they are no longer able to jump to Scene B because Storyline changes how the default layer works, adding a Prev and Next button that are apparently inaccessible to triggers.

In other words, when you look at an answered Quiz slide, instead of showing "Submit" the user is given a "Prev" and "Next" button. Am I right to think that it isn't possible to change the trigger on that "Next" button? I want to change the trigger to go to "Next Scene" instead of Next Slide."

I realize that I could add a Result slide, but it would be kind of silly because there aren't many quiz questions, and they require you to keep trying them until you get the right answer.

See attachment for a demonstration of what I mean.

Idea: Maybe there could be a setting in Storyline that makes it so if a user clicks a "Next Slide" trigger at the end of a scene, the system assumes they want to go to the next scene?

3 Replies
Alyssa Gomez

Hi Will!

Thanks for attaching the sample slides! Although you cannot add a trigger to the next button on a quiz slide the traditional way, there is a workaround.

On a different slide that has a Next button, create a trigger that says Jump to next scene when the user clicks the next button. Then, copy that trigger, and paste it on your quiz slide. Then go back and delete the trigger you added to the different slide. 

Does that help you achieve what you're trying to do?

Will Findlay

Thank you Alyssa!

That worked perfectly and is good to know. I was about to give in and just add results slides to 14 quizzes, but this is much more elegant (and avoids the extra unnecessary slides).

One more thing came up unfortunately. I have the seekbar turned on in the player. The quiz slides are customized so that they do not show the seekbar. However, when someone looks at an answered slide, the seekbar appears. Is there any way to turn that off (again)? Or is pretty much my only alternative to turn off the seekbar in the player (make no seekbar the default) and customize all of the narrated slides individually so they show a seekbar?

Alyssa Gomez

Hi Will,

You are correct that the only alternative is to turn off the seekbar in the player and customize all of the narrated slides to show the seekbar.

One way to avoid having to add the seekbar to each narrated slide individually is to add it to a whole group of slides at once. You can do this within Story View. Select a group of narrated slides by clicking the first slide in the group, hold down the Shift key, and click the last slide in the group. Then in the Slide Properties panel on the right side of the screen, select the Seekbar option. 

Best of luck to you on the rest of your project!