Urgent translation import problem

Hi all,

Our team has been using Storyline and want to import translated Word documents into Storyline, but we are running into several big problems. When we import the text file, we encounter one of several scenarios: 

1. All the text boxes import properly. This is the ideal situation. However, this does not happen all the time. More often, we encounter the next two scenarios:

2. Most of the text boxes import properly. We notice that anywhere between 2-20 text boxes do not have the newly imported text. Instead, the text box content seems to be deleted, while the object itself stays on screen, now blank. This is not ideal, but we have figured out ways to just manually copy/paste the missing text into these boxes. However, most recently we've encountered scenario 3:

3. Every single text box has its content deleted after import is finished. All text boxes are empty. Upon clicking on the text box to manually insert text, the entire text box disappears on contact. 

This problem is even more confusing to us because one computer will import and see scenario 1, where another computer sees scenario 2 and another scenario 3 for the same set of Storyline and Word files... We are using 6 computers, all on Windows 7 either through the main PC or through Parallels. The only computer which consistently sees scenario 1 is using an older version of Storyline. The other computers are all using the latest updated version of Storyline. 

Can you please help us to understand why this is happening, and what we can do about it? 

Thanks!

47 Replies
Peter Anderson

Hi Bingjie, 

As a general rule, you'll want to follow these guidelines:

  • Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. 
  • You should also make sure the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate).
  • Avoid using special characters, accents or symbols in your file names.

Can you tell us a little more about your workflow, in case that could be the cause of some of the trouble?

Thanks!

Bingjie Hu

Hi Peter,

Thank you for your reply!

To answer your questions: We have been each working from our local drives - we use the same version of a file downloaded from our file server, but each makes a local copy on their own computers when testing the imports. I think that our published output is less than 260 characters... I will have to check this for each of our machines, but to my knowledge so far I think that they are within the character limit. We do not use special characters or symbols or accents in our file names.

Our workflow: we used one computer (actually, the one with the oldest version of Storyline) to export Word documents for translation. We send these Word documents to a company which translates them, and sends it back to us in the same format. We then disperse the returned files across different members of our team, who import the file, and this is where we have seen the problems. 

My suspicion was that maybe the problem came up because the older version of Storyline exported the Word files, so it caused problems on all of the computers with new versions of Storyline?

We just tried a test run on two computers to see if this is the problem.. I will try to describe what we did below, and maybe you can help us understand the back end a little more? To give context, computer1 is the one with the old version of Storyline, and computer2 has the updated version of Storyline. The file we are trying to import is the one returned by our translation company. Same word file, same Storyline file. We downloaded fresh copies of the Storyline file from our network onto both computers and tried a Translation-import of the document - Computer1 had no problems and Computer2 encountered several missing text boxes.

After this, we ran a test and downloaded fresh copies of the Storyline file.story onto both computers. 

1. Computer1 ran a Translation-export on "file.story" and saved the output as "test1.doc". We changed font colors on "test1.doc" and tried a Translation-Import on fileA.story in the same computer. Everything ran smoothly - we can tell because all the font colors changed in the Storyline file. 

2. Computer2 ran a Translation-export on "file.story" (downloaded from the network) and saved the output as "test2.doc". We changed font colors on the file, ran a Translation-Import on the same computer, and everything ran smoothly. 

3. We exchanged and opened up "test1.doc" and "test2.doc" on the opposite computer. Computer1 tried a translation-import with "test2.doc" on its local copy of "file.story", and vice versa. Both computers were able to run this test smoothly, no problem.

4. We then ran the Translation-import on the original file given to us from the translation company - now, it works smoothly on both computers, even though we encountered missing text boxes on Computer2 at the beginning.

Then, we ran one more test only on Computer2, trying to remove Computer1 from the equation. We used another fresh copy of file.story, translations-exported a Word document, re-imported this Word document to ensure that this works, and then re-imported the translated document from our translation company. Now, it works again. We did one more test by downloading a fresh copy of file.story, and only importing the translated document. Again, there are missing text boxes. 

This is as much as we have tried to do so far... I apologize for such a long message! But I hope that providing this information can help you to maybe see where the issue is, and help us to solve it? Our temporary solution is to always do the process of export-import-import to ensure that text boxes are maintained... 

Peter Anderson

Hi Bingjie!

Thanks for such a clear explanation of your scenario

My suspicion is that the older version of Storyline on "computer 1" is the root of the trouble, but we'd love to get our hands on the .story file to be able to run some tests on our end. Are you able to open a ticket and send that over to us? We'd really appreciate it. 

Thanks, Bingjie!

Andrei Kazatchek

Was there a resolution on this one?

We've just run into this same problem in our office. It seems to only happen when I use my PC to import. The other two computers used to do it had no problem. Both of them have significantly higher specs than mine (i7 processors and 8GB RAM as opposed to my Intel Core2 Quad and 4GB RAM).

Peter Anderson

Hi Andrei, 

Doesn't look like we ever got to work with Bingie on her case, but I'd first make sure that you have the most recent version of Storyline installed - Update 3.

Once you've installed the newest version, please try the translation process again. If you're still having trouble, we'd be happy to take a closer look at it. Please go ahead and open a ticket, including the .story file, so we can take a closer look at what's going on.

 

Thanks!  

Ashley Terwilliger

Hi Rebecca,

I don't see where Andrei submitted a support case for this or Bingjie, so I don't have information to share about what was happening for either of them. We're now on update 4 of Storyline, are you using the most current version?  If not, please follow the steps to install the newest version and test the translation again. If you're still having difficulty can you share the .story file with us? You're also welcome to share it here. 

James Birks

I too am having this same problem with version 4. Initially i thought it was due to the client changing formatting in the exported word document. But in checking back - the text was the same as the original - so that wasn't the problem. I then tried importing the original document I exported from storyline. All seemed normal, until you start going into slides and then BAMM! The text disappears in front of your eyes and is replaced by an empty text field.

To add further confusion to this, the text fields that get replaced seem random. Each time i try this import function, different text fields are removed.

Christine Hendrickson

Hi there James,

Sorry to hear about the trouble!

I know it was suggested earlier, but can you confirm that both the Storyline project files and the translation files are local?

  • Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. 
  • You should also make sure the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate).
  • Avoid using special characters, accents or symbols in your file names (this includes spaces and underscores).

Additional information regarding "Naming Files, Paths, and Namespaces" in Windows operating systems can be found in the following Microsoft article.

Also, does this seem to happen if you import to a specific file? If you haven't already, please try importing to a new, blank project file. Let me know if you see the same results.

Thanks!

M. Bosscher

I'm finding the same problem, and since I don't speak french, replacing the missing text proves to be very difficult. 

I'm on version 4. I'm working 100% local. As with the other people here the problem happens with every import but which text boxes get left out is sporadic.

So still no solution other than the cliche'd Articulate "Make sure you're not on a network drive" fix?

Ashley Terwilliger

Hi M,

The previous community members in this thread don't have an existing case where we were able to look at their files, but looking at Bingjie and Peter's original conversation it seemed that there was something associated with transferring the files from a computer using one version of Storyline to a computer using another version. If you'd like to share your Storyline file and the translated file with us we'd be happy to take a look. 

Also, update 5 of Storyline was release at the end of January and although there wasn't a specific fix for that issue it's always best to work with the most recent update. 

Jennifer St. George

Hello all,

I had a very similar issue last year when working on a file and had 26 languages to import.  What I found was ... and this is going to sound crazy but here goes.

Make sure you have all the language packs installed for Word.  What seemed to happen is that Word would run into an error during the import because if the language set in Word was not the one you are importing then it couldn't spell check through to the end and it would time out and stop the language import when the spell-check in Word max'd out.

I know it sounds crazy but after I downloaded all the language packs I was using, set the language in Word to the import language, closed Word and then re-imported into Storyline - no more problems.

The Asian languages never timed out in Word even if the spell check was attempting to spell check in English because the Asian languages re much more abbreviated (in characters) than romance or Germanic languages.

Hope this helps!

Jennifer

p.s. Microsoft doesn't have language packs for every single language so some of them you might have to cross your fingers and get the most and copy and paste in the rest.

Corey Barr

Hi everyone - I'm having the same problem that has been talked about in this thread. I've tried everything that has been suggested in terms of shortening the file titles, keeping the files on a local drive, installing the language packs, etc. I've tried several different formats of Word as well (1997-2003 and 2010 specifically). The 1997-2003 version "imports successfully" and gives me the congratulations message, but it deletes all of the actual content in the course. Storyline doesn't even recognize the 2010 Word document. I'm happy to submit the file if that would be helpful. Thank you in advance for your help!

Corey

Ashley Terwilliger

Hi Corey,

Are you using Storyline 1 or Storyline 2? If you're using Storyline 2, any version of Word 2007 or later should work as detailed here in the system requirements.  Also, are you following along with the directions here in regards to conducting the translation export/import? 

If you'd like us to take a look at the behavior, we'd be happy to. We'll want to see the .story file that you're working with and the Word doc that you're using to import in the translated content. 

Corey Barr

Dear Ashley,

Thank you for your quick reply. We are using Storyline 1. We did follow the directions with regard to conducting the translation export/import. It would be great if you could take a look at the files. I'm attaching the .story and Word document here. I tried to send them via email, but the file size exceeded the limit. Please let me know if you need any further information. 

Thanks,

Corey

Ashley Terwilliger

Hi Corey,

Thanks for that update. It looks like it may be something with that file than - and I already tried importing it into a new Storyline project to see if that would resolve any corruption issues and the behavior persisted. I'm not sure if it's the .story file or the Word doc that is causing the issue - but you may want to try exporting out another translation file and see if making some  minor changes to that one allows the import to work as expected - if not, then it's likely the .story file. If that small translation import works - you'll want to redo the translation document (probably copy and paste from the original into the new one). 

Martin Dean

Same problem occurring here... would appreciate any available answers

SL2 - exported to Word
NO changes made to Word doc
Same document imported back into SL2
2 button text items vanished
Re-imported the same document - 9 text items vanished
All text (that vanishes) is visible in the Word doc

All file and locality 'rules' obeyed.  Seems like a bug in the import process.

Alternative attempt

SL2 - exported to xliff 
Changed one word in xliff doc
Saved xliff
Imported xliff (this was instant - no 'load' time at all)
No change was made to the project - original text persisted

Ashley Terwilliger

Hi Martin,

I wasn't able to replicate the behavior on new files after taking a look at Corey's files, and it seemed that it was just that one file for him. Is this occurring for you on all your files? From your description, if you continued to import the Word doc, does more text disappear each time? 

Have you looked into conducting the repair of Storyline if this is occurring in all your files? If it's just this one file, I'd suggest trying to import it into a new project to see how it behaves.  

We're also happy to take a look at your project. You can share the .story file here or sending along to us here. 

Martin Dean

Hi Ashely (multiple message threads today!)

I have now been connected with one of the Tech Support team on this matter (Ticket ID:12353) and I have uploaded a load of files.  I believe Ben in Omniplex support is raising a case with Articulate on this issue.

Here is a link to a screen recording I made to illustrate the problem:

https://qlnk.io/ql/54808c23e4b057ea2df0c0eb

 

Ashley Terwilliger

Hi Martin,

All over the place today. :-) 

I see your previous case regarding the iPad full screen, but I don't see one regarding this issue. Did you get an email from Support@articulate.com or did Ben submit it through to our team? If so, do you have the case number from Ben (or his full name) so that I can look it up and follow along? 

Martin Dean

Hi Ashley

The only information I have is as follows:

The case was raised by a sales person in Omniplex on my behalf (her name is Ciara McCullough).
It is currently being handled by Ben Sewell at Omniplex Service Desk
The Omniplex case ID is 12353
In his last communication with me, he said he 'has already submitted to Articulate direct' in case it was a bug.

I have left a message for Ben to tell me the case ID from Articulate so we can triangulate!!!