Urgent translation import problem

Hi all,

Our team has been using Storyline and want to import translated Word documents into Storyline, but we are running into several big problems. When we import the text file, we encounter one of several scenarios: 

1. All the text boxes import properly. This is the ideal situation. However, this does not happen all the time. More often, we encounter the next two scenarios:

2. Most of the text boxes import properly. We notice that anywhere between 2-20 text boxes do not have the newly imported text. Instead, the text box content seems to be deleted, while the object itself stays on screen, now blank. This is not ideal, but we have figured out ways to just manually copy/paste the missing text into these boxes. However, most recently we've encountered scenario 3:

3. Every single text box has its content deleted after import is finished. All text boxes are empty. Upon clicking on the text box to manually insert text, the entire text box disappears on contact. 

This problem is even more confusing to us because one computer will import and see scenario 1, where another computer sees scenario 2 and another scenario 3 for the same set of Storyline and Word files... We are using 6 computers, all on Windows 7 either through the main PC or through Parallels. The only computer which consistently sees scenario 1 is using an older version of Storyline. The other computers are all using the latest updated version of Storyline. 

Can you please help us to understand why this is happening, and what we can do about it? 

Thanks!

47 Replies
Martin Dean

Hi Ashley

Sorry to bother you (yet again).  I have had a ping from Ben at Ominplex saying he was unable to re-create the problem (Case # 00442944) and was waiting for me to respond.

I have not heard anything yet from Articulate and was worried that this might slip into  a black hole.

As I understand it, I have sent all the files that misbehave on my machine and a video showing this happening.  I am hopeful that this is still being looked into by the Articulate support team and that I will get some response.

Ben did suggest that I re-install the application but am loathe to do this in case it messes up the trial I am carrying out.

Please can you let me know the status?

Thanks very much

Martin

Ashley Terwilliger

Hi Martin,

No problem, I had a note to check in on the case Ben submitted for you later this afternoon. It looks like John Say (our support engineer) tested the files Ben shared, and he wasn't able to recreate the issue on his end using SL2 Update 2. The import occurred successfully. He was checking to see if Ben was able to replicate the behavior (no update back from Ben yet) but John did share a reminder of the following, which I've shared with you previously but will include here again: 

1) Be sure to only work on files that are saved on a network drive. 
2) Please also make sure that you have the latest version of Articulate Storyline 2 installed which is Articulate Storyline 2 update 2. In Articulate Storyline, go to Help > About Articulate Storyline. If you have a lower version, please download the latest version from the link below: 
http://download.articulate.com/storyline/2/storyline-2.exe 
3) If the issue still occurs, I would recommend that you uninstall and re-install Articulate Storyline 2. 
4) I would also recommend always saving versions of your project files so that you have a file to go back to should your current project file crash or become corrupt. 

Reinstalling Storyline, or conducting the repair won't have an impact on your overall trial time or any of your existing project files. You'll just want to ensure you have saved the files and I'd make a back up copy of the files (just in case, in general I'm a worrier...) and then go through the repair steps here. 

Martin Dean

Thanks Ashley
I think Ben got this message as it was relayed to me exactly as you have copied it.

Can I check the first recommendation?

Surely the advice is NOT to save to a networked drive, and to make sure files are
on the local hard drive?.. or am I completely mistaken? If I am, then I do not have a network drive on which to save them.

I will try reinstalling later this week.

regards
Martin

Sent from my iPad

Ashley Terwilliger

Hi Martin,

I just wanted to follow up here again in terms of John's communication with Ben. John replied:

I understand that the issue with the translation import is intermittent. 

So far I am still not able to replicate the same issue on my end even after trying to import the translation from a 2nd computer. 

Please feel free to keep us posted here or with Ben/John through your case. 

Martin Dean

Hi Ashley
Thanks for following up.

In order to try to test this again, and having had to reinstall following the Flash problem, I have done the following:

1 - installed the new software
2 - opened my translation original and tried to export
3 - the export failed (at the end of the export process, an error message box popped up with no error message text
4 - I presumed that my original file was corrupt, so decided to abandon this file, and start again
5 - I created a new file with similar functionality as my original
6 - on trying to export from this file, the export failed again

So I appear to have another problem - this time I cannot create a translation file.

I am not at my desk at present but will send you my latest file when I am next there.

Regards
Martin

Sent from my iPhone

Martin Dean

Hi Ashley

Further to my post last night, I have now gone through the process I described and am indeed seeing variable results (not intermittent, as this suggests the re-occurence of the same thing).

Please bear in mind, that last night, SL2 was failing to export to Word at all.  It failed on both attempts to use the Word formats but successfully exported to .XLIFF - the latter content being viewable in a text editor.

This morning the export was working again (no restart overnight)

I have made another video this morning in which I show the following:

  1. A working new file - in SL2 release 3
  2. The export of that content to WORD
  3. A minor change to that Word doc
  4. The re-import of the Word doc
  5. The disappearance of various pieces of text

I then closed the file without saving and did the following:

  1. Opened the source file (which was not changed from the original)
  2. Imported the same Word file as had been used in the first test
  3. Observed the disappearance of DIFFERENT pieces of text and the re-appearance of text that had been previously missing

In the past, we have seen how Microsoft applications can introduce hidden characters which if allowed to pollute XML, can cause whole files to misbehave.  Is this a possible source of the problem?

To test the above, I will Export to .xliff - make some minor changes and re-import from .xliff

Meanwhile - here is a link to my latest video
https://qlnk.io/ql/548ad664e4b0c9434c041c2c

 

Ashley Terwilliger

Hi Martin, 

Thanks for going through all those steps - super helpful in terms of troubleshooting. I know from the previously shared files in the case we weren't able to recreate the same behavior on our end - but since you continue to see it, I'd like to have you continue to work with our support team. I know Ben opened up the case for you last time, but do you want to share your files with us directly here? 

The hidden character element is another interesting piece, so we'll want to know what occurred after you testing the export to .xliff. 

Martin Dean

I have now conducted the following test:

  1. Used the same original file as in my previous test
  2. Exported text to .xliff format
  3. Made a small change to the .xliff file and re-saved it
  4. Imported .xliff file to my project 
  5. Viewed the content to discover the change had not been implemented
  6. Checked the .xliff file to confirm edit was saved
  7. Renamed the .xliff file
  8. Reimported to my project
  9. Confirmed that the change had not been made

I do accept that my XML knowledge is sparse and I could perhaps have not edited the .xliff correctly.  The import of the XML was incredibly rapid, which implies that nothing is actually being imported.

Here is a video of the above:

https://qlnk.io/ql/548b8c86e4b0c9434c042404 

 

Ben Sewell

Hi Martin and Ashley,

I thought it may be easier for me to respond in line with this post.

I also tested Martin's files and was unable to recreate the issue.

I wonder if this issue lies with a very specific Office setup, as the fault does seem to only occur at the stage word makes changes.

To test this, I have suggested we both take a copy of Martin's test course to try:

  • On machine A - export a file, make changes, save and send to machine B. Import this file on machine B.
  • Repeat the above for machine B to machine A.
  • If this yields results, we may further test by exporting the file, as above, but make no changes. The tested file will simply have been exported and unopened.
Ashley Terwilliger

Hi Martin and Ben,

Did you open up a new support case yet? If not, I can reopen the one Ben was previously working on so that our team can continue troubleshooting this with you as it may be easier to handle this outside of the forums, especially in terms of sharing files back in forth. 

If you have a new case number, please let me know - otherwise, I'll share the information here with John who worked on the initial case, and have him include both of you in the email replies. 

Martin Dean

Hi Ashley

Yes I have opened a new case and the ref is #00445400.  Iam just studying a reply from John Say on your support team now.

There is a suggestion that this may relate to using a Mac and possibly on the placement of the import/export files on the hard drive.

I shall respond to John and update the forum as I get further.

Regards

Martin

Ashley Terwilliger

Hi Martin,

I just checked in on your case today - and it looks like all is working as expected now! It looks like there were a few issues such as a Shared profile on a mac, and a known issue of translating  content via XML Localization Interchange File Format (XLIFF).

Glad things are back in working order and that John was able to help you! 

Shawn P. Conroy

Good day everyone,

I'd like to report that following the suggestions from staff here has greatly reduced the number of missing text boxes. That is, on a test I ran the import with both files on the root of my c:\ and eventually I made a folder right on my C: called c:\storylineimport\ and this reduced the number of missing text boxes from about a dozen or so to about 1 in 25 slide lessons.

However it was still random text in random objects. Usually just one per import.

Test Case 1:

Exported and translated the document. When I went to import a random block of text was missing. I closed both files. I reopened Storyline and imported the translation again. This time a completely different text box on a different slide went missing.

Test Case 2:

I opened a different lesson in Storyline. I exported the English text for translation. I then imported the document that was just exported, not making any changes to it. A random textbox on a random slide went missing. Repeated this experiment and found a different block of text on a different slide went missing.

Test Case 3:

I opened a Storyline file and did a translation import. A text box went missing. Without closing the document I merely imported it a second time. Now more than one text box was missing. Everytime I imported an additional random block of text from a different screen went missing.

I assume if I continued the experiment eventually the entire document would be devoid of text.

If anyone has additional tips or solutions I would appreciate it.

Leslie McKerchie

Hi Shawn! I see where you have a support case (00629486) open with our team, but it looks like the e-mail address we have on file is bouncing back as invalid.

Could you e-mail support@articulate.com with your correct e-mail address and reference Case#00629486 so that we can continue to assist you?

Lya Ryabenko

Its incredible how little support there is for this obviously very common issue! 
the basic things you ask us to do are done and do not influence anything. 

I have imported a previous translation file into the same new version of articulate and that works fine, but my new language file is exactly the same, and also converted to Windowns 97-2003 - which is already quite an embarrassment for an updated software to not be able to read docx. 

So three is clearly some bug going on, where reinstalling the program certainly is not a solution instead you should invest some real bug fixing in your updates. And this whole thread 3 years ago!!!

I guess I am going to once again workaround manually, like with so many things with articulate. 

Ashley Terwilliger

Hi Lya,

I'm really sorry that you're still running into issues with this. I also responded to your other post here, and I'd love to make sure you're getting the help you need.

Let me know if you hit any roadblocks, or if you'd prefer to work one on one with our Support Engineers, they're happy to help. Reach out to them here.