Using the ENTER key to move to next slide

I would like to use the enter key to move onto the next slide, but the problem I'm having is that the ENTER key wont respond unless the user clicks on the screen first. The last action the user does is click the NEXT button, so when this slide starts with the focus defaulted to outside the interactive screen part, so I'm not sure how to make it so the enter key will just work.

I'm working on simulating software that cannot have the user clicking around the screen (old telnet mainframe software), so how to I have the Enter key work without making the user click within the player first?

15 Replies
Jackson Hamner

After playing around with it for a few hours I believe that it is a bug in Storyline. I just copied and pasted the slides into a new storyline presentation and it magically worked, so I think there might be an error in my story file?

I'm going to re-create the problem slides from scratch to see if it works, but if anyone else experiences something like this or has suggestions on how to fix/prevent this in the future please let me know :)

Jackson Hamner

Okay so I haven't really figured out WHY its doing this, but I figured out the cause of it failing on me.

 

Apparently if I have these two objects, one picture and one textbox, right at the beginning on the timeline it takes the focus away from my screen so pressing enter doesn't work.

BUT it works if I move it 0.01 seconds after the timeline starts

It works...

 

It is something about having those two objects start as the timeline begins that takes away from the main screen's focus. Any thoughts?

Jackson Hamner

Sure, I had to edit out some of the things in the timeline, so it might look kind of empty, but the problem is still there.

Example.story is the problem file, the second slide contains the two objects that are messing this up, they start at 0 seconds on the timeline and wont let you press the ENTER key to continue until you click somewhere inside the window.

WORKING_EXAMPLE.story is the same file, only the two objects start at 0.01 seconds instead of 0 seconds, and you can just click the ENTER key to continue without needing to click anywhere.

Thanks :)

 

Ashley Terwilliger

Hi Jackson,

Thanks for sharing those files here - and I see the behavior you're referencing. I was hoping to see the example you mentioned in regards to how it worked after copying/pasting. I can share this with our QA team to determine if it's a bug or by design but it seems that the slide itself doesn't have the focus until something occurs on that slide, such as the working example you shared where the objects appear after .01 seconds. In the meantime I would suggest using that workaround going forward. Once we have any additional information to share we'll post here for you. 

Jackson Hamner

. I just copied and pasted the slides into a new storyline presentation and it magically worked, so I think there might be an error in my story file?

Brande Morrison

I'm having this same issue, but it works on one slide, and not on another, and the slides are nearly identical. I've tried the .01 second delay for loading the content with no luck (the slide only has 3 items - 2 text boxes and 1 picture). The slide immediately following DOES work when the user clicks enter (that slide contains 2 text boxes, 1 pic, 1 rectangle - and none are delayed on the timeline). Any new updates on this? Thanks!

 

EDIT: I reordered my 2 slides to see what would happen, and the slide that had worked (the second one) stopped working once it was first, and the slide that didn't work (the 1st one) started working once it was second. Any ideas why the focus would be on the 2nd slide correctly but not the first? Also, these are not the first/second slides in the scene - there are slides before and after them. 

Jack Drolet

I use arrows that the user can click on to go to the next/previous slide, and also make triggers that say go to the next/previous slide when the user presses the Right/Left arrow key. If these are set up as Slide Triggers, then they don't work unless the user first clicks on the screen. However, they work as expected if they are attached to the arrows themselves.