Visited State not being triggered in SL 360 Review and LMS Published Files

I have a series of shapes that I have created a Visited State for.  These "buttons" upon click, show a layer.  I have tried putting triggers on the buttons, on in several different locations on the layer to try and achieve the buttons actually showing their visited state in SL 360 Review and the LMS published file.  Nothing is work.  I've also rebuilt the buttons using shapes, pictures and actual buttons. Nothing seems to work. 

This is happening across a catalog of over 15 courses.  Appreciate any help. :-/

12 Replies
Sam Hill

Hi Mary-Scott. I've found a solution for you. The problem stems from the button not being part of the slide until it appears in the timeline toward the end of the slide. It looks to me like the visited state is only going to work if the button has always been on the timeline.

You can do this by using a disabled state on the button. For example, when the slide first loads the button is disabled, and then when you want the user to interact with it, you use a cue point on the timeline to make the button available (Change state to Normal), or you can use a motion path to animate the button in at some stage. The key is that the button has always been there from the start of the timeline for the Visited state to work.

I think the disabled state might work best in your instance. I have provided an example. I brought the cue point forward (5s) for a quick test.

Walt Hamilton

Mary,

Do you have any samples that don't have triggers to change the state to visited that don't work?  Every one that I tested that doesn't work is one that has an "artificial" trigger associated with it. Once I remove those triggers, they all work.

I find that Sam's sample works, but not for the reasons he gives. It is because he has removed the artificial triggers on the layers. If I completely remove the disabled state, and have the button show at 5 sec (or 51 sec), it works, so I don't think the problem is the presence or absence on the slide from the beginning.

If you remove the offending triggers, and some of the buttons don't change state, my first guess would be the look at the method you used to create the visited state. If this is not one button that was copied and repeatedly pasted, there may be some variation in how it was created. For example, there may be a delay in the animation that was copied when the group was pasted, or something of a similar nature.

Anyway, if you could find an instance without those triggers that consistently doesn't work, and post it here, I'd be grateful. I'd like to see if you have uncovered some sort of bug.

Sam Hill

Hi Walt, I actually tried what you were suggesting as a first stop, as that was my first suggestion to remove the triggers to set a Visited state as they are unnecessary. It's possible my work around is working around a bug as I did not get the visited state in the example I am attaching now.

I reckon the visited state is actually preset, but the animated tick might be the problem. I wonder if changing the layer properties might help (changing to pause the base rather than hiding base objects).

Let me know what you experience with this single slide example Walt.

Sam Hill

Hi all, I have confirmed that if the animation on the tick is removed, the visited state will show on the button. It is correct that the visited state was always present, but the tick was not showing due to a glitch with the animation being triggered. The only thing I did not test was whether changing the "Hide objects on base layer" property on the layers had any impact.

Walt Hamilton

If you click the button before the audio ends, it works. If you wait for the end of the timeline before you click, it doesn't. I believe that if the timeline ends, the animation of the state doesn't have time to occur, so it doesn't appear. If the animation is removed, it works, even if you wait until the end of the timeline to click.

Mary-Scott Hunter

Hey folks,

Thanks so much for responding! Did you verify your results in SL 360 Review. Just so I'm clear, it works as expected in all cases during preview.  It fails in SL 360 Review and in LMS testing. Also, it happens on slides (like 3.9 in my example), when the buttons are present from the beginning of the timeline.

I do realize that some of my triggers to try and force the visited state are on the condition when the timeline ends and those timelines are sometimes long.  But trust me it's happening when the layer timelines are set to less than 1 second.  :-/

Mary-Scott Hunter

Unfortunately, I don't have examples anymore of the buttons without triggers, although obviously easy enough to create. I had to change them all because they consistently didn't behave as expected without triggers in SL 360 Review and LMS testing. Hence adding the triggers. 

I'm curious why you are thinking that adding the triggers would "invalidate" the visited state.

Thanks ahead.

Walt Hamilton

Actually, adding your own triggers that duplicate the built-in triggers doesn't invalidate the states. What it does is frequently conflict with the built-in triggers, causing unpredictable and usually frustrating results.

The animations are not on the state, they are on individual items within the visited state. The oval and check mark have a fade entrance animation. (You can watch it fade in in the instances where it works.)

Look at the video, it shows the actual reason these visited states don't work. Ignore my first post. i thought I had gotten it to work, but that was because I wasn't waiting for the audio to finish before I clicked.

In the video, notice that the first time through slide 3.9 that I click on the button right away, and the visited state shows.

The second time through, even though you can't hear it, I wait for the audio to end, and the timeline to end. The visited state doesn't work.
Then, I Edit the states of the button, go to the Visited state, select the group of the oval and check mark. I copy it, so I can move it back to the slide, because you can't do animations while editing states. I close the Edit States, paste the copied group on the slide, and check animations. Sure enough there is an entrance animation on that group. The long and short of it is that if the visited state doesn't appear while there is at least 0.75 sec of timeline left, that entrance animation doesn't have time to complete, so while the State changes to Visited, the oval and check group doesn't appear.
Notice in the last part of the video, I changed the color of the visited state and waited for the timeline to end. The state is changed, but the group doesn't appear. You can also test this by putting a trigger on slide 3.9 to pause the timeline at 5 or 10 seconds. Any button clicked before the pause will show the oval and check, while those clicked after the pause won't.

I suspect that in your tests, the times the check appeared, you had clicked the button before the timeline ended.

The solution, unfortunately is to copy one of those groups, paste it on the slide, remove the entrance animation, copy it, and paste it back into the visited state in place of the old one. With one cleaned up, you can paste it into the visited state of each button, but don't forget to delete the old one first.

Or alternately, you could ask the learner to click before the audio runs out :)

Mary-Scott Hunter

Sorry for the delayed response. You are so right!!! This has been plaguing our team forever.  Thank you so much for figuring it out. Walt, you are truly my hero :).

One thing though, I have been able to add, edit or remove animations for elements during editing states.  I just had to have copied that element into the state after having created the state -- boy that was a mouthful ;).  Anyway, doesn't affect the solution, just thought I'd share that.