Web Objects Not Loading

Oct 08, 2013

Hi there - 

I have a course where I use web objects heavily and I have discovered that many of the browsers I initially used to test out the course are having problems loading them now. Does anyone know why this might be happening?


2 Replies
Ashley Terwilliger-Pollard

Hi Lindsey,

There are two troubleshooting options here for why a web object may not be working, that I've also copied below: 

If you find that a web object does not display in your published Storyline project, review the following possible reasons.

View content in the correct environment
Be sure to view your content in its intended environment. If you published for Web or LMS, upload your content to a server for proper viewing. If you're viewing content locally, publish for CD, and then double-click theLaunch_Story.exe file. Otherwise, local security restrictions in your computer, browser, and Flash Player will cause various features to fail.
Hosting website may not allow viewing in an iframe
If your web object still doesn't display, it's likely that the hosting website has configured its X-Frame-Options toSAMEORIGIN or DENY. This means it cannot be viewed in an iframe, such as a web object container in Storyline. A common example is Facebook.
Lindsey McLean

Thank you for the response, but neither of those options will fix the problem I am having.

What is happening is that the latest browser security updates, most specifically Firefox 23 & 24, is blocking mixed content on webpages. The consequences for those of us distributing our courses through an LMS is that, because the course is loading with an https any http web objects in the course will be blocked.

I have tried to just simply allow the content to load (by clicking on the security shield in the address bar), but this action interrupts the courses communication with the LMS.

The simplest solution I have come up with so far is to use the https version of the webpages used in the web object if you plan to launch your course through an LMS.

This discussion is closed. You can start a new discussion or contact Articulate Support.