Weird bug when replacing images using the Media Library

Aug 04, 2023

Just had the weirdest bug trying to use the Media Library. Image on disk i updated. In the Media Library it shows as 'The original file is newer'. Reimporting it then. And then the image name somehow refers to another. As i use that name targeting it things fail. I cannot remove or change it anymore from the Media Library.

Anyone else had weird bugs using the Media Library and a way to fix this ?

4 Replies
Math Notermans

It kept returning, whatever way i imported or changed the 2 images. One was called multimeter_h.png and the other multimeter_n.png

2 different images that by using the Media Library to update somehow internally got confused and both ended up named multimeter_n.png in the timeline. Offcourse that was wrong for me, as my Storyline didnot work properly anymore.

Removing them, adding them new...nothing worked.

The only solution in the end was creating a new file with the 2 images.... opening up my actual project, remove them there and copy/paste them from the timeline.

Conclusion: The Media Library is not intuitive and using it only causes trouble. @Articulate take a proper look at the Media Library in the new Storyline. Probably skip the obsfuscating of files and code so we as developers get more options.

Eric Santos

Hi Math,

Thanks for bringing this to our attention! What you're experiencing may be related to an existing bug that we are monitoring:

  • Storyline Keeps the Original Filename of Media Files that were Renamed From Windows Explorer

When you said you updated the image on disk, did you mean the file was renamed, or a different version of the file replaced it with the same name? I could not reproduce the message "The original file is newer" in the Media Library. Would you mind outlining the steps you took for the issue to happen? If it would be easier for you to discuss the steps in a screen recording, that would also be great.

I'm looking forward to your response!

Math Notermans

Hi Eric,

In the end it got really confusing, so its hard to redo it precisely.

What i basically did, i had 2 files on disk. a.png and b.png
I edited one of them in Photoshop, saved back to disk.
In Storyline i got in the Media Library "The original file is newer".

Updated it and continued to work. When in a later stadium i changed the other one.
I suddenly had 2 the same named files in my timeline. No way to fix it even removing them didnot work. As described above...only way of getting it fixed was creating a blank new SL...adding the files there...copy/paste to the original SL and then all was fine again.

The Media Library as is, for now is totally offlimits for it only gave headaches.

Kind regards,

Eric Santos

Thanks so much for sharing additional details, Math! I tried applying the steps, but I did not see the issue on my tests; the images in the timeline were as expected after editing the images and reimporting them in the Media Library.

I've opened a support case on your behalf, so our Support Engineers can dig deeper into the problem. You're in excellent hands working one-on-one with them, and you should hear from them shortly!