Youtube videos won't play in slide when inserted as web object

I'm having trouble with YouTube videos. I can't embed them because we want the modules to be mobile-friendly, so I'm inserting them as a web object. The problem is, I want them to play inside the slide instead of opening a new browser window, but I can't get that to work. 

When I select to have it play in frame and then test the links I get a message that says "The Web address you entered cannot be displayed in a frame. In order to function properly, this web object must be set to open in a new browser window." 

Here's the YouTube videos I'm working with:

http://www.youtube.com/watch?v=NBNrYOBFwDs

http://www.youtube.com/watch?v=1r31pL1aZDQ

http://www.youtube.com/watch?v=BcC9YSTa8B8

http://www.youtube.com/watch?v=Z8g_fkQb2F8

15 Replies
Evie Price

That worked to get the video embedded into the slide, I missed that word, "embed"! Unfortunately, it still won't play, but it does show up.

When I publish and test it, I see the YouTube screen with the red play arrow, and after I press the play arrow, I get this error message (screenshot attached).  When I "test link" from the insert object settings, I get the same error message. Not sure if that error is YouTube related, or something else going on in my settings. Any ideas?

Evie Price

I published for web and I'm viewing the HTML5 file from a Public Dropbox folder, so its being viewed in the intended environment. 

There are four YouTube videos inserted as web objects - 2 in each module section. I was just able to get one of them to play, but the other three return the error message.

The weird thing is, that for all of the videos, I can adjust settings in the YouTube play bar that show up in the slide -- I can adjust the volume slider, mute/unmute, go in and out of full screen -- they just won't play.

Here's the link to the module: https://dl.dropboxusercontent.com/u/110737230/Interprofessional%20Communication%20-%20Storyline%20output/story_html5.html

Maybe the issue is that a public Dropbox isn't secure? But it is an "https" address, and one video plays.  

Two of the four videos are produced by the same person, they're a set, and one of them works, and the other doesn't, so I don't think it has anything to do with restrictions on the video, but I could be wrong.

Molly Cooper

Good morning, I am having the same or a similar problem.  I have videos set up embedded in a lightbox slide.  When I publish the course, the videos play for me when I click the "View Project" blue button which appears at the end of the publish.  However, when I click the Zip file button and put the published zip folder on SCORM Cloud, the videos don't play.  The lightbox opens and is blank.  I have read some of the posts about the server settings and such.  I am relatively new to Storyline, so I wanted to see if there were faults or errors in the way I set up the slides.  I pulled the slides out of my big course and have attached them here.  Thank you in advance for your help.  This one has been baffling!