Error initializing communications with LMS - Info and discussion

Nov 04, 2013

Dear all,

Many people have been searching and asking why they are getting the "Error initializing communications with LMS" error. However, it seems that while there is some understanding as to why it happens there is very little information on how to resolve it.

I have found many posts on here and other sites that explain that you will need to contact you LMS provider as this is there issue. After some research and reading into the SCORM standards etc i am not so sure the LMS is to blame.

What do we know? 

1. The error is caused by the user launching content and then losing connection to the LMS (as this has to remain open at all times). This results in the LMS not receiving the message on the status of the SCORM content and crashing out. Subsequent attempts to open the content cause the same error.

2. This appears to be random but can be either a internet connection fault at the users end, or in some cases a bottleneck on the LMS server.

3. Some LMS providers have built in manual tools to fix the content that locks out for a user, we have found this seems to wipe all record of the users progress.

4. Some help explains that you need to stop your content from launching in a new window if the LMS does this already. I think there are several cases where this has fixed it but also several cases where it has not.

5. This is not a fault with the LMS as they are not required to handle this error on your contents behalf. The content you build should be able to handle errors but it seems that most content authoring systems don't code this in as default.

How do you stop it happening?

I had a discussion with some LMS developers who have themselves worked with some SCORM experts who have built content that can handle the above error. They claim that to fix it you need to add code to the SCORM package that sends an exit command when the content launches and detects and error. This will clear any status' in the LMS that never finished correctly allowing the content to open. They would not offer the solution for free and were not willing to help out.

I wanted to open up this discussion to get other peoples thoughts on this. Should the Articulate software be built to compile content to handle this? It would appear that as far as the compliance is concerned, this error handling is not required. Do you have experience in editing compiled SCORM packages and would be willing to help this community to resolve this issue once and for all? I know there are many cases where people are trying to deal with this error but have no idea who to turn to and what they need to do.

My hope is that all of us can provide a solution to eradicate this error from everywhere.

Thank you and i hope i am not talking rubbish and wasting your time

Also, if you are one of the people who has been affected by this error then let us know and introduce yourself.

7 Replies
Richard Mundon

Hi Tim,

Not yet know, was hoping that we could get a group of us on here who could work together to figure out how we can work around this problem, specifically with the manual editing of the SCORM package. I think that area is our best chance of making our content handle the error and recover from it, plus it will also work on any LMS then too.

I will update this if i find out more in the meantime. fingers crossed.

Richard Mundon

Hi Tim,

Just thought i would update you something i have just read about attempting to remove the LMS error from content.  It sounds like it might be due to publishing content in SCORM 2004 4th edition. Basically the advice is that unless you need to track high details from quizzes or surveys then publish to SCORM 1.2. Its likely to have better support and if i have read into it correctly, wont suffer from the initialize errors.

I am going to do some testing this end by rolling out our entire content library as 1.2 and then track how many errors we get logged.

I personally am happy to sacrifice some quiz and survey features to ensure content does not crash and lock itself out!

Manoj Shekar

Hello Everyone,

                           Got a same problem with my PRINCETON REVIEW PORTAL which prompted  "Error Initializing communication with LMS" and here is the reason why it should've caused

1. There might have been a registry error in your pc (in case of mine) while loading content which would've been crashed by some unknown mean.

2. Maybe you might 've downloaded Java (64-bit) for a 32-bit browser or vice-versa.


Solution :

                In order to get rid of this problem please perform a PC Tune Up with software such as 1. AVG TuneUP ( in my case ),

2. Re-image etc.,

                 These software would clear the break-downs in your system registry etc., would be repaired. And then you would not find any error initializing communication with LMS etc.,.If you need a link to download those software for free please contact me through my mail "".

This discussion is closed. You can start a new discussion or contact Articulate Support.