Picture problems inside states

Sep 11, 2017

Hi folks,

I've taken a look for similar problems, but not seen anything. I'm trying to use multiple pictures within a single spot using shapes (expecting to have 100+ by the time I'm done). I've tired something similar before and found if I start with a shape, then delete this, and add a picture, the original shape becomes unclickable in  edit mode. 


A new problem comes from having a smaller picture in my 2nd/3rd state, I can't seem to get them to line up, (down and a bit to the right of the little cross that indicates the original picture starting point). Instead it insists on starting on the other shape's stating point and just changes shape. 


Is this something others have run into before? Any easy ways to solve other than  using 100 different pictures?


Thanks Allan 

7 Replies
Allan House

Hi Allison,

That was quick! I've extracted the odd behaviour to show you, as if I leave it in the project would take ages to explain what is going on, as the project is only 10% complete. 

 Basically, I'd like dotted outline to change to one of the two sword states when you click each button (will actually be using other variable triggers later). 

The trick is, I need to control where the sword appears. that seems of for one, but for the other state (30), it is always flush left. 

I'm wondering if I'm missing something easy?

Allan House

Thanks for taking a look Wendy.

I gave that a go, and I can twist this into a solution, involving taking the image in an editing tool and adding white space to make the left boundary identical, but keep the sizing the same if I have to. 

Gets even stranger though when I try to move the image (now resized) off to the right. 

If you look at the articualte file (under view states), it shows state 50 appearing far to the right of the origional image (sort of what I'm after). 

When I run a preview/publish, i has squished it up and moved it to slightly to the left of the image. Is it doing the same for you? 


Thanks Allan


Allan House

Thanks, that works if I'm aiming to keep them locked in an identical spot. I feel as though something went wrong with image 30 when it comes to moving it around. 

I tried to reproduce the problem, and when I created a totally new set of images, the behaviour doesn't repeat.  I can move the comparative images anywhere with no issues. Odd. But must just mean I'll need to wipe out my old images and start over. 

Thanks heaps for taking the time to look at this.


This discussion is closed. You can start a new discussion or contact Articulate Support.