Embedded Storyline in Rise - doesn't 'play'

Hi,

First of all I love that we can now embed a storyline file in a rise block.  And even better, we can now use a combination of completion triggers and the continue block to ensure the learner completes the content.

For the most part it works perfectly in our environment.  We use Workday Learning and have had no issues through the Workday App or through multiple browsers.  Until this week, when we launched Workday Learning to a wider audience, and therefore, a wider range of environments.  We now have a situation, where if a learner is using an iPad (<iOS 10), the content doesn't load or play (tested using Safari and Chrome).  Instead, an image of the opening screen with a Launch button is shown.  (see attached screenshot).  The Launch button is active, but nothing happens.  I've also been told this happens on a Mac, however I've been unable to replicate or get enough information about it to understand the conditions it happens.

All other Rise elements work.

Can anyone explain why this is happening, or provide a workaround?

Alison

embedded storyline not playing in rise

18 Replies
Alison Woodage

Yes!  Thank you so much.  You've saved me a whole lot of work and rework.

It's a bit disappointing that learners using newer mobile devices won't have the nicer interface - because it turns out the problem isn't specific to storyline embedded in Rise.  The same thing happens for published storyline content on older devices.

Crystal Horn

I'm glad that helped, Alison!  

Can you tell me a little more about what you mean regarding the "nicer interface?"  Just to clarify, the new responsive player is automatically launched on any mobile device with Storyline 360.

Unless you need to make content available for offline viewing on an iPad or an Android device, you may not need to include the Articulate Mobile Player option.  Let me know if I'm misunderstanding, though!

Jennifer Young

Hey, I just dipped into this discussion because I am previewing a course i made in Rise- with a Storyline block section. The Storyline is not playing when I Preview in Mobile mode. Its playing in Preview mode in all other designs EXCEPT  the Mobile view. Are you saying here that we SHOULD or SHOULD NOT check the "Use Articulate Mobile Player" when publishing the Storyline course? Could one of these settings be the reason its not previewing in the mobile view?

Alyssa Gomez

Hey Jennifer!

Storyline blocks won’t work when you click the smartphone preview icons in Rise, but they’ll work as expected in published output on smartphones. One way I like to test how a Rise lesson will appear on a smartphone is by opening the Rise "Share" link in a mobile browser. 

Give that a try, and let me know if the Storyline Block works correctly there!

Crystal Horn

Hey Jennifer.  Just to add to Alyssa's comment, The Articulate Mobile Player is what we recommended in previous versions of Storyline for courses to look their best on mobile devices. Since we've launched the responsive player with Storyline 360 (and 3!), you generally won't need to use the Articulate Mobile Player.

Mumtaz Badshah Brown

Thank you. I have a storyline file embedded in a Rise Course. When I run the course on my iPad, the storyline file doesn’t seem to open. I chose the format that was recommended and disabled AMP. Please advise.

Thanks,

Mumtaz

Manager, Learning Technology, Learning & Development | ph: 617.673.8788 (Eastern Standard Time| email: mbadshah@brighthorizons.com

[cid:image001.png@01D4AE44.4904D690]<https://mybrightweb.brighthorizons.com/

Allison LaMotte

Hi Mumtaz, 

I'm sorry to hear you're having issues here. The quickest way to resolve this issue is to have our Support Team take a look. You can submit a case here.

Also, just thought I'd point out that when you respond directly from your email, your signature is appended to the message. You may want to pop in there and edit out any personal information that you don't want to share with the community.