Error embedding PDFs in Rise

Good morning!

I wanted to adress a small problem with embedding PDFs from web hosting. Sometimes when loading the courses (like one out of 5) we don't get the view of the embedded content. There is no error code, big red cross, 404, nor anything: it just doesn't show. The frame remains blank. We used several ways to store the archive, from Google Drive to Calameo, even the "articulate user content" link you get when downloading the PDF after uploading it into a course.

The problem gets worse when there are several documents in a row because the chance of at least one of them failing gets even higher.

Is there anything we could do?

 

Thank you very much!

25 Replies
Nicole Legault

Hi there! 

Thanks for posting your question here in the community. Sorry to hear you've run into this issue!

Can you elaborate how you are embedding the PDFs in your Rise course? Can you perhaps share a link to your Rise course so we can take a closer look? You can share it here in the thread, or if you'd like to share privately, you can send it along to our Support Engineers here. 

RISE 1

Good afternoon Nicole.

We have tried 3 different ways of embedding our PDFs. The first one uploading as an attachment, then opening the resulting link (from your hosting service) and copying the URL into the embed code bar. The second one a Google Drive URL, and the third one a Calameo URL. Management didn't want them to show just like an attachment so this would be our last choice. As our courses are private, I'll send you a small sample with copied parts issuing this problem.

https://rise.articulate.com/share/r91pughGrW8KLjijBR9oXt5y2HEB8hUd

 

Thank you very much!

 

Alyssa Gomez

Hello, Angela!

It sounds like you're trying to embed a PDF document in your Rise 360 course, but the embed block appears blank. Is that right?

Where is the PDF hosted? Is it hosted on an internal server?  If the internal server requires some kind of authentication before accessing its content, your Rise 360 course might not be able to pass those credentials.

Brenda Heilman

I am seeing this issue as well with PDF's inserted using the Embed block, but it's sporadic, and when I refresh the browser, it usually rights itself, but the course begins from the start again.  The PDF's are posted on a server within our fire wall which does NOT require any type of authentication, and they are accessible when I type the address into a browser's address bar.  Super frustrating for learners and nearly impossible to troubleshoot.  Has there been any further research or progress on this issue?  :(

Alyssa Gomez

Hi Brenda,

It sounds like you're running into two issues here:

  1. The PDF doesn't load reliably and sometimes requires a browser refresh
  2. The course does not resume where the learner left off

For issue #1, Embedded PDF documents should load without issues if the firewall doesn't require any type of authentication. Is your course hosted on a learning management system? Do you have the same problem when testing the course Share link?

For issue #2, courses should resume where the learner left off if you're using a learning management system. Is that where your published content is hosted?

Brenda Heilman

Hi Alyssa,

1.  Correct.  PDF's do NOT load reliably.  Either in our LMS (PeopleSoft) or in Review 360 or just typing the address in the browser's address bar.  It's sporadic.  One time, the first PDF won't load; the next time, the second one won't load, but the first one will, etc--same results no matter how/where we access the course (Rise 360, LMS, browser).  The firewall does NOT require any kind of authentication as I mentioned in my post above.  I just can't figure this out!

2.  The course does resume where I leave off when refreshing the browser, but only in our LMS.  If we have to refresh the browser in Rise 360 to get the PDF's to display, the course starts over (it also starts over when accessing the course direct from a browser link and refreshing, too, but that was expected).

Here's a Peek video to show you what's happening in Rise 360...having exactly the same issue as in the LMS (except it will return to where I left off when refreshing in the LMS):  https://360.articulate.com/review/content/0197b209-8b88-454c-b1f6-cf6345092e14/review

Crystal Horn

Thanks for those details, Brenda. First, we'd only expect the course to resume when launched from an LMS. I can understand that would be frustrating for stakeholders who are trying to review your course in Review 360 and are encountering the PDF issue.

I'm going to open a case for you with my team so we can troubleshoot why the PDFs are not displaying consistently. You'll get an email from us with some next steps soon!

Jenna Toledo

Hi, 

I'm having the same issue here. I am using the method of adding the pdf as an attachment block and getting the articulate user link to embed in the embed block. I delete the attachment block afterwards. It worked flawlessly before, but this time, like Brenda, it is sporadic in showing up in the embed block. It was embarrassing to showcase to stakeholders when it didn't work, but worked on my end. 

Another issue is that when I click on the pop out icon, the URL is redirected to Google Drive instead of the original link to articulate user. This seems odd because we were not hosting any of the PDFs in Google Drive. 

Do you recommend I support a case as well?

Crystal Horn

Hi there, Jenna. I would recommend using another hosting platform to serve your PDFs since the attachment block isn't really meant to be a way to host web content for embedding in other places. Here are a couple of free and low cost options:

  • Amazon S3 offers free hosting with generous usage limits. If you go over your limit, you'll be charged a small fee. See this video tutorial to learn more about Amazon S3.
  • Google Cloud also has a free hosting service. You'll be charged a small fee if you go over the free limit. See this video tutorial to learn more about Google Cloud.

When you embed content with a URL rather than an iframe embed code, our embed provider, Embed.ly, uses Google Drive to give a preview. You can click "open original" to get to the source URL in the browser.

Hannah R Conner

Hi Alyssa,

Thank you for reaching out! 

Here is one example: https://asupd-curriculum-prod.s3.us-east-2.amazonaws.com/ELA09+2021/Semester+1/Module+1/Honors+Lesson+B/1.Honors+Lesson+B+-+The+Epistolary+Writer+Rubric.pdf

Note that it is intermittent. Sometimes these show up just fine and disappear after a refresh and vice-versa. It happens in “edit” mode, “preview” mode, “share”, and in our published SCORM output loaded in Canvas LMS. Behavior seems equally intermittent in all modes across all of our embedded PDFs. Let me know if you need to look at the Rise course and I will definitely open up a case for that.

 

Thank you!

Hannah R Conner

Hi Hazel. I have also been able to embed it just fine using those steps. I understand those instructions just fine. Similar to the other people posting in this thread, it typically shows up just fine at that stage. Upon later visits, it sometimes disappears (just shows and empty white block) intermittently. And the intermittent behavior is consistent (consistently intermittent, ha!) across edit, preview, published for web, published for LMS and hosted in Canvas. Sometimes it works, other times it's just a white screen. You may or may not be able to replicate the behavior at any given time.

Jessica Velez

has this issue bee resolved.  I seem to be experiencing the same issue.  Added a lesson where I inserted my PDFs as attachments.  I copied the link from each attachment and inserted it into an embedded block within it's corresponding lesson.  Sometimes it works and other times just a blank box.  Please help!  

Renz Sevilla

Hi Karl! To answer your question, the method Jessica shared is a way to show the PDF inline in the embed block in Rise so you don't need to download or open a new window to see the PDF.

1 - Uploading it as an attachment and clicking this opens the PDF in a URL. 
2 - Copying this URL and inserting it in an Embed Block display it inline

Jessica, if you're having trouble seeing the PDF, it most likely hasn't loaded in yet. You may need to refresh or clear your cache so that the PDF loads in properly. 

I've seen this happen with wider PDF files or PDF files that are in landscape mode.

Can you try clearing your browsing data? Here's how to do it for your browser:

Google Chrome

Firefox

Safari

Microsoft Edge

Let me know if that doesn't help!

Frisk Spesialist

Experiencing the same issue here. Tried embedding from several different sites, but still unreliable. I also embed a lot of videos, and those never fail, only embedded PDF's experience this problem. It seems this has been an issue for at least 3 years according to this thread. Hasn't  there been anything done to resolve this?

Frisk Spesialist

Sure, I can share an example. In this example I use the link from an download-block in Rise, I have others from a company FTP-site, but I experience no difference in how reliable they show up on either. It doesnt seem to be connected to the source URL. Heres the link: https://articulateusercontent.com/rise/courses/a2Bh1h90n2ISqFyhCMsX5780M4hi5j_v/iiI8YaXuQC1fPtKF-frisk_oppskriftshefte-min_0.pdf