Rise Translation Import Stuck in Processing

Dec 21, 2022

My Rise translation import is stuck in processing with a spinning circle.

I duplicated the original Rise course, exported the XLIFF file (from duplicated course), generated the translated XLIFF file from a 3rd party, and am now trying to import the translated XLIFF file back into the course. It is stuck in processing as shown in the attachment.

I have tried cancelling and restarting the import, as well as regenerating the translated XLIFF file to try again.

I am attaching a screenshot of the spinning processing circle, as well as the XLIFF file I'm trying to import.


P.S. It is a translation for Arabic (which I know is not supported). My goal is to use the method discussed in this community post as a work around. I have also tried translating the course into Spanish and uploading that xliff file into this course- it also gets stuck in processing.

36 Replies
Crystal Horn

Hi there, Amanda. Thanks for all of that helpful context. I've opened a case so we can have a closer look at your XLIFF file - there could be a formatting issue in the file that is preventing it from being uploaded.

We should be able to get back to you soon with some next steps in an email, but we might be a bit slower due to the holidays. Thanks!

Leslie Barrentine

Hi everyone - After submitting a case for this I found out the issue, for me at least. I exported one xliff file for multiple duplicate courses, this is wrong. You have to export a file for each duplicated course individually - imagine each course having a fingerprint... the xliff and course have to match in order for the import to work. hopefully they update the instruction to be more specific but the case team helped me identify the issue and I figured out a workaround since I already had the translations back.

Leslie Barrentine

my solution (see my issue below) can be complicated without showing so i'm going to be specific. i originally dupicated my course into 3.

course 1 (English (original)) was duplicated to course 2 & 3 and xliff downloaded from original/

- since this is the original course (finger print) i imported spanish, then duplicated and kept duplicate as spanish

-then imported turkish to same original course and kept as turkish

course 2 (duplicate for Turkish) - was still english so i used it as my english course

course 3(duplicate for Spanish) - deleted, not needed

it is complicated but i hope it helps

Thor Melicher
The first place to start troubleshooting is your workflow.  If you deviate from the Rise 360 workflow for translations, you can experience the file not being processed as you described.
The workflow should be:
1. Duplicate your course.
2. Export the XLIFF file.
3. Translate the XLIFF file.
4. Import the XLIFF file into the duplicated course.
If you did anything else along the way (make a duplicate of a duplicate for example) and try to re-import the XLIFF file into the second duplicate, it won't work.
Another common thing that will make an upload fail is if you update the course after exporting the XLIFF and then trying to import it back in.
I hope that helps!
Editing Guest


I have a the same problem with one xlf file (in Russian).

I've duplicated my course, I've exported the course as an XLIFF File, I've imported XLIFF File traslated with Trados, but at this last step, xlf file gets stuck loading. It does not give an error, it just gets stuck loading.

I've changed the font (I've import a russian font).

I've imported also labels traslated, and they work.

The problem arose only for xlf course.

Amanda Roschetzky

Unfortunately no- I never got this worked out. In my case, this was a test course when we were just beginning the translation process, so I didn't actually need it. I feel like I lucked out, because when I tried with a real course, it worked. The test course in this case still wont process.

Gayle Garcia


When a collaborator sends me a copy of a course, can I import that translated text to the copy I was sent?

Colleague created a copy of a course then exported the xlf file for translation.
I now have taken over the work, sent xlf file it to a translation company.
Colleague sent me a copy of the course (now showing my name as the author).

I have been trying to import the translated xlf file but stuck in processing.

Does my colleague need to import the translated xlf file himself on the copy of the original course where he exported this file?

Question 1:  Different author cannot import translated text to a copy of a course that another author sent them?

OR....  Sending a copy of a course changes the fingerprint of the course so the imported file can only be done by the original author of the course?

Does sending a copy of a course change the fingerprint?

Lea Agato

Hi Gayle,

I'm sorry you're having trouble importing your translation into your Rise course. To ensure that your translations are imported successfully, you need to make sure you're in the content from which you originally exported your XLIFF file. The XLIFF file is content-specific, so it can't be exported from one deliverable and imported into another. 

If a colleague sends you a copy of a course, here's what you can do:

  1. Export the XLIFF file from your copy 
  2. Translate that XLIFF file 
  3. Import the new translation file into your copy of the course. 

You also want to avoid editing your course after exporting your XLIFF; otherwise, you could have difficulty importing the translation.

Please check out this article on translating your Rise 360 course.

I hope this helps!

Lukasz Kujac

I would like to ask for a support with the same issue as reported multiple times in this thread.
My issue is regarding one of the modules where translated xliff doesn’t work in each of the 6 language versions i have. All of the correct steps were followed so:
1.Export the XLIFF file from your copy
2.Translate that XLIFF file
3.Import the new translation file into your copy of the course.
I've also tried re-exporting the xliff again and sending the file to our team responsible for translation to process it again. Unfortunately this fix didn’t work as well. 
Is it possible that the Rise file created/duplicated from the original English version is bugged or the source file which I’m duplicating? I would appreciate your help and some guidance to try and resolve this issue.

Lea Agato

Hi Lukasz,

I'm sorry to hear you're having trouble importing your translation file. We'd love to take a closer look at your course/translation file so we can troubleshoot the issue and determine what's preventing your translation from being imported into your course. Kindly open a support case here and we'll reach out to you directly as soon as we can.

I hope this helps!