Carousel Interaction Not Working in LMS

We have a module that uses the Carousel interaction. When previewing it within Articulate or SCORM Cloud, everything works properly. Once the course is published within our LMS (HealthStream), the slide with the interaction is blank. The course is restricted, so there's no possibility to go backwards or forwards, and even though the content isn't displaying, if I try to go forward or backwards I get the notification that  all items need to be viewed before continuing.

Any ideas? I tried it in IE and Firefox and it's blank in both. It works in IE and Firefox in SCORM Cloud.

7 Replies
David Burton

Veronique,

To verify this issue is related to the Carousel Interaction, I would recommend republishing the content and re-uploading to your LMS. If using a FTP client to upload your published content, please make sure this application is set to Binary transfer mode. More on this is outlined in the following link.

Content works locally, but doesn’t load on a web server:

http://www.articulate.com/support/presenter09/kb/?p=1199

If the issue persists, please replace the Carousel Interaction with a simple StairStep Interaction, republish and upload. This will help determine if the LMS is having issues with all Engage Interactions or just the Carousel.

David Burton

Veronique,

When the slide containing the Carousel Interaction is reached, is the preloader shown (spinning segmented circle)?

Because the Carousel works in  the SCORM Cloud, I would agree there is  most likely an issue with your LMS that is not allowing this to work as expected. What happens if your publish the Carousel as a standalone Engage interaction (not inserted into Presenter) and upload to your LMS?

Veronique Brossette

Hi David,

The preloader does not show. The content area is just a blank white screen as soon as the page is reached.

I did publish the interaction as a single slide and it worked perfectly in the LMS.

So I tried moving it to a different location in the course and again it didn't load. When I removed all but two slides (one being the main title slide and the second being the interaction) it worked fine. I left it in that location with the remaining presentation, and it didn't work again.

David Burton

Veronique,

Thank you for taking the extra steps to troubleshoot this issue.

When adding all the slides back in, after it worked with just 2 slides, are there any other Engage Interactions in this Presentation? - (please list what type)

Its quite possible the Presentation itself is corrupt and why this worked with just a few slides. Have you tried repairing the PowerPoint file? More on this is outlined in the following link.

Here’s how to fix a corrupt PowerPoint file

The reason why I have suggested a repair, is because you are not seeing the Engage preloaded when all slides are included. This portion of the interaction is the same as any other interaction and should at least show the preloader if nothing else.