3 Replies
Christine Hendrickson

Hi Nhu!

Do you experience this when you're previewing, publishing, or both?  Also, what browser are you currently using? If you're publishing and using Google Chrome, there is a known issue with some versions of Flash.

Here's some information:
This is a known issue that occurs when using the Google Chrome browser with one of the following Adobe Flash Player versions:
*  10.1.53.38
*  10.0.45.2
*  10.0.42.34
You can determine which version of Adobe Flash Player you are using by visiting this link. If you're experiencing the problem with links while previewing and publishing, make sure you're using the most recent version. If the page above shows you're not using the most recent version, you can download the latest version here.
If you're only experiencing the problem after publishing, you can try viewing the content in a different browser (Internet Explorer, Firefox, etc).
If you've checked the information above and you're still unable to use the links, let us know!
Thanks!
Christine
Tracy Hoang

Thanks Christine

I checked my Flash version and it is the latest (11.4.402.287). I experienced this link problem while previewing and publishing, in both IE and Firefox. Didn't check with Google Chrome.

This wasn't very big an issue as I managed to find a way to work around it (I used Engage hyperlink function instead). But it would be nice to know why this happened - my initial guess was that it had to do with some security features of the Flash player.

Christine Hendrickson

Good morning Nhu!

I'm very happy to hear you were able to find a way to work around the issue. You make a very good point, it may have something to do with Flash, or the way Flash was imported. 

I did find some information on the Adobe site that may help with this, if you'd like to continue investigating. This information isn't provided by Articulate, but I think it might shed a little light on the security settings you mentioned.

The article states:

When text is hyperlinked to a web page (Hyperlink > Open Web Page), the link works fine during the project preview. But, when published, the hyperlink does not work as expected.

Perform the following steps to add the SWF file output file location as a trusted location in Flash security settings:

  1. Click Settings.
  2. Select Edit Locations.
  3. Select Add Location.
  4. Under Trust This Location, enter the location of the folder that contains your published project.
  5. Click Confirm.

I am curious to see if this makes a difference for you. I know the work around may be helpful, but hopefully the above will save you a step in the publishing process!

Have a great day!

Christine