I need a hero! Issue with Engage Navigation - Storyline 360

Feb 06, 2017


I'm having a frustrating time with my engage interactions in my SL 360 presentation. My first engage in my presentation is a Media Tour. I set the Interaction Properties to not show the previous and next buttons, as I have these buttons on the player skin. When I publish the presentation and upload it to Tempshare, I am unable to navigate through or past this engage. I even tried the opposite way (selecting to show the prev/next button in the interaction properties and removing the prev/next button from the skin) but NO navigation buttons appear when I do this — again I'm stuck on this engage.

I don't even know how my other engages are behaving since I cannot get past this first one. It's frustrating that I have to publish the course and upload it to tempshare to see if everything is working. Is there an easier way to do this? Previewing the presentation does not allow viewing engages.

I see that there are some navigation options for the engages in SL 360, but they are greyed out and I'm unable to change them. I've attached a screen shot.

Below is a link to the course so you can see what I mean. Please help!

Thank you.



40 Replies
Alyssa Gomez

Hi Kolton! Sorry to hear you've run into this trouble. Let's see if we can figure out what's going on here. 

Can you confirm that all your files (Storyline and Engage) are located on your local hard drive and that you used this method to import the Engage interaction into Storyline?

It might be helpful if you could share your files here so we can take a closer look at your set up. And since you asked about a faster way to test your file, I would recommend publishing it to Articulate Review. It's an easy way to test your course in different browsers without having to upload a zip file to Tempshare.

Kolton Durkin

Hi Alyssa,

Thank you for getting back to me. I've imported my Engages as suggested. I am on a MacBook Pro but I use VMware to connect to a PC so I can use Storyline. Do you think this may be the issue? I save and work on the .story file on the PC's local hard drive.

Anyway, here is a link to the course. I'm having issues attaching it here.



Alyssa Gomez

Hi Kolton,

No, VMware should not be an issue. The Articulate 360 system requirements show that Mac OS X 10.6.8 or later with Parallels Desktop 7+ or VMware Fusion 4+ is supported, and I actually use VMware on a Macbook myself without any issues. 

Thanks for sharing your file with me. I'll do some testing on my end, and I'll report back once I have more information to share.

Alyssa Gomez

Hi there Kolton,

Thanks for your patience! After looking at your file, I noticed that the Flash output works perfectly, so it seems there's something failing with HTML5. Here's a sample of your content published for Web in Flash. Please test that link and let me know how it looks on your end. In the mean time, I'm going to share this with our Support Engineers so they can investigate this a little further. Keep you eye on your inbox - you'll receive an email from Support@Articulate.com shortly!

Kolton Durkin

Thank you, Alyssa. I'll try publishing the whole thing for Flash so I can present it today while the HTML5 thing gets sorted out.

Let me see how that goes. I've been having some other small issues that I can't figure out (like my note font color will randomly turn orange or white, but I don't see this on the version you published). And is there a way to turn up the audio volume for the Engage slides? It's lower than the rest of the course. 

I'll probably be bugging you with some other things as well. I think once I get everything nailed down with this course the rest that I'm building will be a breeze.

Thanks again!

Alyssa Gomez

Hey Kolton,

I see my colleague Victor has taken your case and is testing your file, so you should hear from him shortly. I also wanted to share another interesting find with you. Currently the navigation in your course is set to Restricted. If you change it to Free, you can move past the Engage interactions without any issue, and it works as expected in HTML5 and Flash. Here's a link to your published content with Free Navigation for you to test.

The font color change you're seeing in the Notes section is likely due to the HTML5 output. You're not seeing it in my version because that was a link to the Flash output. Can you please send me a screenshot of a slide that has the wrong font color and let me know what browser you were using to test the content? You'll want to ensure you're using a supported browser listed here. 

Yes, you can adjust the audio in your Engage interaction. From Storyline, select the slide with the interaction and click Edit in Engage. Once you're in Engage, click on the move icon below the video, then click Volume

I hope that helps, and please let me or Victor know if you have any further questions!

Kolton Durkin

Here is a link to my updated course. I published as Flash only and I'm using Chrome.


The font is still orange. It's dark grey when I preview it in Storyline. 

Also, now the menu is out of order. The course progresses as it should, but in the menu tab the Summary and Conclusion are near the start. The slides are all in order in the .story file. I need to have the navigation in the course restricted since the user must go through the course linearly and at least look each slide/engage.


Alyssa Gomez

I'm seeing the orange text as well, Kolton. Your color settings in the player properties show that you've selected dark gray for Notes text, so I'm not sure why we're seeing it as orange. I'll pass this along to Victor so he can investigate this, as well.

You can reset the menu order by clicking Player > Menu > Reset from story. 

Alyssa Gomez

Hey Kolton!

I wanted to come back around to share that Victor tested the issue in a new file and found that the next button does not work properly on Engage interaction slides when navigation is set to Restricted in Storyline 360. He reported this to our Quality Assurance team, and we've added this discussion to the report. I'll be sure to come back and update this thread as soon as we get any new information from the team on this issue. Thanks for your patience while we tested this!

Kolton Durkin

Thanks Alyssa,

I'm hoping the issue can be resolved soon. These courses go live to over 120 locations on the 22nd. The workarounds just won't cut it for the actual launch, but will work fine for reviews.

I do have another question for you, however. Is there a way to restrict navigation within an Engage? I want the user to watch/listen to the entire media section before being able to move on to the next. All within one Engage. Also, it would be idea if after the media is watched, the user can go back and watch it again without any restriction. Meaning, they can now scrub through the video or skip around. Does that make sense? I feel like this was doable with Articulate 09??

Let me know. Thanks!

Alyssa Gomez

Hey, Kolton. I'm not able to provide a timeline for when this issue will be resolved, but I'll certainly advocate for a fix in our next team meeting. 

And to your question about restricted navigation in Engage 360, you can control how learners navigate through an interaction within Interaction Properties > Playback. Here's how. You'll want to keep in mind that including the Playbar under the video will allow users to scrub forward without restriction, and unfortunately there's not a way to include the video Playbar only when the video is revisited. If you'd like to see an option to restrict navigation the first time a user views an interaction, that's certainly an idea worth passing along to our product development team.  The beauty of Articulate 360 is that we're able to roll out updates pretty frequently, so would you be able to share your ideas in a feature request?  

Kolton Durkin

Hi Alyssa,

It's me again. I'm having the issue with the "this project is invalid or corrupt" message again. This is the second time this has happened, but this time I've lost an entire course that will take me more than a day to rebuild. Can you take a look at the file to see if there is anything you can do?? I have a deadline on Wednesday and this pretty much guarantees I won't make it.

Kolton Durkin

Good  Morning,

So after recovering the temp file for one project, the next project I opened was corrupted. IT set me up with a whole new machine, so hopefully this will stop happening.

The issue that I am having now is till with the navigation. I cannot get the presentation to get past an Engage. I've tried all the suggestions and what I feel like is every combination of navigation options. I can't figure it out.

The ONLY way I have found is to have the prev/next button visible on the player skin and set the presentation settings in the Engage to presentation. This isn't ideal since the prev/next buttons don't work. And I have tried hiding them until the media is complete, but that doesn't work for me either.

I have a deadline tomorrow and I need to get these courses published. Can you please take a look at my project and let me know if I'm doing something wrong?

Thank you again!


Alyssa Gomez

Hey Kolton!

Glad to hear you're getting a new machine, and hopefully you won't run into any more corrupted files!

And you're not doing anything wrong. What's happening here is the issue I mentioned previously about the next button not working properly on Engage interaction slides when navigation is set to Restricted in Storyline 360. This one is still in the hands of our QA team at this time. We're careful about testing new updates to make sure we don't put other features at risk, and I don't want to commit to a date before we have a fix finalized. You're in the right place, and we’ll share as much as we can, as soon as we can!

As a workaround, it looks like shrinking the Engage slide timeline to the shortest possible duration works well. The slide automatically jumps to the next slide at the end of the Engage interaction. Here's a shortened version of your file for you to test. 

Kolton Durkin

Hi Alyssa,

It's me again. You're favorite person. I lost an entire project to the corrupted file issue and wasn't able to find it in the temp folder. However, I know I had sent the .story to you and I think Victor at some point. Would you be able to see if you still have it somewhere? That would be amazing to just recover some of the information. It was the "Menu Masters" project.

Thanks so much!

Alyssa Gomez

Hi Kolton!

The most recent version of the file we have is the one linked in Dropbox here. Are you able to open that one?

I'm sorry that you keep getting corrupted files, and I know that must be extremely frustrating. This definitely shouldn't be happening, and we want to make sure it doesn't happen again. I've opened another support case for you for this particular issue (01022933). We need to get this sorted out so you can finish up this project, because I know you're looking at a tight deadline. Keep an eye out for an email from our Engineers!

This discussion is closed. You can start a new discussion or contact Articulate Support.