Link works in Engage Preview but not when published in Presenter

Hi,

I have created an Engage FAQ interaction and put links on some of the answers. Those that link to a web page are fine, but those that link to zip on a web server behave differently in Engage Preview and Presenter after publishing.

When I preview the FAQ interaction in Engage, all zip links work as desired by opening up a new download window. But when I publish the FAQ to Presenter as a tab, then publish the Presenter and view the resulting course I get no download window. It looks as though a browser window opens then closes immediately before I can do anything.

What do I need to do to make the zip download links work in my course as they do in Engage Preview?

Regards,

Andy

13 Replies
Andy Parker

Hi Brian,

Thanks for the rapid response. The target path is only 70 or so characters, but yes, I am testing locally, mainly because I have not yet figured out how to get the course online. Maybe I need to chat with our webmaster to do this. Am trying to evaluate the products and am very impressed so far.

Andy

Andy Parker

Hi Brian,

I have now published the course to our intranet but still cannot get the zip download links to work. Does an intranet count as online? The same links still work as desired when previewed in Engage but the offending browser windows just open and close immediately in the published course. I'm using IE7.

Sorry for seeming so dim, but this is my first venture into web publishing so am trying to figure it out as I go along.

Brian Batt

Hi Andy,

Do you have any special characters in the ZIP file itself?  Also, please use the following method to update your browser security settings to see if it resolves the issue:

1. Open Internet Explorer.

2. Go to Tools > Internet Options.

3. Select the Security tab.

4. Click on Internet.

5. Click the Custom Level button.

6. Under the Downloads section, change "Automatic prompting for file downloads" to Enable.

7. Click OK.

8. Click Apply, and then click OK.

9. Restart your browser, and test your published content again.

Andy Parker

Hi Brian,

Many thanks for your patience.

I tried the above, with no difference. I also confirmed that the following Windows Explorer option was checked

1 Tools menu

2 Folder options

3 File Types Tab

4 scroll list of registered file types to ZIP and click to select

5 click advanced button

6 in the resulting Edit File Type dialog, check the box labelled Confirm open after download

Also made no difference

If I open the published course from a link in an email, I can open another Articulate course but still get that annoying IE window opened and closed on all the other links.

If I open the course from my intranet web server folder in windows explorer, I can click the zip link from there and open up the zip, can view the other course, but get the open/close window when trying to link to the zip in our public customer portal.

I can probably get around the problem by just linking to the appropriate product information pages in our customer portal rather than the zips themselves, but it is a bit worrying that the course works as desired for for two colleagues (and for me in Engage Preview) and fails for two others (including me).

I also checked my Flash player version, 10.2.152.26 (installed today)

Brian Batt

Hi Andy,

Would you mind submitting a support case to us so that we can take a closer look at the issue?

Please create an Articulate Presenter package, then upload the zip file to our server. You can review how to do this here: 

Send to Articulate Presenter Package – Articulate Presenter ’09 Help

Upload the resulting zip file from your computer to our server using this upload form: 

Articulate Support - Upload Your Files for Review 

Please be sure to include a description of your issue, your version of PowerPoint, version of Windows and version of Presenter '09 which you can find in Help and Support -> About Articulate Presenter. Please also include the URL for this thread so we can follow up with you in the forums.

Brian Batt

Hi Peter,

I would suggest you submit a case by following the steps below.

Please create an Articulate Presenter package, then upload the zip file to our server. You can review how to do this here: 

Send to Articulate Presenter Package – Articulate Presenter ’09 Help

Upload the resulting zip file from your computer to our server using this upload form: 

Articulate Support - Upload Your Files for Review 

Please be sure to include a description of your issue, your version of PowerPoint, version of Windows and version of Presenter '09 which you can find in Help and Support -> About Articulate Presenter. Please also include the URL for this thread so we can follow up with you in the forums.

peter collins

Thanks, however, I don't think it is the file as I have the same problem with 6 different projects. They all worked a few weeks ago to my knowledge but now don't work on some pc's. We have about 3000 pc's across our organisation all running Internet Explorer 7 and the player.html file sits on a Sharepoint server.

Brian Batt

peter collins said:

Thanks, however, I don't think it is the file as I have the same problem with 6 different projects. They all worked a few weeks ago to my knowledge but now don't work on some pc's. We have about 3000 pc's across our organisation all running Internet Explorer 7 and the player.html file sits on a Sharepoint server.


Hi Peter,

It's possible that your IT group changed a global policy in Internet Explorer that is now causing the issue.  So, you might check with your local IT group to see if they changed anything.

Also, did you try changing the IE security settings yourself to see if they make an impact.  Here are the instructions again:

1. Open Internet Explorer.

2. Go to Tools > Internet Options.

3. Select the Security tab.

4. Click on Internet.

5. Click the Custom Level button.

6. Under the Downloads section, change "Automatic prompting for file downloads" to Enable.

7. Click OK.

8. Click Apply, and then click OK.

9. Restart your browser, and test your published content again.

Please let me know if there's anything else that I can do.