Error in uploading articulate course in moodle

Hi everybody,

I am using moodle 1.9.2 and Articulate studio. I tried to upload a course with some interactions as adding resource (link to file or web site) but as I select the .zip file the upload stopped with following error:

internet explorer has stopped working

I already uploaded a file with this method without problems, the only difference in this last one is that I have a flipbook interaction. Could this give some problems?

I could not upload them as Scorm activity, as both presentation freezed after starting.

Is anybody able to help me?

Thanks a lot.

SIlvia

24 Replies
Heather Dickinson

Hi guys

Thanks Silvia for posting your question.  I'm having similar trouble.  I'm new to both Moodle and Articulate.  Last night I followed the instructions posted on this site back in 2006 about uploading the zip file into Moodle.  I followed the instructions and all worked well....execpt.....none of the Articulate Engage interactions displayed - blank screen.  Like you Silvia, I've also incorporated the flip card interaction.  A blank screen turns up when it comes to any of the Engage activities.  I would have the latest versions of both Moodle and Articulate given it was only downloaded about a fortnight ago.  I'll check out the link Phil and Brian talk about above to see if that fixes my problem.  Any other ideas why they're not working?

Thanks

Heather

Heather Dickinson

Well, it turned out to be user error (me of course!).  I had a little housekeeping session with my files on Tuesday night and turns out I moved my Articulate interactions from where the program was looking so when I published the file, it didn't pick up the interactions and hence didn't play in Moodle.  Just sharing this with you in case some other non-IT person makes the same silly mistake.  Lesson:  keep the PowerPoint file and any Articulate interactions in the one folder/location.  Thanks to Dean at eCreators in Melbourne for over an hour of his help.

Silvia Vantusso

Hi everybody,

I only would like to answer to Phil and Dan as I just tried with a test version of moodle (1.9.12), but with same result. The course stops, hangs, no chance to use mouse. And an error appears " error- unable to acquire LMS API".

Silvia

Phil Mayor said:

Dan is right, if I remember correctly 1.9.6 or 7  was the first release where scorm was reliable in Moodle.

I would laso remember to include the articulate moodle fix on your machine to ensure articulate tracks your scorms correctly

Phil

Dan Marsden

Hi Silvia,

you haven't really provided enough information here to help - does this happen in all browsers? - if not what browser does it occur under, are you using the setting to open the SCORM in a new window or the current window - try loading your SCORM in Firefox with Firebug installed and check to make sure no Javascript errors are occurring while viewing your SCORM (search on Google for details on how to do this)

Phil Mayor

Hi Silvia, I think Dan is going to be your best bet at finding a solution.

We are curently swiching over to Moodle 2 and having a few issues.  Our solution is to get moodle to open in the same window then use the articulate launch page to enable a new window.  This seems to work and we dont get these errors

In 1.9 I am unsure what is going on, for some users when they use the enter button they get the same issue as you.  If I login as them I get the same problem even on different machines.  If I login as me and access the same course I dont get the error.  If I force them to skip the contents page they do not get the error.

Starnge but true

Phil

Silvia Vantusso

Hi all,

I wanted to add another detail. I tried just with Firefox and it works fine (SCORM package).

This test doesn't solve my issue as the customer has IE, but it is just an info for you.

Just the last question. If I select in Articulate Launch presentation in new window (creates launch page) how shall I behave with other 2 selections (allow user to resize browser and Display window with no browser controls)

Silvia

Silvia Vantusso said:

Hi Phil,

I will try today as suggested and afterwards I let you know. Moodle has already set open in the same window. I just need to change in articulate launch page in a new window.

Thanks again for your kind support.

Silvia

Silvia Vantusso

Hi Phil. No chance. I just tried.

Setting in moodle open in same window and in Articulate Launch in new window. My browser stopped totally and I needed to kill the task from task manager.

Just a small recap:

IE 8 as browser

1.9.12 as moodle version

File uploaded as SCORM Package

I have no words...

A new debug file has been produced. Do you need it?

Silvia

Phil Mayor

you could add it to the frontpage on your moodle, turn on editing add a resource, link to website or file,  then upload the zip , when you upload right click the file in moodle  to copy the path  the path and paste that into a pm, do not complete the resource on moodle and the link will not show on your frontpage.  I will then be able to download it

Phil