Hyperlinks to attachments - slashes defaulting to backward slashes

Hi everyone,

I have built a course with hyperlinks in the ppt slides to attachments in pdf.

I have added the 'data/downloads/' add-on at the start of the path. All loads well and I can go on and test successfully.

What's happening is after the fact I go back or forward files for proofing and the forward slash is defaulting to a backward slash, which breaks the link.

Does anyone know why this would occur?

I get a message saying I'm not publishing to a local drive - I publish from and to the same server?

e.g.:

“Data/downloads/Attachment%20OHS%20Act%20Section%202.pdf”

becomes: 

“data\downloads\Attachment%20OHS%20Act%20Section%202.pdf” .

Thank you!

Xanthe

5 Replies
Brian Batt

Hi Xanthe and welcome to Heroes,

Unfortunately, there is a bug in PowerPoint that is causing your issue.  However, there are a few workarounds that you can try:

First, you can use a URL shortener like tinyurl.com to create a relative hyperlink per this post:

http://www.articulate.com/forums/72070-post2.html

Another solution that I've heard about is saving the presentation as a PPT file instead of PPTX file.

I've also heard that this solution works as well:

http://www.articulate.com/forums/84346-post4.html

Xanthe Loyer

Hi Guys,

This macros looked good... but I just want to add this link from your website (incase others pull this post)

http://www.articulate.com/support/presenter09/kb/?p=907

When publishing to an LMS with a course with a hyperlink to a pdf, we've learnt that one has to copy the pdf to the player folder, after publishing - oh the joys of learning!

This probably takes out the need for the macros as one is just required to paste the name of the file, not browse to the file when hyperlinking. - we're still tetsing. I should have indicted that we are publishing  to an LMS.

Thank you!

Xanthe