Email Quiz Results - Not Working

I have my email address keyed into the Pass and Fail Result areas so that the results will come to me.  I've tested it twice now.  I'm not receiving the email.  It's not in junk mail either.  Microsoft Outlook is set up as my default email on my system.  Any ideas?  Also, I'm curious about this.  If someone is taking a quiz and they do not have a default email on their system, maybe they just always login to Yahoo or Gmail or something, will their be any problem in their results being emailed?  Thanks.

26 Replies
Peter Anderson

Hi Brock,

You can learn more about reasons for the emailing results feature not working in this article.

There is also a known issue where the email results feature in Quizmaker '09 does not work if a quiz contains 13 or more questions. Depending on the browser you are using, you may experience a blank email, or an error may occur. Our Quality Assurance team is investigating this issue. In the meantime, the only workarounds are to reduce the number of questions in the quiz to 12 (or fewer) or to disable the email results feature.

Brock Culpepper

I just tested my second question.  Without a default mail client installed on the computer, the results cannot be emailed.  I still don't know why I'm not receiving the results from the computer I took the quiz on that has Outlook installed as my default mail client.  Maybe it just takes a long time to come in...I don't know.

Brock Culpepper

I looked at the article.  It recommends using an LMS system.  We have that, and it will track who passes/fails the quiz.  3 of the questions are survey questions and an individual needs those emailed to him personally.  Is quizmaker setup so that the results of the quiz are not reported until the Finish button is clicked?  If I hide the Finish button and only have the Email Results button, will the course actually show as complete, or is the Finish button, when tracking by the Quiz what sends the results to the LMS?

Bud Keegan

Peter Anderson said:

Hi Brock,

You can learn more about reasons for the emailing results feature not working in this article.

There is also a known issue where the email results feature in Quizmaker '09 does not work if a quiz contains 13 or more questions. Depending on the browser you are using, you may experience a blank email, or an error may occur. Our Quality Assurance team is investigating this issue. In the meantime, the only workarounds are to reduce the number of questions in the quiz to 12 (or fewer) or to disable the email results feature.

Peter-- any update on this?  I have an online assessment as part of an association certification process-- we are hosting on Articulate Online-- we're going live shortly and this is a real problem.  I could break it up but, but... why should I have to?  Please advise-- still love Articulate (and waiting ever so patiently for that new version of Articulate PLUS Storyboard!)
Dimitrolos Krajci

Hi Peter, quiz results not being sent by email with pushing the appropriate button on the result page is an old problem that is still not being solved by Articulate. There are several workaround recommendations on this blog, including self-promoting offer of Articulate Online service, but I still believe, that this in-built function of Quizmaker, that has been purchased with the licensed software, should be working without problems, at least after the first or second upgrade of this release of Articulate Quizmaker 09. According to experience of our webmasters in our environment, this malfunction is not dependent on any antivirus or security restrictions of our PC systems. We do not want to have LMS on our PC equipped teaching lab, we do not want to purchase any extra services to be able to record student's results outside of their monitor screens, we do not want to use any unsupported workarounds, we just wont the Quizmaker to work in one of its inherited modes correctly. Isn't a right time now to rectify this old problem? Sorry for this inpatiency. Thanks for considering this call for help.  Dimitri

Justin Wilcox

Hi Dimitrolos.

Sorry to hear about the difficulty. Unfortunately the way that Studio '09 handles email results will not be updated in its current form. There are issues with using this feature as noted here. We are aware of the difficulty some folks are having and we will be looking at how to better handle this in future releases.

Christie Collins

Same old problem and it's several months post the previous discussion on this issue. This is what happens when a company has a near monopoly on a product. I've spent way too much time on this issue trying to get it to work. I will be using another quiz option and quite frankly, my organization should get some money back because you're selling a product with a known defect.

Justin Wilcox

Hi Christie and welcome to Heroes! Emailing results will work in some environments just not all. If it doesn't work in your environment you may want to consider using a traditional Learning Management System that supports SCORM or AICC or Articulate Online. You can also allow users to print their results. The email results that we send are only raw comma, delimited data so it won't actually tell you anything until you import that text into Excel or some other application that supports comma delimited data. 

Doyle Meyer

I agree with Christie and add that the print function has never worked at for me. If you are not planning on fixing this problem, have you fixed it in Storyline? I notice there are similar posts in the Storyline threads. 

Is there a way for me to at least print the results?

I read the server side workaround but am not enough of a geek to understand it. Is this a fix that takes place on the customer's system?

Doyle Meyer

Thanks for responding so quickly Peter, but that does not address my problem. I can't get the quizmaker results to either print or email. That means that a product I was ready to deliver to a client is not acceptable.

I need a solution! You said that it may be a security or settings issue with the browser or network. I need to know what the issues are. What security and browser settings will make the published product work for a client using IE? 

The only thing that I have changed on my computer since Quizmaker stopped working is deleting cookies and temporary internet settings. That is not something I can role back. 

Until I have a solution to this, I can't ship any product produced by Articulate. I need help now.

Doyle Meyer

The send email report thread is very long and has too many variables.Articulate's comments almost all go back to Brian Batt's tutorial.Unfortunately, the tutorial used the Quizmaker stand-alone file quiz.js as the starting point.The recommended downloadable 'flashcommand.js' appears to never use the"sendmail.php" and is significantly different than "quiz.js. They only use "Post" action =  "mailto:'+ g_strEmail + '?subject=' + g_strSubject + '"enctype="text/plain">'; or "Post" action =  scorep.php. I have yet to find "sendmail.php in any of the flashcommand.jsfile.

I've changed the "Post" action= functionwherever I can find it, but when I do, the browser either comes up empty or with an errormessage that "scorep.php" cannot be found.

I need a step by step fix for this. I find it difficultto believe you've known about this problem for years and have not come up witha definitive solution to the problem. This is a significant feature ofQuizmaker with an obvious problem.

Thank you for your anticipated response.

Could or has someone come up with a tutorial like Brian Batt's, but one that assumes Quizmaker is embedded in Presenter?

Judy Miller

Was this issue ever resolved? I've got multiple quizzes in my training product and the function was working properly until today.  I received quiz results for quizzes that had ~ 25 questions with no problem and was able to download them into a spreadsheet, etc. Today - all of a sudden, when I click the email results button after completing the quiz, my browser stops working and wants to shut down.  Like others in the above thread - I need this functionality as it was promised to the client and this is how we are tracking completion of the training...AND I've already demonstrated how well it works!  Just tried to submit this issue but the 'Case' website wasn't working right.  Help!

Judy Miller

Evidently, the Email Results feature does not work with Internet Explorer 10 (which is what I recently upgraded to).  There is also a problem with it working if the security settings on the user's default mail application won't allow it.  This is also the case for me as our client is with the US Government.  It actually appears to work, but the email never gets sent.  I've also been told that this feature will not be supported in future versions of Articulate which is very frustrating.  We're having to use a workaround of making users send scanned copies of their Certificate of Completion (which displays when they successfully pass the test).  This doesn't give me the ability to view the quiz results (i.e., to see what questions are giving users the most problems...one of the metrics we promised our client.).  As a workaround for actually getting that data from a Course Evaluation - we're using a fillable Adobe PDF form that the user will have to manually send to us.  Not what we have in mind but until the client decides to use a LMS, it appears to be the only choice we have.

Leslie McKerchie

Hi Judy! Thank you for providing an update to the community on the status of your issue. Sorry that you are frustrated though. Due to the fact that the e-mail results are out of our control with relying on various mail programs and security restrictions makes it hard to support. I am glad that you found a workaround in the meantime. Please let us know if you need anything further.

Shawn Sharkey

I am a sole proprietor that invested in Articulate Studio 9.  I am a bit agitated that Articulate won't fix the email results feature in the 09 bundle.  I run a small shop and spending $1400.00 for the newest and greatest just isn't an option for me in this small business climate. I think that Articulate should create an update to make the feature work in the Studio 09.  I hope you guys aren't going to start acting like Microsoft. By that I mean push to put something new on the shelf and when it doesn't function correctly you abandon that to develop something else new.