Moodle: Quiz is frozen with red bar at bottom

We are using Moodle and everything works great until we reach the quiz as shown below. We have been using the SCORM packages on our moodle server for a few weeks now, for the most part many people are able to complete the videos and quiz with no problem but a few are having problems, like this one:  This person finished the slides and got to the quiz at the end and they get a screen like this, I had never seen this in testing it. The problem is that you cannot click to select true or false. You can click the x on the red incorrect bar but then nothing. What could be the issue?

 

16 Replies
Daniel  Feerst

We have not tested in the cloud yet.. Do you know if Tin Can API is
preferred for Moodle over 1.2 SCORM?
We are using SCORM 1.2. Some people ARE HAVING SUCCESS. So, is this a
browser issue?

Website: http://workexcel.corecommerce.com
Catalog: www.eaptools.com/1.pdf

Daniel A. Feerst, MSW, LISW-CP, Publisher
DFA Publishing and Consulting, LLC & WorkExcel.com
P.O. Box 2006
Mount Pleasant, SC 29465-2006
(843) 884-3632; FAX (843) 884-0442
publisher@workexcel.com

Emily Ruby

Hello Daniel,

 Is this showing up the first time they go through the quiz? Have you tested this file in the SCORM Cloud to see if you get the same issue? There are plenty of members who use Moodle on here, so if they have other suggestions in the meantime, I am sure they will jump in.

Dan Marsden

SCORM 1.2 is supported in the core Moodle release, the Tin Can API is not officially supported but there are some good 3rd party plugins that allow Tin Can to be used with an external LRS like Learning Locker that are quite good. I've also got some proof of concept code that implements a Moodle LRS based on some code that someone else wrote that some people tell me works ok but I wouldn't run it in production myself.

I would suggest trying to find as much information as possible on how to reproduce the issue - if Browser of flash player versions are the same - I'd then try to reproduce the error with debugging tools that show JavaScript errors. If you can't figure this out you could try to engage a Moodle Partner to help debug the issues for you.

Christie Pollick

Hi, Bola -- Sorry to hear you are having difficulties! As this thread is somewhat dated, you may feel free to reach out to individual participants directly using the 'Contact Me' link on their profile pages. Or, you are welcome to share more details of your situation if possible so that other Moodle users in the community can weigh in with their ideas and advice. 

Annette Fuchs

I am having the same issue and from what I have learned, it is a problem in the Articulate software that needs to be fixed?  Spent a lot of time with frustrated people on this one at my own expense.  It is a random issue, and not always desirable to have to tell end-users to try tabbing, clearing cache etc.  Is there anything current on this issue to indicate that it will be solved soon, or a solution that we as Articulate product developers can do to fix this?

Justin Grenier

Hi there, Annette.

Although we've been unable to consistently reproduce or isolate the root cause of this problem, the few times we've seen it happen were always after suspending and resuming a course.  This seems to indicate a problem related to suspend data, which you can read more about here.

To wager a really wild guess, I suspect that the data being returned by your LMS upon resume is not the same data that your content sends upon suspend.  To prove this out, you'll want to enable LMS Debug Mode and capture both (a) the learner's first (suspended) attempt at the course and (b) the learner's second (resumed) attempt at the course.  You can send those logs to us here for closer examination.

One other thing we've seen is that your affected learners may be viewing the content in an unsupported environment (such as HTML5 in IE or Firefox on Android), at least on their first attempt.

Of course, the challenge here is always to catch the problem in action, in an environment where LMS Debug Mode has been enabled.  It's sometimes difficult to gain buy-in for debugging in a production environment, and we often aren't watching for the problem until after it happens.

Good luck with your project, and please let us know if we can help in any way!

Julien Camus

Hi Dan, not sure this is exactly the same issue I've had for weeks now without success solving it. On all browsers but Safari, the last question of all our quizzes freeze on it's result slide and don't go to the fianl quiz result slide. It freezes for 20-30 seconds before it unfreezes. Going back a couple questions thanks to the "Quesiton List" and then clicking next to get to the last question then make the quiz result slide appear.

Note that the issue only happens when a user passes the quiz. Not when it is failed.

I've upgraded to moodle 3.2.1 today hoping this would solve the issue. Nope!

I also tried your suggestion with Site administration > Plugins > Activity modules > SCORMfind the setting " Enable SCORM 1.2 standard mode" and untick the box. Did not change anything.

Your colleague Eloisa posted our quiz on one of your moodle installs and it works there. Opening the "Console" in Chrome, I can see one difference between my quiz on my moodle and my quiz on your moodle: on mine, two lines are called (and seem to block) that are not called on your moodle:

1) datamodel.php

2) prereqs.php

See print screen attached... I really hope someone can help. Our students complain all the time!

Thanks!

Julien

Ashley Terwilliger-Pollard

Hi Julien,

Thanks for reaching out here too and I just saw your post here as well. I gave Eloisa an update about the information you shared in that other discussion so that we could continue to provide assistance on the difference between the course you had published and hosted in Moodle and the one she worked on. 

I'll follow along in the case so that I can share updates here as well.