Some of my Quizmaker '09 quizzes won't convert to '13 format

Dec 19, 2013

I submitted a case (#00367725) to Articulate support over a month ago. After verifying that the issue below could be replicated with '09 .quiz file provided, Articulate support forwarded the issue to "Quality Assurance" on November 14. I have received no reply or resolution since then, and I am hoping somebody out there can help me since we have a commercial course that is waylaid due to this verified bug.

1. I try to open the 2009 quiz, and QM reports that it is an old quiz, and asks if I would like to upgrade (as usual).
2. I click yes.
3. A lot of disk activity happens for a while, and the upgrade bar appears in the lower right corner of the taskbar. However, it does not say "upgrading quiz" as it has with other successful upgrades.
4. A lot more disk activity occurs for about 5 - 7 minutes until the upgrade bar disappears.
5. Then disk activity stops, and QM just freezes, requiring a Task Manager close.

Resolutions and tests:
1. I reinstalled/repaired Studio '13.
2. I re-opened and successfully reconverted previously successful larger quizzes from the previously generated backups. No problem

3 Replies
Christine Hendrickson

Hi Allen,

I've reviewed the case (thank you for sharing the number!) and I've also taken a look at some of the testing that's been done with the file with our support team. 

Out of curiosity, have you tried cutting down the quiz file size? From what I'm seeing it's a fairly large project and that may be contributing to the issue. 

I know that's not a solution to the problem, and our QA team is definitely looking into this. However, in the meantime, it may help to break the project into multiple quizzes and then bring them over to '13.

I'm following along with the support case and the QA testing for this issue. We'll keep in touch through the case and I'll also keep an eye on this thread. Though I cannot give an estimate, hopefully we'll hear more regarding this soon.

Also, please let me know if splitting the project helps. If you no longer have access to '09, I can try to test this on my end, though there may be a little delay as I don't have that version installed on this machine.


Allen Keele

Hi Christine,

Thanks for taking this up. I have two other '09 quizzes from the same series that are about 40% larger at 143 MB and 103 MB, and they both converted with no problems. I do not have '09 on my machine any longer either, so I cannot try your idea to split the problem quizzes down to smaller sizes. However, I have my doubts that this will work since I have already been successful with much larger quiz conversions.

My suspicion is that there are some '09 question types such as the random matching/drop-down that are hanging the conversion to '13. Naturally, this is in your engineers hands to test.

After 6 weeks of waiting, I am beginning to lose faith in using Articulate fo professional LMS courses. All software has issues, but 6 weeks without a fix is frustrating, as I am sure you can empathize. I hope you can provoke a fix from the Q/A people .

BTW - the other issue with themes not applying to '13 quizzes persists, despite heeding your advice regarding file lengths (I was already staying within the guidelines from my years of publishing with QM '06 and '09).

There is not a specific theme that will not apply. No themes - even Articulate built-in themes - will apply to the quiz feedback master of any  converted '13 quiz. Themes apply to the slide master okay, but not with the feedback master. I suspect an issue has been created within the quiz itself during Articulate's suspicious conversion process. Again, this is beyond me to test. I can send you a successfully converted QM quiz to play with if you wish. Just message me where to email it or to upload it. My primary concern, however, is the issue above.

I hope to get positive feedback.

Christine Hendrickson

Hi Allen,

I've been testing the 3 of 4 assessment this morning. I think I may have more information to pass over to our QA team at this point, which is certainly a good thing. Hopefully this will help with any additional testing that needs to take place.

First, I decided to go ahead and try to open the file in Quizmaker '13. When I did this, the progress made it to about 50% and then Engage crashed. I was already expecting this, I mainly wanted to see how far the progress made it, before the crash occurred. I then decided to try importing the questions from the original file into a new file, using Quizmaker '13. 

When importing, the progress made it to about 75% before crashing. I closed the program down, but as I did so, I noticed that a huge list of questions flashed before the program shut down. I thought that a bit odd, but maybe a sign that the questions were carrying over.

So, I tried importing again and simply closed out the crash splash screen. I noticed that the file size had changed and that the title of the file had changed as well, but no questions were in the list. I changed the view of the open project by opening the Feedback Master (View >> Feedback Master) and switched back to the question list. I can see questions 1-81 in the list now.

I am able to navigate through the questions in slide view, but I'm not able to save the file, even under a new name. When I do, I see the error "The project file could not be saved. Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: index". 

I moved to another machine and opened the original quiz in Quizmaker '09 with no trouble. I can see in this file that there are 223 questions - that's quite a difference. I created a new, blank Quiz in Quizmaker '09 and imported the existing questions into this new file. I saved (under a new, short file name) the file and sent it to myself on the machine with Quizmaker '13. This file was 104 MB. I had the same results with this file.

I went back to the '09 machine and imported questions 1-81 (since those were the ones that showed up initially) into a new quiz. The good news is that the progress made it to 100% this time, both when attempting to open and importing, but still resulted in a crash. I cut the file down even shorter - to 75 questions - this cut the size down to just 38.5 MB. 

  • The file opened successfully in Quizmaker '13 at 75 questions.

Obviously not where I would have preferred, but I'm thankful to see it did, at least, open. I was also able to preview the quiz questions successfully. 

I did the same again, this time using questions 75-150. The same crashing occurred. Now I think it's safe to say that the size may not be the issue - I'm thinking it may be a specific question or questions causing the issue. At this point, I'm thinking it's a question around the 80 mark - since this is where the import crashed on the initial attempt.

I tried again with 75-150, but this time I skipped questions 81 & 82. This crashed even faster than the earlier attempts. So, I tried again, skipping questions, for questions 90-223.

Unfortunately, this file crashed as well. However, I will be relaying all of this information to our QA team. 

If you'd like, I would be happy to send the file to you that contains the 75 questions. I know this may not be the entire project, but hopefully it will help. Just let me know and I can send you a private message with the details. 


This discussion is closed. You can start a new discussion or contact Articulate Support.