After I restart my entire course, multi-select question answers cannot be clicked

Hello again,

Glad to say I have finished an entire e-course and everything works fine.

In the end I have a quiz and the button "retake quiz" works fine as well.

But my "restart course" button although it works fine when clicked(really restarts the whole course and goes to the first slide). After a couple slides when some "chose the right answer out of many" questions start (prior the quiz) I cannot click the choices.

Why is this happening? 

 

edit* for me this is happening both in preview and published versions of my course.

7 Replies
Ashley Terwilliger

Hi Andreja,

Have you already checked through the triggers to ensure that the "reset results" trigger is also associated with the "restart course" button in addition to the "retake quiz" button?

If so, and you're still running into issues, can you share a copy of the .story file with us here? You can upload it using the "add attachment" option. 

Andreja Popovik

Yes I have checked and I believe on my side that the triggers are fine. I believe this may be some issue with the software but in both cases we can both learn from this so I am attaching it so you can see. After restart I am experiencing the issues for example on slide 5.1 where the questions prior the quiz start. I just can't click them although the first time I ran the course they ran just fine.

Andreja Popovik

I tried this. It did not work from the preview mode since it is preview and the URL part there is disabled. I tired with publish mode it gave me an error it could not find the link even though it was put where it needs to be. And then I tried running the course in the browser it gave me an error that my browser does not allow it. I ran it in Chrome (but maybe another browser will?!). 

So thank you for the effort but this did not help me.

Nejc Žorga Dulmin

Andreja, notes about the links:

1. Link needs to be relative, which means you need to put only "story.html" in the link. Delete all C/users ....

2. There are options for links in the trigger (click on the far right icon) - change the setting to open in the current browser window.

3. Upload to a server and test there, I also get the error, that links don't work locally.

Andreja Popovik

Hello again Nejc. Thank you for explaining further how I should state the link. This actually helped.

Even when I opened it locally through the player in the end it restarted in the browser but it actually restarted as it should, so for now this is ok. I will use this as is for the time being and yes momentarily this solved my issue. But I still believe that this is an issue with the software that needs to be looked into. I will also see what Ashley says about this, but thank you.

You did help me!