AMP/Tin Can/SCORM Cloud/Resume feature trouble

I looked for awhile and although found a lot of good information, have not found an answer as of yet.

  1. Publish for iPad using AMP and Tin Can.
  2. Tracking via Results slide thus I understand that gives the info to the LRS.
  3. Player set to ignore Flash cookie (also tried other way).
  4. Zipped course for AMP uploaded to SCORM Cloud.
  5. Distributed via html link.
  6. On iPad 2 or latest iPad, course runs.
  7. Try to run course again, it does NOT resume.
  8. Now I am not sure the best way to leave and come back, but I just hit the round Home button.  Then click the URL again, at it goes back to the same place, the beginning.
  9. NOTES: Tracking does work, course launches, also using latest update.

Any thoughts on why Resume is not coming up?  Thinking perhaps since ignore Flash cookie is set, that it depends on the SCORM Cloud LMS to resume to where it left off.  Not sure though.  Thanks all!

7 Replies
Ashley Terwilliger

Hi Jeff,

Thanks for sharing the detailed info here - you mention that it doesn't resume, but at what point within the course have you left and then tried to resume? There is a known issue where if you've met the completion requirement the course may not resume as expected.

Another thought may be, is the course is resuming to a "random" slide, it's possible that you've met the Suspend data limit which, even though the suspend data is compressed could still occur with a rather large course published for SCORM 1.2.

Lastly, you mentioned the "best way to leave and come back, but I just hit the round Home button" - can you try closing the browser and then opening a new browser window and opening the course link again? 

Jeff Forrer

Hello.  Thank you for your reply.  I will do my best to answer your questions.

  1. I have tried to leave at any point in the program, slide 2, the last slide, any, and every time it restarts.
  2. The course always resumes to Slide 1.  I have 13 courses, they all behave the same way.
  3. I have tried to upload a new course, new name, new content, start from scratch, no better result.
  4. I left using the Home button because this course is running using the AMP (Articulate Mobile Player) and is launched from the LMS.  So to get out, I need to hit HOME, this closes the AMP session.  Then I re-launch from a distributed link from the LMS, or directly from the LMS, and it always starts over. 

Thank you for any further assitance

Ashley Terwilliger

Hi Jeff,

If you're always resuming to slide 1, it sounds like the Resume behavior is not working at all (either set within Storyline or using the LMS flash cookie)? Although, I'm unsure from your testing notes, if you've used "Always resume" or "Prompt to resume"? Also are you using Storyline update 5?

Could you share one of the courses with us so that we could take a look? 

Jeff Forrer

Hello, thank you for your reply. 

  1. I have tried publishing to SCORM Cloud with both options of the ignore Flash cookie option checked and unchecked.
  2. The Resume feature is always set to "On restart: Prompt to resume", but it never comes up when returning to the course, I never see it as I do when the course is running on a web server outside of the SCORM Cloud LMS.
  3. I am using update 5.
  4. I can send you an invite to the course via a SCORM Cloud invite.  Can I send an email invite to you?  If so, let me know.  Thank you.
Jeff Forrer

Hello.  I sent you two invites to the course on SCORM Cloud, one with and one without the Flash cookie in the player selected.  Let me know what else you may need, I did send the SL source earlier today, thanks.

Also, please see below, I did email SCORM Cloud support as well the other day, here is their reply if this helps at all.

-------------------------------------------------------------------------------------------------------------------------------------------------------------------

Hello Jefe,

Thank you for your patience. So, this one could be interesting...if you are launching through an LMS, you definitely want to use Tin Can in this scenario. I am not sure why resume wouldn't work though. It sounds like you are choosing all of the right options. Can I take a look at your tin can?

Thank you,

Joe


Jefe, Feb 12 04:01 PM:

Hello, I posted this to Articulate as well, any help greatly appreciated.
I think perhaps maybe I am just distributing the course wrong? I don't
think there is a way for a user on the iPad to launch a course in the AMP
(Articulate Mobile Player) in lieu of using a browser?

Here is the note I sent to Articulate:

I looked for awhile and although found a lot of good information, have not
found an answer as of yet.

1. Publish from Articulate Storlyine for iPad using AMP and Tin Can API.
2. Tracking via Results slide thus I understand that gives the info to
the LRS.
3. Player set to ignore Flash cookie (also tried other way).
4. Zipped course for AMP uploaded to SCORM Cloud.
5. Distributed via html link.
6. On iPad 2 or latest iPad, course runs.
7. Try to run course again, it does NOT resume.
8. Now I am not sure the best way to leave and come back, but I just hit
the round Home button. Then click the URL again, at it goes back to the
same place, the beginning.
9. NOTES: Tracking does work, course launches, also using latest update.

Any thoughts on why Resume is not coming up? Thinking perhaps since ignore
Flash cookie is set, that it depends on the SCORM Cloud LMS to resume to
where it left off. Not sure though.