Answers disappear upon making them shuffle

Hi,

I have this project that I have been working on since SL2. Ever since I have updated my current version of  SL360 and I preview or publish my course the answers on my quiz slide are not visible. But if i disable the shuffling of answers they are visible, what can be the problem. View video attached

8 Replies
Ashley Terwilliger

Hi Kennethg,

That video and description sound really similar to an issue our team is looking into now. In those situations, the answers are hidden behind a background graphic if you've set the answers to shuffle in our latest releases of Update 17. You'll see this occur in Preview, Chrome, Microsoft Edge, Safari but it's working as expected in Firefox/IE11. 

While our team investigates this, there are two other workarounds (outside of using the Firefox/IE11 browsers):

  • Change the Shuffle behavior to None
  • Remove the background shape or graphic

I'll also keep you posted on this issue here, thanks for reporting it! 

Leslie McKerchie

Hello Kennethg and Dario,

Great news!  We just released another update for Articulate 360, and included a few important fixes that you'll see in the release notes here

The item you'll be interested in is:

Fixed: In drag-and-drop interactions, drag items might return to their original positions during quiz review or be hidden by other objects.

Just launch the Articulate 360 desktop app on your computer and click the Update button for Storyline 360. Details here.

Please let us know if you have any questions, either here or by reaching out to our Support Engineers directly.

Amy Nicholson

Greetings - 

I have this same issue, but with Storyline 2. It especially happens when the user clicks the back button to review the previous question, one or more answer choices will be gone. Also, the visited state of the correct answer choice contains a checkmark, but on review (on some items, seems random) the checkmark is on the bottom layer. Some answer choices are missing initially as well. Very simple interactions, but I have used the select one template and shuffle answers.  Thank you for any suggestions. 

Leslie McKerchie

Oh no Amy!

Sorry to hear that you're having a similar issue with your Storyline 2 course.

When you hit the back button and return to a question slide, the slide is probably in Review mode. This is why you're seeing the checkmark, but does not explain the missing items.

If your expectation is for the user to move back and forth and perhaps change answers, I would consider using the Submit All feature explained here.

If you still want us to take a look, please feel free to share your .story file and point us to a problematic slide :)