Audio/video stop playing in published file but seekbar continues

Hello,

I wrapped a video (mp4) in a SL360 file. The SL preview works fine. However, the published version stops (video and audio) 3/4 of the way through, yet the seekbar keeps moving forward. I clicked all over the seekbar but the video stays on the same slide. The timeline is only set to the same amount of time as the video. How do I fix this issue?

5 Replies
Ashley Terwilliger

Hi Reyna, 

I'd love to take a look at your .story file to help troubleshoot what's happening. Can you share it with us here in the E-Learning Heroes Community, or if you'd prefer to share privately you can upload it to our Support Team here. Some additional questions to help us investigate: 

  • Does the video/audio stop where you'd expect it to - or is it stopping early? 
  • When you're testing the published output did you upload to an LMS, web server, or are you testing it locally from the "Published Output" folder?
  • If it's uploaded to an LMS or server, what browser are you using to play it back?

Let us know if you can share the .story file (the file prior to publishing) and we'll dig into it for testing! 

Joseph Stehman

Hello! 

I am experiencing something very similar. However, my video/audio is pausing about a 1/3 of the way through. Like Reyna's my seekbar continues to progress. 

I have tried creating a new slide, deleting and uploading the video, changed the triggers, and nothing seems to fix or improve it. 

Again, like Reyna, my video only does then when publishing either to LMS or to Review. The mp4 video file alone plays without issue. Also, when I preview the slide within Storyline, I don't have any issues with the video playing through to the end. 

Thanks for any help that you can provide. 

Joseph 

Lauren Connelly

Hi Joseph!

Thank you for sharing these details with us! It looks like Reyna reached out to our Support Engineers and worked with my teammate, Cleo. 

Cleo said "If MP4 videos don't display when your Articulate content is hosted on a server, it's likely that the server isn't configured to play MP4 files. See this article for more information.

If this doesn't do the trick, I'd recommend connecting with a Support Engineer.

Brad King

Is there any resolution or update to this?

I have the same issue - a slide with a mp4 (20 min) and around 17 minutes the audio AND video stops but the seekbar continues.  This only happens when published...the course plays fine in preview.  The MP4 is also complete and has no issues playing on its own.

I've reimported the MP4, started a brand new SL from scratch and imported video, adjusted timelines, triggers, etc.  nothing works and the video and audio always stops.

HOWEVER, What I did find....
If I turn the seekbar off and use the video controls, the MP4 plays the entire way through with no issue.  Obviously this is an okay workaround by putting a hotspot over the controls o preventing skipping, but this is pointing to bigger issues with the timeline.

I can also say this is something new that has been happening within the last month or so with several 360 users in our training department when using videos in courses....