bug in storyline 360 - June 1st update

Hi everyone,

I think I noticed a bug in Storyline 360 after the last update: I opened a course to edit some details, and after output noticed that a drag and drop interaction is having an odd behaviour. The drag and drop options were set to "Tile" in previous versions of Storyline, and it worked perfectly. After the last update, the interaction does not seem to work anymore: after I click on the shape to be dragged and dropped, it does not "release" on mouse leave, and if I click, it starts to move randomly on the screen.

I uploaded a quick Peek video so you can see what is going on (it's preview mode, but in output the result is the same).

https://360.articulate.com/review/content/2f54460f-c92e-48a2-b370-3934a2fabf59/review

After I set the drag and drop option to "Free", the interaction seems to become fully functional again.

Someone else is experiencing this behaviour? Articulate guys, can you please check it? This appears to be a nasty bug because it messed up the interaction without me modifying anything (just updating Storyline 360), and so it could affect negatively a course without "notice".

Thank you!

6 Replies
Alyssa Gomez

Hi there Dario,

Thanks so much for those details, and the Peek recording was really helpful! I've tried to recreate this issue in Storyline 360, but I'm not seeing the same thing you're seeing in a drag-and-drop interaction with the "tile" setting.

Can you share your project file with me?  If you'd like to keep it private, use this form instead.

 

Dario Dabbicco

I can provide more detail with the .story file I submitted for case 01085574: I can see the issue in slides 1.16 e 1.25. Hope this makes the job simpler to you, since it's not a short course.

By the way, Juliet, did you experience exactly the same issue submitted by me? Can you confirm that it appeared with the last update of SL 360?

Alyssa Gomez

Thanks for sharing your case number, Dario! Also, thanks for chiming in to this discussion, Juliet. 

I looked into Juliet's case, and it seems that there's an issue in HTML5 where grouped objects set as drag items do not drop correctly when 1 of the items on the group has a hover state. We're tackling this bug, and we'll be sure to post an update in this thread as soon as we get more information.

As a workaround for now, delete the hover state of the grouped drag item, and that should fix the issue. 

Dario, I've got your file open and I'm going to send you a reply through your case shortly. Be on the lookout for an email from Support@Articulate.com!

Alyssa Gomez

Hey folks! We just released another update for Articulate 360, and included a few important fixes and new features that you'll see in the release notes here.

We had talked about how a drag item wouldn't always drop on a target in HTML5 output unless you clicked your mouse to release it.  That issue has been addressed!

Just launch the Articulate 360 desktop app on your computer and click the Update button for each application.

Let me know if you have any questions, or feel free to reach out to our support team!