Can no longer turn the video compression off with new Storyline 3 update...

I recently uploaded the most recent Storyline 3 updates. My published projects are now playing better within the browsers. However, now the customization setting is defauted to 'automatic'. In the past, I had to set this setting to 'none' because my videos would have a better quality when played within their published HTML5 format. Although I understand that Storyline does not like for people to control this setting, it is very inconvenient for it to still be there and for me to not have the option to turn it off. My videos have already been compressed prior to inserting them into my project. Compressing them again causes them to appear grainy and unfocuses. Please help!

44 Replies
Ashley Terwilliger-Pollard

Hi Jackie,

Automatic will be the default setting, but you can still adjust the compression altogether for MP4 videos created with baseline, main, or high profiles. (All other videos will be compressed automatically.)

  1. Select the video placeholder and go to the Options tab on the Storyline ribbon.
  2. Click the Compression drop-down list and choose None.

If you turn off video compression, be aware that your published files will be larger, which could be problematic for learners with slow internet connections.

Let me know if you need anything else! 

Carl Boyd

Hey! It's great that there's a way to turn this off, but on all my videos, it's set to automatic, and greyed out - I can't change it :(

I found an explanation why...
https://articulate.com/support/article/the-option-for-uncompressed-video-is-grayed-out-sl2

...but that seems like something that should have been resolved in current 360. Is it?



Jasmin Fritsch

If I load a video onto my slide, I can turn of the compression.

But if I choose to replace that video (via right click), the option will be greyed out afterwards.

The only workaround I could figure out was to delete the video an import it again.
So replacing multiple videos always has been a hassle, because all options like size, position on the slide, position on the timeline, compression and so on all have to be set AGAIN.

Ashley Terwilliger-Pollard

Hi Kat,

Those are video profiles when using an MP4. Do you have anyone in-house who can help you check or convert your videos? Often when I've run into videos that don't show the uncompressed option, re-encoding them with a tool like HandBrake, a free video editor, typically rights the ship!

Let us know if you get stuck - and we'd be happy to take a look at your video! 

Sharon Bildstein

I had to do an update this week in the middle of a project because I was unable to sign into Storyline 360.  Now I'm unable to change compression to No on one of my video slides.  It has a much different look than the other videos in the same file.  Very frustrating and disappointing that what I'll have to show to the client has visual quality issues for one section of the course.

Leslie McKerchie

Hi Sharon,

Thanks for letting us know that you've run into an issue with video compression.

Storyline supports uncompressed MP4 videos in the published output. This applies to the three most common MP4 profiles: baseline, main, and high.

If the Compression property is grayed out, it means your video was created with a different profile or it has been edited with Storyline's built-in video editor.

Sharon Bildstein

Thank you for the reply and details of MP4 profile requirements of baseline, main, high. However, I’ve chatted with a few people and I/they are not familiar with what that means. Could you please provide some further clarification on what baseline, main and high mean?

Thank you,
Sharon

Sharon Bildstein
Sr. Instructional Designer
Multimedia and Learning Technologies Program
Office of Nursing Professional Practice
(667) 208-7365

Lauren Connelly

Hi Sharon, and thanks Gerry for stepping in!

We optimized video compression in Storyline 3 so you get the highest possible quality at the lowest possible file size. This setting makes for a quicker import to an LMS, website, or any other published output.

We recommend using high quality videos and letting Storyline handle the compression. However, you can turn off compression for MP4 videos if you'd prefer. 

Dale de Silva

If you’re wondering about the video codec, the dev team’s responses are a bit cryptic. Baseline, Main, and High are like versions of the h.264 codec that support different things.
But there doesn’t seem to be many others (Adobe Media Encoder) or in most cases any others (Handbrake). But regardless, anything else is non-standard - so when the dev’s say SL supports anything in using those 3 profiles, you can pretty much interpret that to mean SL supports any mp4 with the h.264 codec - especially of you've chosen any existing preset in a video conversion program.

So codec isn’t likely the issue. In my file I have the same issue as others and I’ve done a bunch of testing that I'll outline below.

Setup:
I have an existing Storyline project file in which the video compression options are greyed out and stuck on auto. This is an issue not only because it’s recompressing my videos and thus lowering their quality, but also because there are 4 videos in the project… so instead of taking one minute to export each time, it takes 30 minutes. Every time.

It’s not the codec:
Using one of the same video files, I created a new Storyline project and imported it again. It didn’t have the error (I could change the compression options).

Therefore, I now have…

The Existing SL file: Video compression options greyed out and stuck on automatic.
The new SL file: Video file allows for adjusting compression options.

Both using the same video file - thus, it’s not the codec.

Following that, here’s everything I tried after - but I found no solution.
FYI: I’m using Storyline 360 v3.30.19518.0

What I tried in the existing SL file that didn’t work...

  • Replacing the video
  • Importing the video again on the same slide
  • Starting a new blank slide and importing the video again
  • Deleting the video and reimporting
  • Deleting all videos before attempting to re-import one.
  • Deleting all videos, saving, closing storyline and reopening file before re-import the video again.
  • Going to publish settings, and in every tab clicking on on “Quality” and setting all video compression to standard.
  • In the player settings, changing the Player Style to Classic and in Other, trying both “Lock player at optimal size” and “Scale player to fill browser window”, 
  • In the player settings, changing the Player Style to Modern.
  • Saving the player settings from a file without the error and and applying them to a file with the error.
  • I also tried doing each of the above one at a time and closing the file and re opening.

What I tried that partially worked...

I also tried saving the file as a template file

  • When double clicking the template file…
    • I select all files and import, a new document is created automatically and this still has the same issue (compression options greyed out and stuck on auto).
  • When starting a new file manually…
    • If I immediately create a new slide from the template slide that has the video on it, it still has the same issue.
  • BUT...When starting a new file manually…
    • If I import the video file manually, the issue ISN’T present, then if I create a new slide based of the template slide with the video on it, it too DOESN’T have the error.
    • This isn’t much of a solution because it still requires recreating the rest of the project (so depends on your project). It’s included here in case it can help anyone or help the SL devs fix this issue.

Note: I tried this the other way around too. Ie. I saved the version WITHOUT an error as a template. Then I opened the file WITH the error and created a new slide using the error free template, but it unfortunately adopted the error too. Also tried using import and this didn’t work either.

Good luck everyone.

David Sweeney

I am exporting Vyond animations to Storyline 360.  All exported MP4s were successfully imported into Storyline 360 slides with the option to disable compression active

I then needed to make a small edit to the Vyond animation.  

For these new video, exported in exactly the same way, the "None" option with respect to video compression is not available.  This is the case when I try to replace the existing video (the preferred option) or if I delete the rev 1 and import the rev 2.  No "None" option.  

Like Dale above, if I create a new Storyline file and import the rev 2 video, i.e. the same video as above, I have the option to apply "None" for video compression

To get past this issue, I added a new slide to the original storyline file and imported the new video and was given the option to disable compression.  I then cut and pasted it into the original slide.  Not ideal but how I got around this bug.  

 

 

John Wylie

I have been running into  this very often , where I import a video to the slide , change the compression to none , later if I have to replace the video with a revised file , the option of none is no longer there. It is set to Automatic and greyed out.

I even tested it with importing a mp4 to the slide , saving the project , choosing to replace the file and using the same exact file that is already there, and the drop down to select NONE is not available, it is set to Automatic and greyed out.

Work around:

What I do is delete the video file from the slide , save & close the project , close Storyline 360 , delete the Storyline folder from my Temp directory. Re-open the project , insert the video onto the slide , and I can now select the option for Compression to NONE.

A royal pain, and I hope it gets fixed soon.


Gwen Tanner

Thank you John!  This worked.  Nothing that the Articulate support told me helped.  They sent me the list of profiles, and asked if I edited the video in Storyline - which wasn't helpful. Eventually, support gave me 'steps' to follow, which is basically reinstalling Storyline.  Again, not helpful.  I hope they understand that there IS a problem here, its not just us not using the "right profile".

The first time I tried inserting a new slide and importing the same video I was able to change compression to "None"  I thought that would be the end of it....but a few days later, and I'm stuck with "None" grayed out.

I tried your work around and it works (at least for now) :)  I was so close to just redoing the whole course in a new file!   

 

Stephanie Curry

This is definitely a problem! My videos are h264 high. When I start a new storyline file, they go in with no issues and I can change the auto compression setting to none. However, in the preExisting course I'm editing this is NOT working this way. Compression is greyed out and isn't an option. This is the SAME video, different SL file. So, it's not the videos fault. This is even an issue when I add a new slide and import the video again. Still no compression option. 

 

Sharon Bildstein

Thank you for the thoughts on how to deal with this! Yes, it's still a problem, experiencing the same issue with a completely different project that also involves Vyond video. I'm not sure how to clear out my Temp files, but I will figure it out and see if that helps.
In the past I've had to set up a new slide and transfer all the objects and reimport the video in order to access the compression control. Your solution would be much quicker! Thanks for sharing your experience!

Stephanie Curry

I did not try that. I imported the slides from the storyline file that is working into the existing project that isn't working. I figured out that the compression switched to auto if the file is edited in SL. Which was mentioned earlier in the thread. So... a good thing to keep in mind. Dont use SL video editor. 

Veronika Domorakova

Hi all,

I would like to also express my disappointment from this ongoing issue and add, that what I find very frustrating, is the fact that videos recorded using Storyline have the compression option greyed out as default! I would expect that at least you can choose not to compress videos recorded directly using SL 360 without the need to make any super complicated amendments as described below. Not sure how to fix this to be honest, since the option is greyed out from the very beginning. Any thoughts?

Thanks

Veronika

Carrie Wass

Your post saved me so much time and frustration!

I had imported 4 videos to Storyline for animation that I had recorded in Replay. Three of the four allowed me to change the compression setting but the fourth gave me issues. After reading your post, I opened up a new Storyline project, recreated the slide with the same video, and was able to change the settings with no problem.

This seems to be a glitch that may need some attention!